The Lost Depths DLC and Update 35 base game patch are now available to test on the PTS! Read the full patch notes here: https://forums.elderscrollsonline.com/en/categories/pts
Maintenance for the week of August 15:
• PC/Mac: No maintenance – August 15
• Xbox: NA and EU megaservers for maintenance – August 17, 6:00AM EDT (10:00 UTC) - 11:00AM EDT (15:00 UTC)
• PlayStation®: NA and EU megaservers for maintenance – August 17, 6:00AM EDT (10:00 UTC) - 11:00AM EDT (15:00 UTC)

FPS Problem

  • Jeth
    Jeth
    ✭✭✭
    Tick-tock....
    -Jeth
  • mistermacintosh
    mistermacintosh
    ✭✭✭
    agegarton wrote: »
    I can only suggest the everyone in this thread raises a ticket - I know it's not the answer, and I get that the lack of any response beyond "oh, OK then" is really not acceptable, but it's all I've got!

    @ZOS_GinaBruno @ZOS_JessicaFolsom I'm usually a fan, but this is a poor, poor effort.


    Edit: worth noting that a big part of the Murkmire patch was reversed out today - enchants and poisons proc-ing from DoTs - because the PVP community complained a lot on these forums. Essentially what years of playing this game has taught me is :-

    1. It'll get fixed right now if it involves Crowns.
    2. It'll get fixed soon if it involves PVP.
    3. Anything else? There's a long list and you're lucky if you even get an acknowledgement!

    Opening a ticket won't do anything. Customer service won't give you any info the devs haven't released as "official" fixes. I know this because I just finished a 12+ round email exchange with them that resulted in them telling me to watch for an incremental fix in the future... Go ahead and open them if you like, but don't expect anything to be resolved through that department.

    Also, it's worth remembering that the PVP community has had the worst overall support experience in ESO. If they're actually enjoying Cyrodiil right now, that's a good thing.
    Legalize Nirnroot!

    Mac User, NA Server (CP810+, PVE focused):
    Magicka Templar Ra the Everlasting (Level 50 - Main Character)
    Stamina Sorcerer Khazaka-ri (Level 50 - Crafter)
    Dragonknight Tank Skalda Flamewreath (Level 50)
    Pet Sorcerer Hellias Ocume (Level 50)
    Magicka Necromancer Socelon (Level 4)

    Templar Healer Mends-Through-Panic (Level 50)
    Stamina Nightblade Adanna-daro (Level 50)
    Stamina Warden Marely Sprigs (Level 50)
    Stamina Dragonknight Ursula Trollcalmer (Level 50)
    Stamina Necromancer Daengeval (Level 4)

    Stamina Templar Cornellus Graves (Level 50)
    Warden Healer Pays-For-Luxury (Level 50)
    Magicka Sorcerer Sophia Flash (Level 50)
    Magicka Dragonknight Cinvalo Aloavel (Level 50)
    Magicka Nightblade Esmerelda the Cruel (Level 50)
  • Thrawn75
    Thrawn75
    ✭✭
    Since there's no response at all, I suggest reaching out the top managers for a kind response. I'm not looking for a fix for tomorrow, just some statement on the matter and what do they think, if there's something that can fix the problem (even if that takes time), etc..

    Game Director -> Matt Firor: https://twitter.com/mattfiror
    Technical Director -> Dan Dunham: https://twitter.com/StrangeCoding

  • Montie
    Montie
    ✭✭✭
    Elder Scrolls Online has been mostly unplayable for 15 days on Macs.
    Last ZeniMax response to their game being in a mostly unplayable state was 8 days ago.

  • tunepunk
    tunepunk
    ✭✭✭✭
    Been playing around with UserSettings file but nothing has helped so far.

    Before Murkmire:
    I was getting pretty much constant 60fps with a few dips (capped by V-sync i think) with most settings on high.

    After Murkmire:
    Getting around 20fps in towns and around 40-60 fps in open areas (No Vsync on) Medium/Low settings, shadows off.
    Also seeing:
    * More frequent invisible monsters.
    * Have to click twice to enter password for login
    * Spinning Camera after update, and after weekly update.
    * Pixel filtering high. UI becomes blurry, but medium World is blurry but UI sharp.
    * Extreme stuttering and FPS as low as 3-5 occasionally, seems like it's when areas are loading.
    * Game getting even more laggy after a while so have to close and restart every now and then.
    * Sometimes game just freezes/unresponsive, so I have to close and restart. (No Crash dialog)
  • alterfenixeb17_ESO
    alterfenixeb17_ESO
    ✭✭✭
    Jeth wrote: »
    Tick-tock....
    Heh I miss Jack Bauer really.
    tunepunk wrote: »
    Been playing around with UserSettings file but nothing has helped so far.

    Before Murkmire:
    I was getting pretty much constant 60fps with a few dips (capped by V-sync i think) with most settings on high.

    After Murkmire:
    Getting around 20fps in towns and around 40-60 fps in open areas (No Vsync on) Medium/Low settings, shadows off.
    Also seeing:
    * More frequent invisible monsters.
    * Have to click twice to enter password for login
    * Spinning Camera after update, and after weekly update.
    * Pixel filtering high. UI becomes blurry, but medium World is blurry but UI sharp.
    * Extreme stuttering and FPS as low as 3-5 occasionally, seems like it's when areas are loading.
    * Game getting even more laggy after a while so have to close and restart every now and then.
    * Sometimes game just freezes/unresponsive, so I have to close and restart. (No Crash dialog)
    Actually I have followed this thread: https://forums.elderscrollsonline.com/en/discussion/368986/mega-thread-eso-performance-tweaks-fps-improvements-stutter-free-graphics-tweaking

    It surely did not resolve all issues however on my GeForce 775 running in QHD & High Settings in low crowded areas I can get up to 40 fps (before it was 20) and on average 15 - 20. Not perfect but still made it playable. And on top of that before trying anything I have removed all contents of user data folder with an exception of addons and addon settings (so that i.e. shaders are recompiled).
  • tunepunk
    tunepunk
    ✭✭✭✭
    Just did some more tweaks... and got my FPS bumped up quite a bit... UserSettings.txt

    SET SIMPLE_SHADERS "1"

    and deleted the files:
    ShaderCache and PipelineCashe from the the ESO folder in Documents.

    Before this I had about 23 fps in Artaeum Ceporah Tower, now it was up to 45-55. Helped for me, maybe it will help for others too. Didn't notice any significant difference in quality of the shaders.

    Suspected it might be that the Vulkan didn't like the shaders so tried that setting. Seemed to help a bit, hopefully it would help for others too.
    Edited by tunepunk on 6 November 2018 14:15
  • Montie
    Montie
    ✭✭✭
    tunepunk wrote: »
    Just did some more tweaks... and got my FPS bumped up quite a bit... UserSettings.txt

    SET SIMPLE_SHADERS "1"

    and deleted the files:
    ShaderCache and PipelineCashe from the the ESO folder in Documents.

    Before this I had about 23 fps in Artaeum Ceporah Tower, now it was up to 45-55. Helped for me, maybe it will help for others too. Didn't notice any significant difference in quality of the shaders.

    Suspected it might be that the Vulkan didn't like the shaders so tried that setting. Seemed to help a bit, hopefully it would help for others too.

    Thanks, but it did not work for me. No change.
  • HowTaoBrownCow
    HowTaoBrownCow
    ✭✭✭
    tunepunk wrote: »
    Just did some more tweaks... and got my FPS bumped up quite a bit... UserSettings.txt

    SET SIMPLE_SHADERS "1"

    and deleted the files:
    ShaderCache and PipelineCashe from the the ESO folder in Documents.

    Didn't work for me either, I'm afraid. Same fps in the same places. I'd imagine, based on the differences between people's systems, that some of the tweaks people suggest trying might help some others, at least some of the time, so it's always worth the attempt. But no luck for mine so far.
    Censored
  • tunepunk
    tunepunk
    ✭✭✭✭
    @sean.montgomery_ESO Hmmm....

    I did have to restart twice though. After changing, no improvement, second restart FPS increased. Not sure why, but it helped here after restarting two times. Maybe the shader cache is rebuilt on first restart, but takes effect on next.. not sure.

    Game runs way better after changing that settings.

    On a second not i did also fiddle with:
    SET COLOR_CORRECTION "0"
    setting it to "0" but i doubt that was the thing that did it.
  • Thrawn75
    Thrawn75
    ✭✭
    The SIMPLE_SHADERs tweak does NOT work for me either.

    My Mac specs are quite good:
    - iMac Retina 5K 27-inch 2017
    - 4,2 Ghz i7
    - 32GB
    - Radeon Pro 580 8GB
    - 512 GB SSD

    And I can't play ESO unless I drop the quality settings to Low.

    Absurd. I'm giving it a week more - if I can't play it anymore, I'm removing any trace of ESO and forget about this franchise forever.
  • tunepunk
    tunepunk
    ✭✭✭✭
    Travelled and Tested a few other areas where my FPS been extremely low. SIMPLE_SHADER only seem to improve in some areas, but not that much in other. Rawl'kha was still terrible. around 35 fps. Maybe only a few FPS better with the tweak. Dungeons and indoor areas generally got a bit better, but cities were still quite low FPS.

    Well... well... I think i tweaked it so it's quite playable now, but still not good enough... compared to pre Murkmire.
  • JJBoomer
    JJBoomer
    ✭✭✭✭✭
    tunepunk wrote: »
    Travelled and Tested a few other areas where my FPS been extremely low. SIMPLE_SHADER only seem to improve in some areas, but not that much in other. Rawl'kha was still terrible. around 35 fps. Maybe only a few FPS better with the tweak. Dungeons and indoor areas generally got a bit better, but cities were still quite low FPS.

    Well... well... I think i tweaked it so it's quite playable now, but still not good enough... compared to pre Murkmire.

    do keep in mind that this is not an actual fix for what is clearly broke by murkmire. And I don't want them thinking that changing a single text file is an acceptable course of action for all of us. we don't need tweaks, we need actual fix to the client. and posting user tweaks is just going to make an actual fix take even longer. because if we can tweak, why should they have to fix anything?
    Edited by JJBoomer on 6 November 2018 15:53
  • zarnon_akoni
    zarnon_akoni
    ✭✭
    @ZOS_AlexTardif thanks for finally making an update. This should probably be more clearly posted vs. buried under a long thread. Please be more proactive about communicating. Now is the time to reinforcing support for the platform, not being silent. This change should not have been a surprise and you should have been better prepared for a mess. I can only imagine what first impressions you are giving to brand new mac customers.
  • Carmina
    Carmina
    ✭✭✭
    @ZOS_AlexTardif Thank you very much for your post. The technical dilemma you guys are in surely is something people here can relate to. What was really frustrating is that no one posted here, and everyone thought that ZOS simply does not care.Now that we know what is going on, I think everyone can relax a little and lean back. Apple sure forced some quick reprogramming on you guys, and it is a huge deal to read that you are committed to the Mac and its users here.

    No one will blame you for technical problems, but people will feel lost if it seems like their problems are being ignored. So keeping the community updated here would be a really big thing.

    Thanks again :)

    C.
  • Evilspock
    Evilspock
    ✭✭✭
    JJBoomer wrote: »
    none of the tweaks in this thread worked for me. also please be careful with user tweaks, that gives ZOS less incentive to find an actual FIX if they see user tweaks being even somewhat successful. User tweaks is not a solution, don't encourage them or ZOS will consider the issue fixed without actually fixing anything.

    Graphics tweaks are misleading because there are too many random variables going on in game that affect performance. Sometimes I’ll have high fps and it’s easy to jump to a conclusion as to why, especialy if you just changed something. There is a problem with thier engine that isn’t going to be solved by any simple tweak of any user settings.
    EvilSpock |PC/NA|
    Guild: Vulcan Commandos |AD|
  • alterfenixeb17_ESO
    alterfenixeb17_ESO
    ✭✭✭
    tunepunk wrote: »
    Just did some more tweaks... and got my FPS bumped up quite a bit... UserSettings.txt

    SET SIMPLE_SHADERS "1"

    and deleted the files:
    ShaderCache and PipelineCashe from the the ESO folder in Documents.

    Before this I had about 23 fps in Artaeum Ceporah Tower, now it was up to 45-55. Helped for me, maybe it will help for others too. Didn't notice any significant difference in quality of the shaders.

    Suspected it might be that the Vulkan didn't like the shaders so tried that setting. Seemed to help a bit, hopefully it would help for others too.
    Yes, that was one of settings that I have changed. I have also changed HIGH_RESOLUTION_SHADOWS to 0. Also people experiencing object/terrain loading issues may be interested in playing with MIP_LOAD_SKIP_LEVELS and setting it to something lower than 0 if they haven't done it yet.
  • Jeth
    Jeth
    ✭✭✭
    Carmina wrote: »
    @ZOS_AlexTardif . . .
    No one will blame you for technical problems, but people will feel lost if it seems like their problems are being ignored. So keeping the community updated here would be a really big thing.

    Thanks again :)

    C.

    I do not believe that's the case at all. ZOS has had plenty of notice prior to Mojave, the game ran on Mojave just as it had on the day before Mojave. OpenGL isn't gone from Mojave and Apple all but didn't provide updates to OpenGL anyway. While I appreciate the update and the stones it took for Alex to come here and post, I certainly blame a "Graphics Engineer" for the 80% loss in performance and potentially not communicating it in patch notes before many people bought crowns and DLC with even more $$. This is well beyond a communications only issue. I don't see how any credibility remains.
    Edited by Jeth on 6 November 2018 20:43
    -Jeth
  • yacoob
    yacoob
    ✭✭
    which is something not available on Mac's (now-unsupported) OpenGL version

    Just to point out - OpenGL got deprecated on Mac, but it still works.That is, nothing has changed, and there's an expectation that it'll actually stop working in the future - but it works right now. Which means that everyone needs to switch eventually - but not right now this instance. If ZOS decided to switch at a particular patch, and it works poorly, that change should be rolled back, tested more, adjusted, and rolled out later. Unless something else, unrelated, was requiring this change, and the MacOS userbase was simply too small, to make a point strong enough for a more relaxed rollout rate.

    For the context: I'm a *very* new ESO player (4d in), and the performance I see on my Mac is similar to poorly made ports, shipping with a semi-customized Wine wrapper. I'm happy to hear that the performance *used* to be better (like properly made ports like LoL or WoW?), but I'd love for this performance to be something more than just a memory :D

    So, in short: can you please reconsider, roll back the changes (if there's nothing else hinged on it), and come back later with much smoother port? 😍
  • Jeth
    Jeth
    ✭✭✭
    Hi everyone,

    ...

    I sincerely applaud and thank you for having the chops to update us.

    /cheers

    -@JethroT
    -Jeth
  • Montie
    Montie
    ✭✭✭
    Hi everyone,

    We’ve been actively working non-stop on the Mac performance issue with the new API. It's one of our highest priority tasks, but it's a complicated issue that requires a large amount of reworking / testing and we’ve had to fast track a lot of this work due to OpenGL no longer being supported by Apple.

    As to why OpenGL isn't available as an option from here on out: we're introducing compute shader support for Mac devices through the new API, which is something not available on Mac's (now-unsupported) OpenGL version. This will allow us to use graphics hardware for things we couldn't before, like GPU particles.

    We do sincerely understand your frustration with the performance problems you're experiencing, but know that we’re working on this until it is resolved. As soon as it's fixed, it will be pushed in an incremental patch.

    Thank you for the response, it is appreciated. However, I do agree with others here, Apple did NOT remove OpenGL, in fact I was playing a game just last night that uses OpenGL. They DEPRECATED it. This should not have been released in this state.

    What's done is done. Now we have to wait for a fix. So, let's talk compensation. I have a 6 month sub that I paid for that I am not getting the full value of. What are you going to do about it? How are you going to make this right? What about the event tickets? I barely managed to get them for the last event, but what about the future ones where I may not be able to participate because your game, quite frankly, makes me sick to play more than the basic log on, do writs, log off.
    Edited by Montie on 7 November 2018 00:15
  • nathan_bri
    nathan_bri
    ✭✭✭✭
    Hi everyone,

    We’ve been actively working non-stop on the Mac performance issue with the new API. It's one of our highest priority tasks, but it's a complicated issue that requires a large amount of reworking / testing and we’ve had to fast track a lot of this work due to OpenGL no longer being supported by Apple.

    As to why OpenGL isn't available as an option from here on out: we're introducing compute shader support for Mac devices through the new API, which is something not available on Mac's (now-unsupported) OpenGL version. This will allow us to use graphics hardware for things we couldn't before, like GPU particles.

    We do sincerely understand your frustration with the performance problems you're experiencing, but know that we’re working on this until it is resolved. As soon as it's fixed, it will be pushed in an incremental patch.

    Just because OpenGL has been deprecated in Mojave does not mean it no longer works properly. It still runs just fine. It’s just that no NEW development should be done using it. Legacy code—like that in ESO—should continue to work fine for the foreseeable future. This should give you plenty of time, perhaps a year or more if needed, to roll back your implementation to the prior one and give users the option to toggle between new and old.
  • kenjitamura
    kenjitamura
    ✭✭
    nathan_bri wrote: »
    Hi everyone,

    We’ve been actively working non-stop on the Mac performance issue with the new API. It's one of our highest priority tasks, but it's a complicated issue that requires a large amount of reworking / testing and we’ve had to fast track a lot of this work due to OpenGL no longer being supported by Apple.

    As to why OpenGL isn't available as an option from here on out: we're introducing compute shader support for Mac devices through the new API, which is something not available on Mac's (now-unsupported) OpenGL version. This will allow us to use graphics hardware for things we couldn't before, like GPU particles.

    We do sincerely understand your frustration with the performance problems you're experiencing, but know that we’re working on this until it is resolved. As soon as it's fixed, it will be pushed in an incremental patch.

    Just because OpenGL has been deprecated in Mojave does not mean it no longer works properly. It still runs just fine. It’s just that no NEW development should be done using it. Legacy code—like that in ESO—should continue to work fine for the foreseeable future. This should give you plenty of time, perhaps a year or more if needed, to roll back your implementation to the prior one and give users the option to toggle between new and old.

    Not saying what they did is right but at this point they had probably been exclusively building all of the Mac Murkmire patches against the new MoltenVK code base for weeks or months in advance and tweaking them specifically for MoltenVK. If they did it that way then the old OpenGL codebase had neglected to receive any Murkmire patches and that would require just as much, if not more, time and developer resources to bring it up to speed.

    Not a software developer myself but from the sound of things it would seem code for video games isn't modular and can't just be shuffled around between rendering implementations 100%. If I had to use an analogy it sounds like it requires gum and duct tape to get an implementation to work correctly on top of what is reusable between clients.

    A game like World of Warcraft will have the cash flow to do what they do which is to massively overhaul large parts of their game engine nearly every expansion and amounts to almost a rewrite of the engine every time. But then you have the less fortunate games like Rift which are using a Frankenstein client that amounts to just piling more and more minor patches on top of what is essentially the same tech they started developing with in 2006.

    And then you have ESO in between which has opted to do fairly large revisions every so often but sacrifices backwards compatibility by deprecating their own older implementations. This way they're not dedicating developer resources towards trying to keep the codebases synced on content with their own quirky workarounds.

    It's not always a user friendly approach. I was one of the people playing this game on Linux by using the Windows OpenGL implementation before they switched to DX11 and completely borked it for Linux. Linux users weren't the only ones left out in the cold however as they had a not insignificant user base that was either on unsupported hardware or using an older Windows version that didn't support DX11.
  • Carmina
    Carmina
    ✭✭✭
    nathan_bri wrote: »
    Hi everyone,

    We’ve been actively working non-stop on the Mac performance issue with the new API. It's one of our highest priority tasks, but it's a complicated issue that requires a large amount of reworking / testing and we’ve had to fast track a lot of this work due to OpenGL no longer being supported by Apple.

    As to why OpenGL isn't available as an option from here on out: we're introducing compute shader support for Mac devices through the new API, which is something not available on Mac's (now-unsupported) OpenGL version. This will allow us to use graphics hardware for things we couldn't before, like GPU particles.

    We do sincerely understand your frustration with the performance problems you're experiencing, but know that we’re working on this until it is resolved. As soon as it's fixed, it will be pushed in an incremental patch.

    Just because OpenGL has been deprecated in Mojave does not mean it no longer works properly. It still runs just fine. It’s just that no NEW development should be done using it. Legacy code—like that in ESO—should continue to work fine for the foreseeable future. This should give you plenty of time, perhaps a year or more if needed, to roll back your implementation to the prior one and give users the option to toggle between new and old.

    ...

    It's not always a user friendly approach. I was one of the people playing this game on Linux by using the Windows OpenGL implementation before they switched to DX11 and completely borked it for Linux. Linux users weren't the only ones left out in the cold however as they had a not insignificant user base that was either on unsupported hardware or using an older Windows version that didn't support DX11.

    This. Murkmire is a huge patch, and at one point ZOS needed to make the switch to the new renderer. What Alex wrote was that they are using new functions of Metal which they could not use before. So it seems that this switch, which was thrown at us just now, has been in the planning for quite some time. It is not like ZOS decided to change this within 10 days, because that is not possible. So, sticking with OpenGL at this point probably seemed like a bad idea.

    Not talking to the community was the most urgent thing for us. They working on the fix is as urgent, and they said they do. So if the next step is some kind of reparation, that is another topic. Let's just hope they will tell us what is going on, and go from there.

    Communication seems to be a huge problem here, and even if ZOS might not want to embarrass their partner Apple, they still need to understand that keeping people in the dark when there is a thread on fire like this is not a smart idea.

    C.
  • Wodinn
    Wodinn
    ✭✭✭
    I have a slight dilema. I no longer have the Usersettings.txt file. How do I get that back again? Do I have to do a full DL from the website?
  • Puodas
    Puodas
    ✭✭
    Wodinn wrote: »
    I have a slight dilema. I no longer have the Usersettings.txt file. How do I get that back again? Do I have to do a full DL from the website?

    Just run the game and it will be re-created.
    Edited by Puodas on 7 November 2018 18:16
Sign In or Register to comment.