Maintenance for the week of April 3:
• PC/Mac: No NA megaserver maintenance – April 3
• PC/Mac: EU megaserver for maintenance – April 3, 8:00PM EDT (April 4, 00:00 UTC) – April 4, 10:00AM EDT (14:00 UTC)

UI-error when try to preview a set item via text chat in gamepad mode

Hey, since the newest update from Monday I recieve an UI-error when try to view a linked set item in chat box while being in gamepad mode (see Screenshot). Without gamepad mode it works but it is rather annoying to turn it off and on every time. Yes, I also tried turning off/uninstall all addons etc. Still getting this error.

  • clark71822
    Soul Shriven
    I'm getting the same thing, but also affecting the mail system as well. This occurs with or without addons enabled. This is on PC NA btw. I've included the full text of the error with the More Info option checked (this is from the gamepad chat interface):
    Checking type on argument equipped failed in GetItemLinkSetBonusInfo_lua
    stack traceback:
    [C]: in function 'GetItemLinkSetBonusInfo'
    /EsoUI/PublicAllIngames/Tooltip/ItemTooltips.lua:544: in function 'ZO_Tooltip:AddSet'
    |caaaaaa<Locals> self = ud, itemLink = "|H0:item:172121:362:50:0:0:0:0...", equipped = "UI_SHORTCUT_SECONDARY", hasSet = T, setName = "Deadlands Assassin", numBonuses = 5, numNormalEquipped = 0, maxEquipped = 5, setId = 580, numPerfectedEquipped = 0, totalEquipped = 0, isPerfectedSet = F, setSection = ud, bonusIndex = 1 </Locals>|r
    /EsoUI/PublicAllIngames/Tooltip/ItemTooltips.lua:774: in function 'ZO_Tooltip:LayoutGenericItem'
    |caaaaaa<Locals> self = ud, itemLink = "|H0:item:172121:362:50:0:0:0:0...", equipped = "UI_SHORTCUT_SECONDARY" </Locals>|r
    /EsoUI/PublicAllIngames/Tooltip/ItemTooltips.lua:1578: in function 'ZO_Tooltip:LayoutItem'
    |caaaaaa<Locals> self = ud, itemLink = "|H0:item:172121:362:50:0:0:0:0...", equipped = "UI_SHORTCUT_SECONDARY", isValidItemLink = T, itemType = 2 </Locals>|r
    user:/AddOns/VotansFishFillet/VotansFishFillet100015.lua:386: in function 'newMethod'
    |caaaaaa<Locals> self = ud </Locals>|r
    user:/AddOns/BetterUI/Modules/GeneralInterface/Tooltips.lua:166: in function 'handlerFunction'
    |caaaaaa<Locals> self = ud </Locals>|r
    /EsoUI/Libraries/ZO_Tooltip/ZO_Tooltip.lua:1206: in function 'ZO_Tooltip:LayoutLink'
    |caaaaaa<Locals> self = ud, link = "|H0:item:172121:362:50:0:0:0:0...", linkType = 1, handlerKey = "LayoutItem", handlerFunction = user:/AddOns/BetterUI/Modules/GeneralInterface/Tooltips.lua:158 </Locals>|r
    /EsoUI/Common/ZO_Tooltip/Gamepad/ZO_Tooltip_Gamepad.lua:21: in function 'LayoutFunction'
    |caaaaaa<Locals> self = [table:1]{currentLayoutFunctionName = "LayoutLink"}, tooltipType = "GAMEPAD_RIGHT_TOOLTIP", tooltipContainer = ud, tooltipContainerTip = ud, tooltipFunction = /EsoUI/Libraries/ZO_Tooltip/ZO_Tooltip.lua:1201, tooltipInfo = [table:2]{autoShowBg = T, scrollIndicatorSide = 2, resetScroll = T, defaultAutoShowBg = T, bgType = 1} </Locals>|r
    /EsoUI/Libraries/ZO_GamepadLinks/ZO_GamepadLinks.lua:284: in function 'ZO_GamepadLinks:Show'
    |caaaaaa<Locals> self = [table:3]{gamepadTooltip = "GAMEPAD_RIGHT_TOOLTIP", currentLinkIndex = 1}, linkData = [table:4]{link = "|H0:item:172121:362:50:0:0:0:0...", linkType = "item"}, link = "|H0:item:172121:362:50:0:0:0:0...", useKeybindDescriptor = [table:5]{order = 10, keybind = "UI_SHORTCUT_SECONDARY", alignment = 3}, actionName = "UI_SHORTCUT_SECONDARY" </Locals>|r
    /EsoUI/Ingame/ChatSystem/Gamepad/ChatMenu_Gamepad.lua:450: in function 'ZO_ChatMenu_Gamepad:RefreshTooltip'
    |caaaaaa<Locals> self = [table:6]{dirty = F, nextMessageId = 84, activateOnShow = T, updateCooldownMS = 0, selectedChannelText = "Elder Scrubs United: ", addListTriggerKeybinds = F, initialized = T}, currentTargetData = [table:7]{numIcons = 0, alphaChangeOnSelection = F, text = "|H1:channel:Elder Scrubs Unite...", fontScaleOnSelection = F, showBarEvenWhenUnselected = T, enabled = T, subLabelTemplate = "ZO_GamepadMenuEntrySubLabelTem..."}, links = [table:8]{} </Locals>|r
    /EsoUI/Ingame/ChatSystem/Gamepad/ChatMenu_Gamepad.lua:307: in function 'ZO_ChatMenu_Gamepad:OnChatEntryPanelActivated'
    |caaaaaa<Locals> self = [table:6] </Locals>|r
    /EsoUI/Ingame/ChatSystem/Gamepad/InteractiveChatLog_Gamepad.lua:105: in function 'ChatEntryPanelActivateCallback'
    /EsoUI/Libraries/ZO_Focus/Gamepad/ZO_GamepadMultiFocusAreaManager.lua:60: in function 'ZO_GamepadMultiFocusArea_Base:Activate'
    |caaaaaa<Locals> self = [table:9]{active = T} </Locals>|r
    /EsoUI/Libraries/ZO_Focus/Gamepad/ZO_GamepadMultiFocusAreaManager.lua:186: in function 'ZO_GamepadMultiFocusArea_Manager:SelectFocusArea'
    |caaaaaa<Locals> self = [table:6], focusArea = [table:9], hasActiveFocus = T </Locals>|r
    /EsoUI/Libraries/ZO_Focus/Gamepad/ZO_GamepadMultiFocusAreaManager.lua:106: in function 'ZO_GamepadMultiFocusArea_Base:HandleMovePrevious'
    |caaaaaa<Locals> self = [table:10]{active = F}, consumed = F, selectableFocus = [table:9] </Locals>|r
    /EsoUI/Ingame/ChatSystem/Gamepad/InteractiveChatLog_Gamepad.lua:168: in function 'ZO_InteractiveChatLog_Gamepad:UpdateDirectionalInput'
    |caaaaaa<Locals> self = [table:6], result = 2 </Locals>|r
    /EsoUI/Libraries/ZO_DirectionalInput/ZO_DirectionalInput.lua:166: in function 'DirectionalInput:OnUpdate'
    |caaaaaa<Locals> self = [table:11]{lastUpdateS = 2733.474609375, updating = T}, deltaS = 0.020751953125, nowS = 2733.474609375, index = 4, inputObject = [table:6] </Locals>|r
    /EsoUI/Libraries/ZO_DirectionalInput/ZO_DirectionalInput.lua:57: in function '(anonymous)'
    Edited by clark71822 on December 25, 2022 6:32PM
  • Razdam
    Soul Shriven
    Same here. I disabled all my addons and still get this bug every time I check mail.

    Checking type on argument equipped failed in GetItemLinkSetBonusInfo_lua
    stack traceback:
    [C]: in function 'GetItemLinkSetBonusInfo'
    /EsoUI/PublicAllIngames/Tooltip/ItemTooltips.lua:544: in function 'ZO_Tooltip:AddSet'
    /EsoUI/PublicAllIngames/Tooltip/ItemTooltips.lua:774: in function 'ZO_Tooltip:LayoutGenericItem'
    /EsoUI/PublicAllIngames/Tooltip/ItemTooltips.lua:1578: in function 'ZO_Tooltip:LayoutItem'
    /EsoUI/Libraries/ZO_Tooltip/ZO_Tooltip.lua:1206: in function 'ZO_Tooltip:LayoutLink'
    /EsoUI/Common/ZO_Tooltip/Gamepad/ZO_Tooltip_Gamepad.lua:21: in function 'LayoutFunction'
    /EsoUI/Libraries/ZO_GamepadLinks/ZO_GamepadLinks.lua:284: in function 'ZO_GamepadLinks:Show'
    /EsoUI/Ingame/Mail/Gamepad/MailInbox_Gamepad.lua:844: in function 'ZO_MailInbox_Gamepad:UpdateLinks'
    /EsoUI/Ingame/Mail/Gamepad/MailInbox_Gamepad.lua:819: in function 'ZO_MailInbox_Gamepad:ShowMailItem'
    /EsoUI/Ingame/Mail/Gamepad/MailInbox_Gamepad.lua:382: in function 'OnMailReadable'
  • thechiefisback
    Is that a known bug? Seems to happen since the last update on 19th december and only in gamepad mode.
  • Thecompton73
    I'm having the same problem with mail. I've uninstalled and reinstalled but the issue persists.
  • React
    I'm also having this bug as of this patch, using an xbox controller on PC. Disabling addons did not fix the issue.
    @ReactSlower - PC/NA - 2000+ CP
    React Faster - XB/NA - 1500+ CP
  • Vampryss
    I'm also having this issue. Looks like there are a couple threads about this.
    The links below are from checking mail. Mother's Sorrow item sold.


Sign In or Register to comment.