Maintenance for the week of November 27:
· [EXTENDED] NA megaservers for maintenance – November 28, 4:00AM EST (9:00 UTC) - 6:00PM EST (23:00 UTC)
· [EXTENDED] EU megaservers for maintenance – November 28, 9:00 UTC (4:00AM EST) - 23:00 UTC (6:00PM EST)

Official Discussion Thread for "Receive Special In-Game Items & Collectibles with Amazon Prime"

  • valenwood_vegan
    I always have so much trouble with these - I've eventually received the past ones after randomly unlinking and relinking the accounts every couple of days for a week or two (each time I think about it and realize it hasn't showed up yet, lol). Looks like it'll be the same for this new one. I greatly appreciate the free stuff, but I do wish it worked more reliably!
  • Lixiviant
    Having the same problem. Guess I'll try the ole link/unlink trick again and hope for the best. :'(
    PS4/PS5/NA - And sometimes EU

    Daedroth might bite, just letting you know
  • Arato
    Elsonso wrote: »

    same issue here, keep trying but getting same problem.
    I claimed an item for Guild Wars 2 just fine right after, tried the horse again.. no dice
    So it's specifically that offer not an amazon error.
  • ZOS_Kevin
    Community Manager
    Hi All, we are following up with Prime Gaming about the issue it seems like some of you are having. For now while we try to figure this out, pleaser make sure to follow up with Prime Gaming Customer Service. You should be able to follow up here. That way, we can make sure they have reports of this issue as well.
    Community Manager for ZeniMax Online Studio and Elder Scrolls OnlineDev Tracker | Service Alerts | ESO Twitter
    Staff Post
  • Danyael
    Soul Shriven
    Had problems too and tried to link/unlink Amazon account. Not sure what is the actual magic sequence but got the redeem confirmation email as soon as I logged into the ESO account after browsing this thread, So logging out and staying that way for a few minutes may be important.
  • Elsonso
    @ZOS_Kevin I was able to claim it, so whatever was plugging up the pipes must have gotten cleared.
    PC NA/EU: @Elsonso
    XBox NA: @ElsonsoJannus
    X/Twitter: ElsonsoJannus
  • Lixiviant
    So everyone, I simply went to my Prime Gaming account and linked the account. Yes, it was already linked but doing this again fixed it.
    PS4/PS5/NA - And sometimes EU

    Daedroth might bite, just letting you know
  • Ashryn
    I guess it does take time. Mine finally arrived after most of the day expired.
Sign In or Register to comment.