Maintenance for the week of February 24:
• [COMPLETE] PC/Mac: NA and EU megaservers for patch maintenance – February 24, 2:00AM EST (7:00 UTC) - 12:00PM EST (17:00 UTC)
• ESO Website for maintenance – February 25, 8:00AM EST (13:00 UTC) - 10:00AM EST (15:00 UTC)

Mac Client - "Main Priority" according customer support

Kiljaz
Kiljaz
✭✭✭
For 5 months I've been hearing that fixing the mac client is the top priority for ZoS by their CS reps. After trying everything they've advised and seeing no improvement, plus five months elapsing without any fix, I've come to the conclusion that they really don't want mac user's subscriptions.

I'd love to play this game, but it's more annoying than fun in AvA.

#1 cause of death is client crash...
  • KhajitFurTrader
    KhajitFurTrader
    Community-Botschafter
    1. As @Moonraker has stated time and time again in this section of the forums, technical fixes specific to a particular platform are not normally put into the patch notes. There have been exceptions to that rule, but not many (i.e. less than three regarding OS X, iirc).
    2. http://forums.elderscrollsonline.com/discussion/comment/1141330#Comment_1141330
      [@ OP] - We're sorry to hear you've been experiencing such a frustrating issue. Our Mac team has been on the case tracking this one down. We are currently testing a fix for what we believe is causing your issue. If it passes, it will be in Update 3.
  • Volla
    Volla
    ✭✭✭
    If it passes ? We mac users also pay monthly for the game, as costumers we should get same love as the PC users. It's Really frustrating for us mac users to play pvp and have a crash middle of fight every 10-40 min, seems to vary.

    Looking forward to a fix soon
    //cheers
  • KhajitFurTrader
    KhajitFurTrader
    Community-Botschafter
    Volla wrote: »
    If it passes ? We mac users also pay monthly for the game, as costumers we should get same love as the PC users.

    It's standard practice that any committed code change, be it bug fix or new feature, needs to go through and be approved by QA, before it can be released in a patch. In no way whatsoever does it matter what platform this code change is for.
  • Vatter
    Vatter
    ✭✭✭✭✭
    Kiljaz wrote: »
    For 5 months I've been hearing that fixing the mac client is the top priority for ZoS by their CS reps. After trying everything they've advised and seeing no improvement, plus five months elapsing without any fix, I've come to the conclusion that they really don't want mac user's subscriptions.

    I'd love to play this game, but it's more annoying than fun in AvA.

    #1 cause of death is client crash...

    BWAHAHAHAHA fixing anything is not on any of ZOS's lists of things to do.
  • PrinceBoru
    PrinceBoru
    ✭✭✭✭
    riddled with serious bugs.
    it's just unplayable on my Mac. :'(
    It ain't easy being green.
  • KhajitFurTrader
    KhajitFurTrader
    Community-Botschafter
    @PrinceBoru, could you please specify the issues you're seeing? Please state your system's specs and graphic settings as well.

    I've had zero crashes in PvE since 1.3.4 hit, and with the upcoming particle system prioritizing in 1.4, PvP will run a lot smoother as well. I play nearly every day for some hours without a single hitch that can be attributed solely to the Mac client, so I'm really curious about what you have to report.

  • PrinceBoru
    PrinceBoru
    ✭✭✭✭
    Sure.

    It started after the update in early August.
    The game ran fine beforehand.
    Combat reliably triggers my character into uncontrollable movement.
    For example he won't stop backing up or going sideways.
    Of course this means I can't engage in any combat w/o dying.
    I've tried everything suggested, including different peripherals, as there are plenty of good ideas here in the forums. Nothing works unfortunately.

    My hardware is as follows:
    Mid 2011 Mac mini 2.5 i5 w/ ATI 6630m
    Self-installed SSD w/ 8Gb of memory.
    Apple Thunderbolt display
    Razer Naga 2014 and an Apple keyboard.

    Not hot rod specs to say the least, but what baffles me is the fact that the game ran fine from the release date until early August.

    I'm bummed and I miss playing.

    Thanks for your interest KFT.
    It ain't easy being green.
  • ZOS_MollyH
    Hello @PrinceBoru - we see that you've been using a Razer mouse. While you have tried other peripherals, might you be running RzSynapse? It conflicts with ESO and players using Razer peripherals have reported similar issues before shutting off Synapse. Please let us know if you are able to shut it off and try again! If you have submitted a support ticket, can we please have the ticket number to track down what solutions have been tried? Thank you!
    The Elder Scrolls Online: Tamriel Unlimited - ZeniMax Online Studios
    Forum Rules | Code of Conduct | Terms of Service | Home Page | Help Site
    Staff Post
  • KhajitFurTrader
    KhajitFurTrader
    Community-Botschafter
    One thing to keep in mind, is that the game has seen improvements in the graphics department since launch, such as:
    • the color correction system in 1.3.3 (this is the only change that can be reversed by setting COLOR_CORRECTION=0 in UserSettings.txt)
    • the armor dye system, also in 1.3.3 (which hit in early August, btw)
    • the improved interior lightning system in 1.2.3

    MMOs and their client software are moving targets. Features will get altered or added on a constant basis, and for the most part, "improvement" does not imply "optimization" automatically. Systems on the lower end of the spectrum might be impacted quicker by those changes than those with a greater performance reserve.
  • PrinceBoru
    PrinceBoru
    ✭✭✭✭
    ZOS_MollyH wrote: »
    Please let us know if you are able to shut it off and try again! If you have submitted a support ticket, can we please have the ticket number to track down what solutions have been tried? Thank you!

    Hey thanks for the response.
    I have not used Razer Synapse since purchasing the mouse as it works fine without the Razer software or drivers.
    Here is the ticket number from August 8, 2014.
    140808-003295
    Thanks for your concern!
    I miss playing!!
    It ain't easy being green.
  • PrinceBoru
    PrinceBoru
    ✭✭✭✭
    Systems on the lower end of the spectrum might be impacted quicker by those changes than those with a greater performance reserve.

    Hey KFT.
    I have thought of the low-end spec problem.
    But the game plays fine whenever I am not in combat.
    That's why I believe it isn't my Mac.
    It ain't easy being green.
  • ZOS_MollyH
    Hey @PrinceBoru‌ thank you for letting us know the ticket number! We will be sure to have someone look into your ticket and reach out to you for further assistance. We do see that you have set some keybindings to your mouse, however. One thing to try would be to reset your keybindings and play without them to see if it continues auto-running while they are not connected or if it could be something a bit tweaky with using keybindings on your mouse.

    To Reset the keybindings:

    1.Press [Esc] on your keyboard.
    2.Click Controls in the menu that appears on the lefthand side of the screen.
    3.Click Load Defaults or press X on your keyboard.
    The Elder Scrolls Online: Tamriel Unlimited - ZeniMax Online Studios
    Forum Rules | Code of Conduct | Terms of Service | Home Page | Help Site
    Staff Post
  • PrinceBoru
    PrinceBoru
    ✭✭✭✭
    Hey thanks again for your interest.
    I've copied my reply in a companion thread from Mac support below.
    PrinceBoru wrote: »
    FYI I have tried both of those suggestions to no avail.
    The Razer software is nowhere on my computer. I've long since removed it.
    I've also returned in-game bindings to default with no luck.
    I have used different mice and a different keyboard.
    The keyboard directional keys also triggered the behaviors on two USB keyboards.
    There are similar bug complaints on the Windows Customer Support pages.
    It ain't easy being green.
  • Denus
    Denus
    Soul Shriven
    Seriously ??? :p
  • Calmyron
    Calmyron
    I thought I was the only person having issues with sticky keys. This happens the most in combat, but anytime my FPS starts to suffer, the game seems to lose track of the keyboard at times. It won't register all the key presses and some of them it sticks. I hit the forward, back or left/right keys and it won't stop going in that direction until I re-hit the key, sometimes more than once for it to register.

    I don't have this problem in any other program, just ESO. I lowered some of my settings to keep the FPS up, but with the update to Yosemite, it's back with a vengeance. I get 60 FPS in low spawn areas, but in combat and when there's a lot of mobs, it gets to below 5 FPS. That's right... five. Mavericks wasn't as bad, so something definitely changed in Yosemite. I've gone though all my other apps and they don't seem to have issues, even my many 3D apps and games. ESO seems the most affected by far. Even lowering the subsample from medium to low didn't do a thing.
  • Calmyron
    Calmyron
    Just for information purposes, here's my configuration:

    MacBook Pro (2012) 2.3ghz Intel Core i7, 16gb of RAM, and nVidia 650m with 512mb.
Sign In or Register to comment.