Maintenance for the week of April 3:
• PC/Mac: No NA megaserver maintenance – April 3
• PC/Mac: EU megaserver for maintenance – April 3, 8:00PM EDT (April 4, 00:00 UTC) – April 4, 10:00AM EDT (14:00 UTC)

GeForce Experience cannot detect Elder Scrolls Online

This is something I can't figure out. Every game I have installed is appearing in GeForce Experience, except for ESO and Warframe. Does anyone know why that would happen?
  • nightstrike
    It's not a supported game, so it doesn't show up. You have to manually add eso64.exe (not the launcher). It generally works ok, but sometimes it takes a few tries to get started. And the performance is noticeably lacking compared to games that Nvidia has specifically made to work with it.

    If it keeps not connecting when you add it manually, try just sharing your whole desktop (usually by adding Firefox as a game and minimizing it after it starts).

    None of this is ideal, but in a pinch you can make it sort of work.

    FWIW, ESO worked perfectly with GFE before ZOS made them pull it from GeForce NOW. I assume after that happened and they dropped support from Now, that eventually with enough GFE updates, it just suffered from bitrot (GFE and NOW use the same backend technology)
    Warning: This signature is tiny!
  • Red_Feather
    I tried adding eso64.exe a bunch of times. I gave up.
  • MyxMaster
    Soul Shriven
    I found that when I open the GeForce Experience app before opening the ESO Launcher, GeForce finds the game, but I've only got it to work with the GeForce Game filter.

    After you launch the game by pushing the Play button, you'll see the GeForce game filter banner on the upper right of your screen. The shortcut is Alt+F3 to add and adjust game filters. Once you're on the ESO game landing page, press Alt+F3 to open the game filter. Alt+Z opens the GeForce overlay. Sorry if none of this makes sense!

    I haven't been able to get the GeForce Experience app to find the game in the GeForce Experience application. I've read in other forums that NVidia will need to update GeForce Experience for it to work again. I've also read that GeForce doesn't support ESO any longer. I only really use it for the game filter and I adjust the ESO graphic settings in game. Good luck!!!
Sign In or Register to comment.