Maintenance for the week of April 22:
• PC/Mac: No maintenance – April 22
• PC/Mac: NA and EU for maintenance – April 24, 4:00AM EDT (8:00 UTC) – 8:00AM EDT (12:00 UTC)
• PlayStation®4: NA and EU megaservers for maintenance – April 24, 4:00AM EDT (8:00 UTC) – 8:00AM EDT (12:00 UTC)
• Xbox One: NA and EU megaservers for maintenance – April 24, 4:00AM EDT (8:00 UTC) – 12:00PM EDT (16:00 UTC)
The Elsweyr Chapter and Update 22 base game patch are now available to test on the PTS! You can read the full patch notes here https://forums.elderscrollsonline.com/en/discussion/468599

Full screen and dual monitors seems broken

RickDangerous42
I'm having major issues with full screen mode and dual monitors. What happens is that whenever there's a cursor (e.g. using inventory), if I move the cursor to the second screen (accidentally), ESO drops to maximized mode, and sometimes MOVES the rendering to the second display. Sometimes it will move it back to the main monitor after a few seconds, but sometimes not. When it doesn't move it back, for some reason I can't use ANY keys on the keyboard, to do anything. Only option at that point is to turn off the Mac using the power button. This is reeeaallly annoying. Anyone else noticed this? Any workarounds?
  • xhunter
    xhunter
    YES! I am glad I am not the only one. It drives me insane.

    Here's my thread on the problem: http://forums.elderscrollsonline.com/discussion/61840/full-screen-issues-using-a-second-monitor
  • Moonraker
    Moonraker
    ✭✭✭✭
    Have you tested it on other games t se if it is ESO specific? There was a bug in 10.9.2 for second monitors linked in the other thread linked by @xhunter.

    I have asked the question to development team and will post a response as and when I get one.
  • revvek
    revvek
    Soul Shriven
    Moonraker wrote: »
    Have you tested it on other games t se if it is ESO specific? There was a bug in 10.9.2 for second monitors linked in the other thread linked by @xhunter.

    I have asked the question to development team and will post a response as and when I get one.

    It's not 10.9 or other games, this drop out of full screen is ESO, and was not in the last beta either.

    I would like them to take over all displays, even if they only show black or some game related subtle textures on the un used displays.
  • Moonraker
    Moonraker
    ✭✭✭✭
    revvek wrote: »
    Moonraker wrote: »
    Have you tested it on other games t se if it is ESO specific? There was a bug in 10.9.2 for second monitors linked in the other thread linked by @xhunter.

    I have asked the question to development team and will post a response as and when I get one.

    It's not 10.9 or other games, this drop out of full screen is ESO, and was not in the last beta either.

    I would like them to take over all displays, even if they only show black or some game related subtle textures on the un used displays.
    I posted an update to this on the other thread with more posts about this here.

    Basically the functionality will be reverted as before.

  • RickDangerous42
    As of 1.0.5 the fullscreen mode works PERFECTLY for me. AWESOME!
  • Moonraker
    Moonraker
    ✭✭✭✭
    As of 1.0.5 the fullscreen mode works PERFECTLY for me. AWESOME!
    Cool :) Glad they were able to get this fix out on this.

  • christerb16_ESO2
    christerb16_ESO2
    Soul Shriven
    With the revert, full screen behaviour is slightly better. For me, however, it's still unusable due to the fact that the game steals keyboard focus. I can see applications on other screens just fine and also so things like scrolling a browser window with the mouse wheel. Any keyboard input is sent to the game regardless of what I do.

    This sort of makes the full screen mode unusable for me as I require the ability to type into applications outside of the game.
  • Moonraker
    Moonraker
    ✭✭✭✭
    With the revert, full screen behaviour is slightly better. For me, however, it's still unusable due to the fact that the game steals keyboard focus. I can see applications on other screens just fine and also so things like scrolling a browser window with the mouse wheel. Any keyboard input is sent to the game regardless of what I do.

    This sort of makes the full screen mode unusable for me as I require the ability to type into applications outside of the game.
    Isn't that what this is for? Controls > Key Bindings > Toggle In-Game Cursor

    It's what I use the type in other apps etc.
  • christerb16_ESO2
    christerb16_ESO2
    Soul Shriven
    Moonraker wrote: »
    Isn't that what this is for? Controls > Key Bindings > Toggle In-Game Cursor

    It's what I use the type in other apps etc.

    Doesn't work for me I'm afraid. It's the same behaviour even from the login screen, and behaves as follows:

    1. Start the client and get to the login screen
    2. Switch Display Mode to "Fullscreen" if not set already
    3. External screens (I have two externals connected to my 27" late 2012 iMac) show applications as per normal (for example Safari on these forums)
    4. Click in the password field (and type a few letters to verify it works)
    5. Clicking in the comment box in the forums shows the blinking cursor and appears to be ready to take input. The password field in the ESO client still shows the blinking cursor.
    6. Type anything, and it enters it into the password field in ESO (showing the password hiding dots obviously)

    Nothing I have done have changed this behaviour. The ESO client always steals keyboard input regardless of mode I'm in. I've tested toggling the "Displays have separate Spaces" setting in Mission Control preferences without any difference in behaviour.

    I'm running a fully updated Mavericks installation. The application of the April 22 update didn't change anything (as expected since that was a security update).

    I haven't seen anyone else mention this behaviour, so I don't know if it's localised to my machine, or if it's a behaviour for Mavericks in general. I don't have any other Mac capable of running ESO to test on unfortunately.
  • Moonraker
    Moonraker
    ✭✭✭✭
    Good details of monitor behaviour @christerb16_ESO2.

    Unfortunately I don't have any external monitors to try myself to test. Hopefully others who have them set up can comment and/ or suggest something.

    Have you tried other games in Fullscreen like this? If I remember correctly you have OS X 10.9.2.
    Edited by Moonraker on April 23, 2014 7:46PM
  • RickDangerous42
    FWIW, I have the same behaviour as @christerb16_ESO2‌ but I don't really mind. Whenever I need to type outside ESO I switch fullscreen mode by using cmd-F, do the outside typing, and then cmd-F back. Current behaviour is at least better than the non-working one we had before.
  • Moonraker
    Moonraker
    ✭✭✭✭
    FWIW, I have the same behaviour as @christerb16_ESO2‌ but I don't really mind. Whenever I need to type outside ESO I switch fullscreen mode by using cmd-F, do the outside typing, and then cmd-F back. Current behaviour is at least better than the non-working one we had before.
    In other games like WoW I believe it does the same and it's just the way Apple handle the multiple monitor behaviour. It is complicated by the fact that each OS X version does things differently. 10.7.x has real issues with multiple monitors from forums.
  • christerb16_ESO2
    christerb16_ESO2
    Soul Shriven
    WoW behaves slightly different in terms of full-screen. Basically, you have three modes:

    1. Full screen - Game goes full-screen (on a user selectable display) and blacks out all other screens.
    2. Windowed Full screen - Game is in windowed mode, but maximised over the whole display with no menu bar or window decoration showing.
    3. Windowed - Normal windowed mode where you can move around the window if you wish

    In a sense, the full screen mode is the same I guess, except ESO allows you to at least view the other displays. Blizzard's method of doing the maximised mode is better, as ESO leaves both the menubar at the top and the window decoration at the top. If Zenimax managed to get rid of those two and do a "fake" fullscreen I'd be a very happy camper. Whether or not the display is in proper fullscreen or not is insignificant for me (although I appreciate there are technical differences for things like refresh rate and gamma settings).

    As of Mavericks, the ability to have separate spaces for each display would probably technically allow a proper full-screen mode using Apple's APIs which let you interact with applications on other screens. But I suspect that'd require a specific Mavericks version of the client which seems unlikely. Perhaps it'd be better to leave fullscreen as-is and try to find the workaround in the maximised mode that allows hiding of the window decoration and menu bar instead. That's at least something other developers have managed somehow.
  • Moonraker
    Moonraker
    ✭✭✭✭
    @christerb16_ESO2 you make a good point that actually what is a useful option is the fake fullscreen or a Maximised which goes edge to edge (no menu) It is useful though it means you can't use Vsync from the game (currently we mostly wouldn't though maybe that will change)

    It's all a balance. The biggest is just the fact that OS X has different ways of handling both, Spaces, this and multiple screens pretty much for each supported OS X version and that is as much a limit (to support across 10.7/8/9 and soon 10.10)
  • Windshadow_ESO
    Windshadow_ESO
    ✭✭✭
    Good details of monitor behaviour @christerb16_ESO2. that os just what i see now

    best for me would be a pref selection between what we have now and the way it was
    but I run a pair of 1920x1200 apple cinema under 10.7.5 and the way it was before if you switched it back and forth enough quickly enough it could crash the video card so it is far more stable this way
Sign In or Register to comment.