The Blackwood Chapter and Update 30 are now available for testing on the PTS! Read the full patch notes here:

EU Megaserver

Login and loading chars is failing since 02:30 EST :/
<3 Liebe Grüße,
  • Ilision
    Sakibure wrote: »
    Login and loading chars is failing since 02:30 EST :/

    Having the same problem, getting stuck in the loading screen...
  • iarnold
    I thought I was the only one. Reboot the PC, repaired the game twice, and even removed the addons. Nothing worked so far.
  • ZOS_BillE
    There were issues on the EU megaserver leading to login and loading issues. Both of these issues should now be resolved. If you are still having an issue please let us know.
    The Elder Scrolls Online: Tamriel Unlimited - ZeniMax Online Studios
    Forum Rules | Code of Conduct | Terms of Service | Home Page | Help Site
    Staff Post
  • redgreensunset
    @ZOS_BillE The issues definitely persist, have throughout the day with irregular intervals and are now getting worse again. Have been hanging on 10 minutes long loading screens, only to get booted to the log in screen and then rinse and repeat. As long as I do overland there are no issues and I have no issues with my internet. I've tried resetting my router and close down game and launcher, even reboot my pc, the issues persist still.
    Nor am I alone, there are multiple posts on this on the forum and several guildies have reported ridiculously long loading screens and getting booted while on loading screen.

    I managed to finally port to Rimmen and have parked my character for the night, hoping that this will be resolved tomorrow. But things are not working as they should right now.
    Oh, PC/EU btw.
Sign In or Register to comment.