Maintenance for the week of December 9:
• PC/Mac: NA and EU megaservers for patch maintenance – December 9, 4:00AM EST (09:00 UTC) - 8:00AM EST (13:00 UTC)

Elseweyr update causing MASSIVE FPS drops!!???

AmbitionsVI
AmbitionsVI
Soul Shriven
Ever since the day Elseweyr came out for Xbox, I as well as another buddy of mine are having MASSISIVE frame rate drops. If we get into an encounter with maybe 1 or 2 enemies, it causes the frame rate to drop horribly to the point where I don’t even want to play anymore. Another weird thing I noticed too was that when frame rate dips, my game and chat volume starts to cut in and out (I have a Wireless turtle beach headset if that matters). I don’t know if anyone else is experiencing the same thing, or if I’m the only one.
  • Hrolthar
    Hrolthar
    ✭✭✭
    I've had the same thing. Lots more infinite load screens, freezes and server crashes when it kicks you from the server and says:

    "Unable to connect to game server. Please make sure you have a valid internet connection."

    Make sure you go through the "Troubleshooting Steps". It won't do anything, but at least then you can say you have. (I've tried multiple times over the last 12 months.)
  • frostz417
    frostz417
    ✭✭✭✭✭
    ✭✭
    I’m having the same issue as you are
  • VeryEvilPuma
    VeryEvilPuma
    ✭✭✭
    Also have same problems. I even can't do quests because these lags are freaking me out. In dungeons all is worse.
  • AmbitionsVI
    AmbitionsVI
    Soul Shriven
    I thought I was the only one having these issues. Before the Elsweyr update dropped, the game was somewhat playable, but now the issues are MUCH worse. I hope a fix does come soon, but I doubt it.
  • ZOS_BillE
    ZOS_BillE
    admin
    There are some standard troubleshooting steps in the link below that can help with frame rate issues while playing.

    What do I do if ESO is having performance issues on Xbox One?

    If the issues continue, you can open a ticket with customer support to report this issue.
    The Elder Scrolls Online: Tamriel Unlimited - ZeniMax Online Studios
    Forum Rules | Code of Conduct | Terms of Service | Home Page | Help Site
    Staff Post
  • VeryEvilPuma
    VeryEvilPuma
    ✭✭✭
    @ZOS_BillE I wrote a ticket about several hours ago. As the result the category of my ticket has been changed to “missing items” somehow although I chose “I have performance issues” and I received an automatic response which wasn’t about my message completely. Nice customer support...
    Edited by VeryEvilPuma on June 9, 2019 11:56PM
  • GenjiraX
    GenjiraX
    ✭✭✭
    I have the same problems (Xbox One X) as well as animations not triggering and sounds triggering late, in combat or just gathering resources. I opened a ticket a few days ago but have so far just had the ‘how to improve performance’ advice. Everything was fine before Elsweyr.
    Edited by GenjiraX on June 10, 2019 7:34AM
    Xbox/EU
  • Ronnie42
    Ronnie42
    Soul Shriven
    Yeh the servers have been pretty bad the last few days to a point where it's nearly impossible to login, even if I get in there's usually lag, I dare not log off due to the fact that it would take forever to get back on.
  • pjmh92
    pjmh92
    Soul Shriven
    Same issues here, I've stopped playing since the Elsweyr update as it's completely unplayable. Running a 40Mbps connection with QoS priority to my xbox so definitely not a connection issue.

    Lag is occurring even summoning my mount, usually a 2 second delay. Dungeons an PVP are the worst as combat is literally impossible.

    Hope it gets fixed soon or I'll have to cancel my eso plus sub!
  • macsmooth
    macsmooth
    ✭✭✭✭
    Yep a lot of people are having this issue me included I don’t think Zos have even acknowledged this issue yet

    I moved the game to an external hd which has improved a little but not during any engagements with enemies that’s still really bad, I’ve stopped playing anything that requires major processing until they fix this issue

    At this rate I will have to stop playing until they release the new xbox next year that they just announced
  • AmbitionsVI
    AmbitionsVI
    Soul Shriven
    I also did submit a ticket 2 days ago and finally got a response today. I was told to submit a bug report to the devs so that they’d know about it. They need to put out a fix for the servers, since it seems like it’s more server related.
  • Anotherone773
    Anotherone773
    ✭✭✭✭✭
    ✭✭
    The lag was horrible on PC servers as well when it was released. A lot more people logging in to try the new content taxing the servers. The FPS drops with each new chapter. In Elsweyr, i get 40-60 FPS standing still in the open on a GTX 1070 card with FHD( 1080p). I can stand by the pledge tent in every capital and get 100 FPS at peak.
  • Nyqwont
    Nyqwont
    It's terrible. I que for my random, audio only cuts in from time to time. In dungeons, I don't see mobs until after they're dead. Just random floating numbers.
    Happens when in overland when I move at more than a slow walk as well.
  • Ace1Taz
    Ace1Taz
    Soul Shriven
    Same as everyone else. Elsweyr introduced a lot of lag.
  • veroxiousvemo
    veroxiousvemo
    ✭✭✭
    Same here and I have submitted a support ticket. Hopefully they can fix this fast so I can get back to leveling :)
    Kia ora!
    Xbox NA (PvE) Nord DK Stam CP301
  • Defilted
    Defilted
    ✭✭✭✭✭
    I have hard reset many times. Issue does not go away. I have had my xbox1x and ssd since the Scorpio was released and ESO has ran awesome up to this point. The FPS issues are very distracting and tilts the game experience to the negative side.

    Necro is fun and I am having a good time. Just need to clear up these FPS issues.
    XBOX NA
    XBOX1X
    External SSD USB 3.1(Samsung T5)

    #NightmareBear
  • Endlicht
    Endlicht
    I have the same problem.

    xbox one x, 4k,HDR
    in the start screen i can already hear the fan of my xbox
    the playing is disturbed by massive jerking
    I have only spent about 2 hours in elsweyr :(
    Edited by Endlicht on June 12, 2019 2:51PM
  • chratr
    chratr
    Soul Shriven
    Same problem. It not possible to play anymore. Lag terrible. Off game!!!! and wait for new update to fix this issue.

  • Mr_Walker
    Mr_Walker
    ✭✭✭✭✭
    ✭✭✭
    Same issue, bad lag, audio desynchs, frequent dc's. All since EW dropped.

    Not saying it was great before EW, but compared to this....
  • DarkSajuuk
    DarkSajuuk
    ✭✭
    Been having the same issues myself. Standing around doing nothing, game works fine. Start moving around or getting into combat the game freaks out, the FPS drops to an uplayable level and the audio desynchs. Not to mention the freezing loading screens and the disconnects.
  • SpankinDamob
    SpankinDamob
    ✭✭✭
    Having the same experience on Xbox One X. Tried everything I could think of. Cleaned up stuff on the Xbox, checked multiplayer connection and said it was good, have ipv6 connection, open Nat. Reset my router and Xbox. Uninstalled the game, restarted the Xbox, reinstalled, restarted game.
  • PerArdua
    PerArdua
    ✭✭✭
    Not just Xbox server issue have the same problems on PS4 eu . It’s unplayable at times .Just 1example, I died from a poison aoe that spawned after the add was dead whilst trying a no death in . Also happening at non peak times so not due to server load
  • VeryEvilPuma
    VeryEvilPuma
    ✭✭✭
    I wrote about these issues on June 9th in support. As a result, I have been ignored for 4 days already. I wrote in the “General Help” on the forum. There I received a simple reply with the words "wait for a response from the support." I have never seen such a attitude from a support in any game. But it is still impossible to play, all problems remained in place.
  • SpankinDamob
    SpankinDamob
    ✭✭✭
    Just logged out now after trying to play for about a hour. Checked my network status before logging in. Ip4 / ip6, Nat type open, latency was at 54, download speed 91.37 mbps, upload speed 15.99 mbps according to Xbox.

    Tried a bunch of different zones. Same thing on in each one. Sound for casting spells was off. Constant frame rate drops. Towards the end I’d be doing my spell rotation and the effect would show up about 3 seconds afterwards. Half the time it’d still show me attacking and the mob was dead.

    I understand with new content there’s going to be problems. Just wish they’d acknowledge it and say what their doing to fix it.
  • SweepsAllClowns
    SweepsAllClowns
    ✭✭✭✭
    I understand with new content there’s going to be problems.

    I understand or more like understood this before, new dlc is added every 3 months meaning many new problems are added also, some older problems make comeback sometimes too. When most resources are probably on creating the new content, there's simply no time or resources to fix everything, all this leads to issues piling up in the long run and this game has become the game of how much are you willing to tolerate. This is just going worse from here, the time of let's be patient and wait for the improvements was about 2 years ago for me, of course now that my account has been stuck for over 3 months I don't need to enjoy all the lagtastic experiences anymore.
  • Toc de Malsvi
    Toc de Malsvi
    ✭✭✭✭✭
    Performance wasn't bad for me until Saturday night, then it pooped the bed and hasn't recovered.
    Legendary Archer of Valenwood
    Bosmer Dragon Knight Archer. XBox One. (Flawless Conqueror Bow/Bow)
    Bosmer Nightblade Archer. Xbox One. (Flawless Conqueror Bow/Bow)
    Bosmer Sorcerer Archer. Xbox One. (Flawless Conqueror Bow/Bow)
    Bosmer Warden Archer. Xbox One. (Flawless Conqueror Bow/Bow)
    Templar's are evil..
  • Norgh
    Norgh
    Soul Shriven
    Sadly since the update the game lag is terrible.
    Xbox EU-UK
  • SpankinDamob
    SpankinDamob
    ✭✭✭
    *Edit* Never mind went back to crap within a hour.

    I posted a thread about what found to fix it for me but wanted to make sure you all seen it too. Just copy / pasting it here.

    Think I finally got it running smooth again. Doesn’t seem quite as good as before the patch, but pretty close. I’ll post other info on stuff I did before that didn’t work and my system info. Just going to copy paste from other posts I made.

    The thing that finally got running good was when you click manage the game, delete saved game info, I didn’t realize there are two. I was deleting the one that has stuff saved to my Xbox . On Xbox if you click your avatar there’s a option to delete all saved game info everywhere . This gets rid of the back up stuff saved to cloud.

    Really only noticeable issue since I’d the sound for race against time doesn’t happen sometimes. Hope this helps someone.

    Checked my network status before logging in. Ip4 / ip6, Nat type open, latency was at 54, download speed 91.37 mbps, upload speed 15.99 mbps according to Xbox.

    Tried a bunch of different zones. Same thing on in each one. Sound for casting spells was off. Constant frame rate drops. Towards the end I’d be doing my spell rotation and the effect would show up about 3 seconds afterwards. Half the time it’d still show me attacking and the mob was dead.

    Having the same experience on Xbox One X. Tried everything I could think of. Cleaned up stuff on the Xbox, checked multiplayer connection and said it was good, have ipv6 connection, open Nat. Reset my router and Xbox. Uninstalled the game, restarted the Xbox, reinstalled, restarted game.
    Edited by SpankinDamob on June 16, 2019 12:38AM
  • kitsune_beth
    kitsune_beth
    ✭✭✭
    Elsweyr seems to be causing lag in every part of the game, although there was lag in some places before it came out.
    The infinite load screens are very annoying, it make you reluctant to use wayshrines, or even go through doors.

    Kind of amusing that they always say the problem is on our end rather than theirs. :D
  • Unfadingsilence
    Unfadingsilence
    ✭✭✭✭✭
    From tonight

Sign In or Register to comment.