Mail with attachments being returned

LadySinflower
LadySinflower
✭✭✭✭
I am level 24 trying to send in-game mail with attachments to another player who is level 21. My mail is being returned to me with no reason being given. When I get the mail back, the word "returned" is in the subject line in red letters. The attachments are small things like recipes, a few alchemy or food ingredients. I'm trying to help him fulfill crafting writs by sending him ingredients he's having trouble finding or buying.

This was posted in "players helping players" and no one seemed to know why it was happening. It was suggested to try to trade directly but we live together with one Xbox. We can't be on the game at the same time. We are both ESO Plus members. I am able to receive mail with attachments from other players but he has not tried to send me anything. I am just typing his gamertag in the "to" field. Does it have to be formatted a certain way or any punctuation/symbols added? I have verified that I am spelling his GT correctly and that his inbox is not full.

My GT is ShadokatPH66 and his is Druhsnikinni. Should I submit a ticket or is there something that I am doing wrong? Thank you.
  • Sparr0w
    Sparr0w
    ✭✭✭✭✭
    Add him as a friend on XBL and try sending mail directly through the 'Friends' tab on ESO (click on his GT and select 'Send Mail')

    If that works its likely your typing his GT wrong, could be he has an L rather than an i (as an example). If that still doesnt work then yes I would raise a ticket.
    @Sparr0w so I get the notification
    Xbox (EU) - l Sparrow x | CP 810+
    DD: All Mag + Stam
    Heal: Templar | Sorc | NB | Warden | Necro
    Tank: NB | DK | Warden
    Completions: All HM's + Immortal Redeemer + Gryphon Heart
    PC (EU) - Sparrowo | CP 810+
    DD: All Mag + Stam
    Heal: Templar | Sorc
    Tank: DK
    Completions: Crag HM's, MOL, HOF, AS HM
  • LadySinflower
    LadySinflower
    ✭✭✭✭
    Hi @Sparr0w! Thank you for commenting here too.

    We have sat together looking at his GT together and verifying that I'm typing it correctly. When I go to play later I'll add him as a friend and see if it makes a difference. Thanks so much! B)
  • LadySinflower
    LadySinflower
    ✭✭✭✭
    Sparr0w wrote: »
    Add him as a friend on XBL and try sending mail directly through the 'Friends' tab on ESO (click on his GT and select 'Send Mail')

    If that works its likely your typing his GT wrong, could be he has an L rather than an i (as an example). If that still doesnt work then yes I would raise a ticket.

    Another development. I added him as a friend and tried sending mail through clicking on his name then "send mail." My mail was returned. We both joined the same guild and I tried sending through the guild roster. The mall was returned. I tried sending a COD item. He never received it but I haven't logged back on to see if it was returned. I have submitted a ticket to support. Thanks for your help @Sparr0w .
Sign In or Register to comment.