Maintenance for the week of February 18:
• PC/Mac: No maintenance – February 18
• Xbox One: EU megaserver for maintenance – February 20, 4:00AM EST (9:00 UTC) - 12:00PM EST (17:00 UTC)
The Wrathstone DLC Game Pack and Update 21 base game patch are now available to test on the PTS! Read the full patch notes here: https://forums.elderscrollsonline.com/en/discussion/454456/

Instant crash on my Mac [Workaround]

  • sphane
    sphane
    ✭✭✭
    Annelid01 wrote: »
    Pity if you do not have Xcode and are stuck on Sierra for other reasons.

    You should be able to install Xcode on Sierra. Am still running EL Capitan (10.11). I use Xcode for years (since release) and never had any problem to install it on any OS (didn't test on Sierra or High Sierra tho)

    There is more intrusive way to limit core usage but i dont recommend if you dont have a deep knowledge of what you are doing (will not be reverted when restarting, have to do by your own).
  • sphane
    sphane
    ✭✭✭
    Wodinn wrote: »
    Rowjoh wrote: »
    The workaround detailed by @sphane solved it for me, and I don't have any performance or graphics degradation either.

    Genius!

    I read the patch notes for the update today. I'm no programmer at all, but in the performance section it did make mention that they made changes so that that game would finally make use of multiple core cpu's. I can't help but think either that, or the multithreading has something to do with this. Again, I'm no programmer, this is just a guess. Taking that into consideration, and a couple of other points they made on that topic. Decreasing the amount of cpu cores right now, temporarily, won't make any difference on the performance. tbh, my game seems to play smoother, and looks a bit better even.


    You are right, it's the origin of the problem. I guess all of us have 2 CPU multi-core and obviously, ESO is confusing with more than 1 CPU on mac. Usually i downgrade my computer to run old program... but it's the first time i have to do to run a brand new one...

    Having confirmation that ZOS is aware and working on a permanent fix would be great because multi cpu machines are becoming very commons...

    @ZOS_GinaBruno ?
    Edited by sphane on May 23, 2018 9:46PM
  • smacx250
    smacx250
    ✭✭✭✭✭
    Just curious - has anyone tried changing this in "UserSettings.txt" to something "small" like "4" to see if that works?

    SET MaxCoresToUse.4 "-1"
  • sphane
    sphane
    ✭✭✭
    smacx250 wrote: »
    Just curious - has anyone tried changing this in "UserSettings.txt" to something "small" like "4" to see if that works?

    SET MaxCoresToUse.4 "-1"

    That's a good idea.

    I put
    SET MaxCoresToUse.4 "8" (which is limiting to 1 cpu) and game is launching without downgrading hardware. So I guess its a better and final workaround.

    Going up to 8 will make the game crash again. And i noticed a slightly better FPS with this solution (just tested for few minutes tho).
    Edited by sphane on May 23, 2018 10:31PM
  • Maxitude
    Maxitude
    Soul Shriven
    I am running a late 2013 Mac Pro with 12 (2x6) cores. I can confirm that the Xcode-related recommendations from @sphane work on my machine also. To make this work for me, I cannot set my cores to 8. If you have 12 cores like I do, you must set it to 6, which effectively gets you to use only 1 CPU, which is the problem that has been identified. ZOS apparently has only coded for 1 CPU with multi cores (see above comments).

    I am however, seeing minor performance degradation. I am running two high def monitors on my machine so perhaps that is too much on my rig for only 1 CPU. With both monitors active, my game FPS goes down a little bit and I get occasional cutouts on frames.

    If you are new to the thread, I recommend you read all of @sphane's responses before you attempt to get into Xcode. I too couldn't locate the proper window to change my cores until I read a latter post by the @sphane. (thx sphane!).
  • sphane
    sphane
    ✭✭✭
    Maxitude wrote: »
    I am running a late 2013 Mac Pro with 12 (2x6) cores. I can confirm that the Xcode-related recommendations from @sphane work on my machine also. To make this work for me, I cannot set my cores to 8. If you have 12 cores like I do, you must set it to 6, which effectively gets you to use only 1 CPU, which is the problem that has been identified. ZOS apparently has only coded for 1 CPU with multi cores (see above comments).

    I am however, seeing minor performance degradation. I am running two high def monitors on my machine so perhaps that is too much on my rig for only 1 CPU. With both monitors active, my game FPS goes down a little bit and I get occasional cutouts on frames.

    If you are new to the thread, I recommend you read all of @sphane's responses before you attempt to get into Xcode. I too couldn't locate the proper window to change my cores until I read a latter post by the @sphane. (thx sphane!).

    I edited the initial post and the title with the final workaround suggested by @smacx250

    Now we expect a fix...
  • Rowjoh
    Rowjoh
    ✭✭✭
    Has anyone tried adjusting the cores back up again once in-game ?

    I'm too scared to try !
  • sphane
    sphane
    ✭✭✭
    Rowjoh wrote: »
    Has anyone tried adjusting the cores back up again once in-game ?

    I'm too scared to try !

    Yeah I did at the first time lol : instant crash
  • Maxitude
    Maxitude
    Soul Shriven
    I just tested gameplay using the solution from @smacx250. It works well also. In fact the performance degradation I saw with Xcode seems to be gone based on 5min of gameplay. I can play the game on one HIDef monitor and watch Rogue One streaming on Netflix on the other and both have decent FPS. Again, on my 2x6 core rig, I set my Maxcores.4 value to "6" to get it to work.

    Thanks folks (@sphane and @smacx250) for your great solutions. Cant wait to see that fix. Cheers!
  • sphane
    sphane
    ✭✭✭
    Maxitude wrote: »
    I just tested gameplay using the solution from @smacx250. It works well also. In fact the performance degradation I saw with Xcode seems to be gone based on 5min of gameplay. I can play the game on one HIDef monitor and watch Rogue One streaming on Netflix on the other and both have decent FPS. Again, on my 2x6 core rig, I set my Maxcores.4 value to "6" to get it to work.

    Thanks folks (@sphane and @smacx250) for your great solutions. Cant wait to see that fix. Cheers!

    Confirmed: based on 10 mins play, better performance (FPS in particular) changing the configuration file.
  • Wodinn
    Wodinn
    ✭✭✭
    If I have to reduce the cores used in Instrument from 16, down to 8 to play the game. What do I need to set the MaxCores used too? don't particularly want to mess this up.
  • Annelid01
    Annelid01
    Soul Shriven
    I am unable to install Xcode as I am still on Sierra.

    However, I ticketed support and after a little back and forth, thy suggested changing the UserSettings.txt lines

    from

    SET RequestedNumJobThreads "0"
    SET RequestedNumWorkerThreads "0"

    to

    SET RequestedNumJobThreads "1"
    SET RequestedNumWorkerThreads "1".

    They also supplied a "default" set of values for UserSettings.txt

    The default values worked.

    However, I went back to my original UserSettings.txt. It had

    SET RequestedNumJobThreads "-1"
    SET RequestedNumWorkerThreads "-1"

    I changed these to 1 and restarted with perfect results. I then changed them to 0. Again, perfect.

    MacPro 2013 OS 10.12.6

    Hope this helps someone.
  • sphane
    sphane
    ✭✭✭
    Wodinn wrote: »
    If I have to reduce the cores used in Instrument from 16, down to 8 to play the game. What do I need to set the MaxCores used too? don't particularly want to mess this up.

    We have better solution now with UserSetting.txt change working better than Instrument workaround, check original post.
  • Wodinn
    Wodinn
    ✭✭✭
    sphane wrote: »
    Wodinn wrote: »
    If I have to reduce the cores used in Instrument from 16, down to 8 to play the game. What do I need to set the MaxCores used too? don't particularly want to mess this up.

    We have better solution now with UserSetting.txt change working better than Instrument workaround, check original post.

    sorry I worded that wrong. I'm just asking what I should set that number too? I meant the maxcores thing in user setting.txt
  • Wodinn
    Wodinn
    ✭✭✭
    Annelid01 wrote: »
    I am unable to install Xcode as I am still on Sierra.

    However, I ticketed support and after a little back and forth, thy suggested changing the UserSettings.txt lines

    from

    SET RequestedNumJobThreads "0"
    SET RequestedNumWorkerThreads "0"

    to

    SET RequestedNumJobThreads "1"
    SET RequestedNumWorkerThreads "1".

    They also supplied a "default" set of values for UserSettings.txt

    The default values worked.

    However, I went back to my original UserSettings.txt. It had

    SET RequestedNumJobThreads "-1"
    SET RequestedNumWorkerThreads "-1"

    I changed these to 1 and restarted with perfect results. I then changed them to 0. Again, perfect.

    MacPro 2013 OS 10.12.6

    Hope this helps someone.

    wow really?
    Edit: my values were both at -1 when I opened up the Usertext.txt. I did change them both to 1, seems to be working. Will update soon after I'm in game for a few.
    Update: I switched toons. and logged out and back in. Seems to be working fine. I'm not sure if I've seen any difference in performance or not.
    Edited by Wodinn on May 24, 2018 1:33AM
  • sphane
    sphane
    ✭✭✭
    Wodinn wrote: »
    sphane wrote: »
    Wodinn wrote: »
    If I have to reduce the cores used in Instrument from 16, down to 8 to play the game. What do I need to set the MaxCores used too? don't particularly want to mess this up.

    We have better solution now with UserSetting.txt change working better than Instrument workaround, check original post.

    sorry I worded that wrong. I'm just asking what I should set that number too? I meant the maxcores thing in user setting.txt

    According to your precedent post saying you have 16 cores the correct value is 8.
  • sphane
    sphane
    ✭✭✭
    Annelid01 wrote: »
    I am unable to install Xcode as I am still on Sierra.

    However, I ticketed support and after a little back and forth, thy suggested changing the UserSettings.txt lines

    from

    SET RequestedNumJobThreads "0"
    SET RequestedNumWorkerThreads "0"

    to

    SET RequestedNumJobThreads "1"
    SET RequestedNumWorkerThreads "1".

    They also supplied a "default" set of values for UserSettings.txt

    The default values worked.

    However, I went back to my original UserSettings.txt. It had

    SET RequestedNumJobThreads "-1"
    SET RequestedNumWorkerThreads "-1"

    I changed these to 1 and restarted with perfect results. I then changed them to 0. Again, perfect.

    MacPro 2013 OS 10.12.6

    Hope this helps someone.

    Thanks for sharing what the support finally provided.

    I can confirm it's working too. But i noticed a lower fps by 10-15% than changing Max core value... Hard to say if it's significant or not.

    I update the original post to mention this alternate solution
    Edited by sphane on May 24, 2018 1:26AM
  • Wodinn
    Wodinn
    ✭✭✭
    sphane wrote: »
    Wodinn wrote: »
    sphane wrote: »
    Wodinn wrote: »
    If I have to reduce the cores used in Instrument from 16, down to 8 to play the game. What do I need to set the MaxCores used too? don't particularly want to mess this up.

    We have better solution now with UserSetting.txt change working better than Instrument workaround, check original post.

    sorry I worded that wrong. I'm just asking what I should set that number too? I meant the maxcores thing in user setting.txt

    According to your precedent post saying you have 16 cores the correct value is 8.

    Yeah sorry about the miss communication.
  • Rowjoh
    Rowjoh
    ✭✭✭
    Just to confirm, the solution from @smacx250 works perfectly.

    If you're running on 12 cores:

    Locate and click on the UserSettings.txt document (Documents > The Elder Scroll Online > Live)

    Scroll down to SET MaxCoresToUse.4 "-1" and change to: SET MaxCoresToUse.4 "6"

    If you're running on 16 cores then change to: SET MaxCoresToUse.4 "8"

    The game will now launch and play normally with performance and stability as it should be.

    Big thanks to @sphane for discovering the original workaround and @smacx250 for the simpler solution ! o:)
    Edited by Rowjoh on May 24, 2018 5:51PM
  • Annelid01
    Annelid01
    Soul Shriven
    From Tech Support

    SET RequestedNumJobThreads "-1"
    SET RequestedNumWorkerThreads "-1" = use all cores but one

    SET RequestedNumJobThreads "0"
    SET RequestedNumWorkerThreads "0" = use "available" cores

    SET RequestedNumJobThreads x"
    SET RequestedNumWorkerThreads "x". - use x cores, where x is a number .

    Hope this makes sense.
  • Wodinn
    Wodinn
    ✭✭✭
    Annelid01 wrote: »
    From Tech Support

    SET RequestedNumJobThreads "-1"
    SET RequestedNumWorkerThreads "-1" = use all cores but one

    SET RequestedNumJobThreads "0"
    SET RequestedNumWorkerThreads "0" = use "available" cores

    SET RequestedNumJobThreads x"
    SET RequestedNumWorkerThreads "x". - use x cores, where x is a number .

    Hope this makes sense.

    I may end up trying the other work around. I did this and it did have a noticeable impact on my performance. My fps would be around 50 and then I would sudden be dropping frames for a few seconds.
  • Wodinn
    Wodinn
    ✭✭✭
    After playing all evening, and one pledge. All I can say is both work arounds seem to have the same performance in general. I got some massive fps drops last night out of nowhere (using the 'cores used' work around, not the 'requestnumjobthread' one). Just an fyi.
  • Chykimonkey
    Chykimonkey
    Soul Shriven
    I used the fix suggested by Tech support above (setting numeric values to "1"), and it did allow me to play the game for a while, albeit with pretty bad fps. However, I just experienced another crash with the same report as before. ZOS, please do let us know if a fix is incoming, as the suggested workaround is clearly not an ideal solution.
  • Ironheart
    Ironheart
    Hi there,

    here the same. I have a iMac Pro (Radeon Pro Vega 64) and the german support say to me "your videocard ist to slow! buy a better Videocard" ! :D

    I been change with xcode to only 8 Core and it's work.

    I hope Bethesda fixing this Problem that we again use all cores can. Because with 8 cores now runs fan more often then before.

    sry 4 my english! :)
  • bitranch
    bitranch
    Soul Shriven
    I'm using a combination of the user settings, and everything has been running fine. I got about 10% better fps using the xcode fix, but changing the settings file requires a lot less fiddling and is ESO specific.

    Here's what I currently have it set to:
    SET MaxCoresToUse.4 "8"
    SET RequestedNumJobThreads "0"
    SET RequestedNumWorkerThreads "0"
    

    Thanks to everyone for discovering the cause and working through fixes!
  • Wodinn
    Wodinn
    ✭✭✭
    Ironheart wrote: »
    Hi there,

    here the same. I have a iMac Pro (Radeon Pro Vega 64) and the german support say to me "your videocard ist to slow! buy a better Videocard" ! :D

    I been change with xcode to only 8 Core and it's work.

    I hope Bethesda fixing this Problem that we again use all cores can. Because with 8 cores now runs fan more often then before.

    sry 4 my english! :)

    The 'German' devs don't know wtf they are talking about. The pro Vega 64 is MORE than enough to handle this game. I'm on the baseline iMac Pro, mine has the 56 card and I get great fps. Well not right now, but typically.
  • ZeBlade
    ZeBlade
    ✭✭
    Like to say THANKS. Why THEY can not come up with a fix yet the PUBLIC can.. anyway thanks
  • Wodinn
    Wodinn
    ✭✭✭
    Just hit the same damn problem after the last update. I know about the fix, I cannot find the Usertext.txt file. I don't understand what happened. I keep going into the docs folder, I can see the Live folder. The folders that are in it though, Are all empty. I'm sick of this. what the *** do I do?
    Edited by Wodinn on June 13, 2018 4:15AM
  • sphane
    sphane
    ✭✭✭
    Wodinn wrote: »
    Just hit the same damn problem after the last update. I know about the fix, I cannot find the Usertext.txt file. I don't understand what happened. I keep going into the docs folder, I can see the Live folder. The folders that are in it though, Are all empty. I'm sick of this. what the *** do I do?

    Usual path is ~/Documents/Elder Scrolls Online/live/UserSettings.txt where ~/ stands for /Users/username/ where username is your login.

    If you can't find the file here, are you making back-up with Time Machine ? If so, try to restore it.

    If directory hierarchy ~/Documents/Elder Scrolls Online/live is empty, delete it. If launching the game can't create again the hierarchy and the user setting file before crashing, maybe you should try to use the first workaround with Xcode Instruments once to regenerate the user setting file.

    Hope this helps.
  • Wodinn
    Wodinn
    ✭✭✭
    Thank you for the suggestion. Trying this now, All I wanted to do was get my daily login, and maybe do some stuff in wrothgar. D:
Sign In or Register to comment.