Maintenance for the week of October 15:
• PC/Mac: No maintenance – October 15
• ESO Store and Account System for maintenance – October 16, 6:00AM EDT (10:00 UTC)
• PC/Mac: North American and European megaservers for maintenance – October 17, 6:00AM EDT (10:00 UTC)
• Xbox One: North American and European megaservers for maintenance – October 17, 6:00AM EDT (10:00 UTC)
• PlayStation®4: North American and European megaservers for maintenance – October 17, 6:00AM EDT (10:00 UTC)

Instant crash on my Mac [Workaround]

sphane
sphane
✭✭✭
Hi,

Since summerset upgrade, i am getting instant crash while launching the game from launcher or executable (black screen then crash reporter). I did repare process with no success. I restored the game from Time machine then relaunched update download. Same result. I am now reinstalling game from scratch but well...

My set up is Mac Pro 5,1(mid 2010), AMD Radeon HD 7950 3gb, Mac OS 11.6. All was fine and smooth since 64 bits arrived.

Anyone running same kind on configuration with no trouble ?

Any advice to fix this ?

Will upgrading to High Sierra Help to fix (dont really want to but....) ?

Thanks,
S.


Final workaround proposition without downgrading hardware with Xcode Instrument :

1.Edit ~/Documents/Elder Scrolls Online/live/UserSettings.txt
2. Find SET MaxCoresToUse.4 "-1" line
3. Replace "-1" with number of cores of 1 CPU. For example 8 or 6 depend on your hardware architecture.

Alternate Solution provided by support to one of us experiencing this problem :

1.Edit ~/Documents/Elder Scrolls Online/live/UserSettings.txt
2. Find SET RequestedNumJobThreads "-1" AND SET RequestedNumWorkerThreads "-1"
3 Replace -1 with 1 in both lines

Note : from my experience solution 1 is giving 10-15% better fps. Might not be significant on all configurations.
Edited by sphane on May 24, 2018 1:25AM
  • bitranch
    bitranch
    Soul Shriven
    Same problem here -- click Play, black screen, then crash.

    High Sierra (10.13.4) on iMac Pro (2017) 64 GB, Radeon Pro Vega 8176 MB

    I started with the update, repaired, did a full reinstall. No add-ons. All attempts result in the same quick crash.

    It's throwing a segmentation fault 11. EXC_BAD_ACCESS (SIGSEGV)

    Everything was running fine before the update this morning.
  • bitranch
    bitranch
    Soul Shriven
    I attempted to file a ticket, but Game Consultant hangs -- or it takes more than 20 minutes to run. (It's burning CPU, so maybe it's doing something useful.) The ticket system won't let me file a ticket without a Game Consultant file, so I have no way to get someone's attention on this.
  • sphane
    sphane
    ✭✭✭
    same trouble with game consultant as well
  • Wodinn
    Wodinn
    I also am having the same problem. On baseline iMac pro. Uninstalled and reinstalling now through the launcher. But my game was running just fine yesterday.
  • ZOS_BillE
    ZOS_BillE
    mod
    If you are experiencing crashes on your Mac after the Summerset update, please try the troubleshooting in the article below.

    What can I do if ESO is crashing frequently while playing on a Mac?

    If you still can't launch the game after trying these steps, you should contact customer support to open a ticket.
    The Elder Scrolls Online: Tamriel Unlimited - ZeniMax Online Studios
    Forum Rules | Code of Conduct | Terms of Service | Home Page | Help Site
    Staff Post
  • starfishhunter
    starfishhunter
    Soul Shriven
    I am having this same issue and am using an iMac Pro as well. Everything was fine until yesterday. It is an instant crash at startup that gives the code EXC_BAD_ACCESS (SIGSEGV). It is obviously not a resource issue since we are running pretty powerful machines. It isn't the launcher (which was what was suggested by the online help) since directly running esp.app does the same thing. I tried safemode in case it was a software conflict and that didn't seem to work. I even tried a repair and not surprisingly that failed to fix the issue.

    I am happy to submit a ticket however I do not know how to do this without the game consultant file. The kicker is everytime I try and run the game consultant it freezes. I have tried to run it for at least 1.5 hours and it never progresses it just keeps thinking...

    Help!
  • bitranch
    bitranch
    Soul Shriven
    @ZOS_BillE

    I don't think you actually read what we wrote here and just spit out a canned response.

    1. All three people reporting here have made it obvious that we've attempted far more than the troubleshooting article suggests.
    2. The Game Consultant hangs (I let it run for 3+ hours last night) and thus it is impossible to open a ticket. Your ticketing system requires a Game Consultant file before it will allow me to post a ticket. Because Game Consultant hangs, there is no way to provide that file, and thus there is NO WAY TO OPEN A TICKET on this issue.
  • sphane
    sphane
    ✭✭✭
    @ZOS_BillE

    All described here and more have been attempted.

    I installed PTS, and issue is exactly the same.

    Cherry on the cake or murphy's law. Cant access to page support to open ticket (obviously i can't open ticket as stated here since game consultant running in the void) even after resetting password... any issue on going this side too ?
  • bitranch
    bitranch
    Soul Shriven
    @ZOS_GinaBruno

    Could we please get some kind of attention to this issue above the level of pasted-boilerplate tech support? We need somebody that can understand that the game crashes on startup and NONE of us can create a ticket because the Game Consultant hangs and a Game Consultant file is required in order to create a ticket.
  • sphane
    sphane
    ✭✭✭
    God dammit !

    It's linked to the multi-core change in architecture.

    I manually reduced the numbers of core using Instrument (coming with Xcode) and then game started.

    On first try performance are terrible, will try to adjust...

    @ZOS_BillE can you look into this ?

    Update : game launched when i divide core usage by 2.
    Edited by sphane on May 22, 2018 3:06PM
  • Wodinn
    Wodinn
    ZOS_BillE wrote: »
    If you are experiencing crashes on your Mac after the Summerset update, please try the troubleshooting in the article below.

    What can I do if ESO is crashing frequently while playing on a Mac?

    If you still can't launch the game after trying these steps, you should contact customer support to open a ticket.

    Nothing has changed. And this 'auto response' does nothing to help. This NEEDS TO BE DELT WITH... or those of us with eso+ should get reimbursed for the time we are unable to play the game, or even get the consultant to work to submit a support ticket.

    We are waiting...
  • Wodinn
    Wodinn
    sphane wrote: »
    God dammit !

    It's linked to the multi-core change in architecture.

    I manually reduced the numbers of core using Instrument (coming with Xcode) and then game started.

    On first try performance are terrible, will try to adjust...

    @ZOS_BillE can you look into this ?

    Update : game launched when i divide core usage by 2.


    I don't know how the hells to do that.
  • bitranch
    bitranch
    Soul Shriven
    sphane wrote: »
    Update : game launched when i divide core usage by 2.

    @sphane

    Can you get Game Consultant to run with that config? Hoping somebody can get a ticket submitted and maybe get some actual attention to this issue.
    Edited by bitranch on May 22, 2018 3:41PM
  • sphane
    sphane
    ✭✭✭
    bitranch wrote: »
    sphane wrote: »
    Update : game launched when i divide core usage by 2.

    @sphane

    Can you get Game Consultant to run with that config? Hoping somebody can get a ticket submitted and maybe get some actual attention to this issue.

    Sure will try
  • Wodinn
    Wodinn
    sphane wrote: »
    bitranch wrote: »
    sphane wrote: »
    Update : game launched when i divide core usage by 2.

    @sphane

    Can you get Game Consultant to run with that config? Hoping somebody can get a ticket submitted and maybe get some actual attention to this issue.

    Sure will try

    Thank you for trying for us. This is getting pretty frustrating. And good luck with it.
  • sphane
    sphane
    ✭✭✭
    Wodinn wrote: »
    sphane wrote: »
    God dammit !

    It's linked to the multi-core change in architecture.

    I manually reduced the numbers of core using Instrument (coming with Xcode) and then game started.

    On first try performance are terrible, will try to adjust...

    @ZOS_BillE can you look into this ?

    Update : game launched when i divide core usage by 2.


    I don't know how the hells to do that.

    1.Install Xcode (might take a while 5Gb or so if i remember well) from Appstore.
    2. Among tools coming there is an App called "Instrument"
    3. Launch it and in Preference panel there is a slider to reduce the number of cores to use. Its not permanent. You can revert or it's reverted when restarting your computer. Normally its for developers who want to test performance of there apps.
  • sphane
    sphane
    ✭✭✭
    Wodinn wrote: »
    sphane wrote: »
    bitranch wrote: »
    sphane wrote: »
    Update : game launched when i divide core usage by 2.

    @sphane

    Can you get Game Consultant to run with that config? Hoping somebody can get a ticket submitted and maybe get some actual attention to this issue.

    Sure will try

    Thank you for trying for us. This is getting pretty frustrating. And good luck with it.

    Game consultant not working better. Sorry...

    It Remains stucked or idle most of the time. On log (./Launcher.app/Contents/MacOS/host.developer.log) last line is "Unsupported cursor (move) using default instead. To implement this cursor add move.png to the Resources directory" then nothing seems to happen... process monitoring report it as idle or stucked.
  • bitranch
    bitranch
    Soul Shriven
    @sphane

    I can verify that reducing cores from 16 to 8 allows the game to run. It's an extremely hackish workaround, but it works. Thanks for finding that!

    Later in the day, I'll see if I can file a ticket from within the game.
  • Wodinn
    Wodinn
    Still not working. I haven't tried anything with the cores. But this is ridiculous.
  • Wodinn
    Wodinn
    sphane wrote: »
    Wodinn wrote: »
    sphane wrote: »
    God dammit !

    It's linked to the multi-core change in architecture.

    I manually reduced the numbers of core using Instrument (coming with Xcode) and then game started.

    On first try performance are terrible, will try to adjust...

    @ZOS_BillE can you look into this ?

    Update : game launched when i divide core usage by 2.


    I don't know how the hells to do that.

    1.Install Xcode (might take a while 5Gb or so if i remember well) from Appstore.
    2. Among tools coming there is an App called "Instrument"
    3. Launch it and in Preference panel there is a slider to reduce the number of cores to use. Its not permanent. You can revert or it's reverted when restarting your computer. Normally its for developers who want to test performance of there apps.

    I can find 'instruments', but I don't see a preference panel anywhere. Any word from ZoS at all?
  • sphane
    sphane
    ✭✭✭
    Wodinn wrote: »
    sphane wrote: »
    Wodinn wrote: »
    sphane wrote: »
    God dammit !

    It's linked to the multi-core change in architecture.

    I manually reduced the numbers of core using Instrument (coming with Xcode) and then game started.

    On first try performance are terrible, will try to adjust...

    @ZOS_BillE can you look into this ?

    Update : game launched when i divide core usage by 2.


    I don't know how the hells to do that.

    1.Install Xcode (might take a while 5Gb or so if i remember well) from Appstore.
    2. Among tools coming there is an App called "Instrument"
    3. Launch it and in Preference panel there is a slider to reduce the number of cores to use. Its not permanent. You can revert or it's reverted when restarting your computer. Normally its for developers who want to test performance of there apps.

    I can find 'instruments', but I don't see a preference panel anywhere. Any word from ZoS at all?

    1.Go in Menu Instruments then choose Preferences.
    2.Go through panels (it depends on your version, mine is 7.3 and it's in CPU panel), might be in "General" or "CPU" but anyway find a slider saying "Active Processor cores". Probably it will go from 1 to 16 (i guess you have 2 CPU) then put to 8. It's immediate. Then launch the game. When you are done, just bring it back to 16. Or just restart your computer

    I am afraid, it will not be fixed soon, I guess On Mac, developers have considered only 1 CPU multi-core to make their changes. Our configurations seems "too strong"...

    @ZOS_GinaBruno .
    Edited by sphane on May 22, 2018 11:49PM
  • Wodinn
    Wodinn
    I finally found it. But it won't let me *** do it. Keep asking me for my password, repeatedly. WHY THE F is my luck so ***. This whole thing is *** ***
  • Wodinn
    Wodinn
    Wodinn wrote: »
    I finally found it. But it won't let me *** do it. Keep asking me for my password, repeatedly. WHY THE F is my luck so ***. This whole thing is *** ***

    ok nvm. Replied too soon.
  • starfishhunter
    starfishhunter
    Soul Shriven
    I tried this work around with Xcode. I can confirm that the game can now launch with only 8 cores being used however I now have a different problem. It is telling me I have an old client that needs to be updated! It then dumps me right back out. Since I do have the updated client I really don't have the foggiest at this point.
  • sphane
    sphane
    ✭✭✭
    I tried this work around with Xcode. I can confirm that the game can now launch with only 8 cores being used however I now have a different problem. It is telling me I have an old client that needs to be updated! It then dumps me right back out. Since I do have the updated client I really don't have the foggiest at this point.

    There is a maintenance on going with a client update. Maybe tied to that ?
  • Wodinn
    Wodinn
    I can also confirm that, decreasing core usage, through Xcode does work. I finally was able to figure it out myself. And yes they are doing NA maintenance today.
  • Annelid01
    Annelid01
    Soul Shriven
    Pity if you do not have Xcode and are stuck on Sierra for other reasons.
  • Rowjoh
    Rowjoh
    ✭✭✭
    Same issue here - I click Play then immediate crash with crash report.

    High Sierra (10.13.4) on Mac Pro (late 2013)

    I've updated, repaired, reinstalled. No add-ons. All attempts result in the same crash.

    Report is showing:

    Exception Type: EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000078
    Exception Note: EXC_CORPSE_NOTIFY

    Termination Signal: Segmentation fault: 11

    Everything was running perfectly before the update :(
  • Rowjoh
    Rowjoh
    ✭✭✭
    The workaround detailed by @sphane solved it for me, and I don't have any performance or graphics degradation either.

    Genius!
    Edited by Rowjoh on May 23, 2018 8:59PM
  • Wodinn
    Wodinn
    Rowjoh wrote: »
    The workaround detailed by @sphane solved it for me, and I don't have any performance or graphics degradation either.

    Genius!

    I read the patch notes for the update today. I'm no programmer at all, but in the performance section it did make mention that they made changes so that that game would finally make use of multiple core cpu's. I can't help but think either that, or the multithreading has something to do with this. Again, I'm no programmer, this is just a guess. Taking that into consideration, and a couple of other points they made on that topic. Decreasing the amount of cpu cores right now, temporarily, won't make any difference on the performance. tbh, my game seems to play smoother, and looks a bit better even.
Sign In or Register to comment.