Maintenance for the week of April 15:
• PC/Mac: No maintenance – April 15
• ESO Store and Account System for maintenance – April 16, 8:00AM EDT (12:00 UTC) - 12:00PM EDT (16:00 UTC)

Issues related to loading and/or zoning on the NA Xbox One server are NOT RESOLVED

Simply unable to play the game since around 15:30 AEST 25th May.

Group of four people trying to do Vet White Gold and between us we cannot get to the dungeon nor can one member get to Grahtwood. This includes trying to go from wayshrine into dungeon or restarting XBOX then trying to pay to travel into the dungeon. Everyone attempting WGT get long load screens. Player trying to get to Grahtwood also gets long load screen.

This is not a local issue as player are geographically dispersed so no amount of restarting XBOX or rebooting router is going to fix it. The performance of the game has gotten progressively worse after each of the last maintenance periods with ZOS having to conduct emergency maintenance that doesn't resolve the issue.

Even trying to do stuff in R'Wlaka is getting impossible. Increasing lag/delays interfering with using vendor or crafting stations.

@ZOS_DaryaK or @ZOS_JessicaFolsom can you please help and comment on why this is occurring?
  • johu31
    Same. Cannot get to Grahtwood to get my pledge. Friends of mine said it took them 15 minutes to load into Crypt of hearts.
  • wellendaoud
    I can't even play my character because I got disconnected on the border of Malabal Tor and Grahtwood. Will never load Grahtwood. Please fix
  • Caff32
  • yynari
    Soul Shriven
    My main is in grahtwood (elden root) cannot load in. My secondary cannot travel there
  • Enigmatic
    Having tried to play again further this evening it seems I can play ESO just so long as:
    1. I don't want to go to Grahtwood
    2. I don't want to go into a dungeon
    3. I don'g want to go into a delve

    @ZOS_DaryaK or @ZOS_JessicaFolsom can you please help and comment on why this is still occurring?
  • ZOS_JessicaFolsom
    Community Manager
    Hey everyone, please head over to this thread. We're working on this issue and need a few details from you.
    Jessica Folsom
    Lead Community Manager - ZeniMax Online Studios
    Facebook | Twitter | Twitch | Tumblr | Instagram | YouTube | Support
    Staff Post
  • yynari
    Soul Shriven
    After trying off and on for several hours, I was finally able to load my main char. Previous to this instance I was getting an infinite load screen (to the point of being disconnected due to inactivity) every time I tried to log in to this character (Yynari, high elf sorc, aldmeri dominion). As I said before, my last log off was from Elden Root in Grahtwood.

    My other char was in reapers March and I was able to log into it and even enter my campaign in cyrodil. I just wasn't able to travel to grahtwood. If I have any more issues I'll post the extra info
Sign In or Register to comment.