We are currently investigating issues some players are having regarding logging into the European PlayStation®4 megaserver. We will update as new information becomes available.
Maintenance for the week of June 17:
· [COMPLETE] Xbox One: NA and EU megaservers for patch maintenance – June 19, 6:00AM EDT (10:00 UTC) – 10:00AM EDT (14:00 UTC)
· [COMPLETE] PlayStation®4: EU megaservers for patch maintenance – June 19, 6:00AM EDT (10:00 UTC) – 12:00PM EDT (16:00 UTC)
· [IN PROGRESS] PlayStation®4: NA megaservers for patch maintenance – June 19, 6:00AM EDT (10:00 UTC) – 12:00PM EDT (16:00 UTC)

Holding mouse buttons down and dragging causes... problems

Midnight3v0
Midnight3v0
Soul Shriven
Soo, I've palyed the beta and about a month in after launch, then stopped. It is now over a year later that I now got back into playing it. The bug is still here!!! Every time I hold down Mouse1, Mouse2, or Mouse3, and start to drag, my camera starts to go berserk. Example: If i hold down Mouse1 and drag to the left, the first inch, moves the camera to the left just fine, but when i start to move more to the left, it starts to go way too much to the left and then i start doing five full circles around my character within 6 inches of moving to the left. I'm starting to play with some friends again, and I feel like i can only play classes that battles from afar because...blocking while moving is impossible. Please fix bug or tell me what i have to do to fix it.

Here are my specs:
Macbook air 2013 13-inch
1.3 GHz Intel Core i5
4 GB 1600 MHz DDR3
Intel HD Graphics 5000 1536 MB
Software: OS X 10.9.5
  • Midnight3v0
    Midnight3v0
    Soul Shriven
    I usually play on medium graphics and windowed (Fullscreen)
  • KhajitFurTrader
    KhajitFurTrader
    Community-Botschafter
    @Midnigh3v0, what kind of mouse are you using? Is is a customizable mouse with its own software (e.g. Logitech Gaming Software)? If so, is both mouse firmware and driver software on the newest version?
  • Midnight3v0
    Midnight3v0
    Soul Shriven
    It just a standard Microsoft mouse no customizations, no dpi changer, nothing :(
  • KhajitFurTrader
    KhajitFurTrader
    Community-Botschafter
    Sorry if the following looks a bit incoherent, I'm just picking my brain here for possible reasons. :smiley:

    Do you have a model name, and how old is it? Also, on what kind of surface are you using the mouse? Are the LED and optical sensor clear and unobstructed?

    Are you noticing the same (or other) quirks elsewhere as well, e.g. with other games, apps, or on the desktop?

    Have you tried disabling or uninstalling all addons (if you're using any), to see whether the effect still occurs?

    What are the values of the following settings in your file ~/Documents/Elder Scrolls Online/live/UserSettings.txt (use liveeu instead if you're playing on the EU megaserver):
    SET MouseRawInput "1"
    SET MouseSensitivityFirstPerson "0.50000000"
    SET MouseSensitivityThirdPerson "1.00000000"
    SET MouseSmoothing "0"
    SET InvertMouseWheel "1"
    SET InvertMouseY "1"
    SET InvertMouseX "1"
    
    These should be the default values.

    Do you notice a different behavior if you invert the values for MouseRawInput or MouseSmoothing?
  • chris.dillman
    chris.dillman
    ✭✭✭
    It just a standard Microsoft mouse no customizations, no dpi changer, nothing :(

    Hi
    So far we have not seen this issue on any of our Macs.

    You don't have an external monitor hooked up?

    Have you tried a normal apple mouse?
    -- ESO -- Lead Mac Programmer...
    Staff Post
  • Attorneyatlawl
    Attorneyatlawl
    Community Ambassador
    That sounds like how cursor acceleration or a glide feature behaves if you have the base settings at what you'd normally use and it got enabled. Make sure nothing you're using is causing it to be enabled in OS X or any software on the computer in general. Also as @KhajitFurTrader asked, it's important to know for troubleshooting if it's affecting the mouse/cursor system wide or if it's only happening for you in ESO.

    -First-Wave Closed Beta Tester of the Psijic Order, aka the 0.016 percent. =P
    Exploits suck. Don't blame just the game, blame the players abusing them!

    -Playing since July 2013, back when we had a killspam channel in Cyrodiil and the lands of Tamriel were roamed by dinosaurs.
    -Order of Mundus, Nightfighters, LoM, and Mostly Harmless founding member, "DPS: We Deliver."
    ________________
    -In-game mains abound with "Nerf" in their name. As I am asked occasionally, I do not play on anything but the PC NA Megaserver at this time.
  • Midnight3v0
    Midnight3v0
    Soul Shriven
    I have not tried a standard mouse and I do not use an external monitor.By the way, its weird that you have not dealt with this issue before. My brother has a 2014 macbook air, and he has the same problem as mine. He didn't sent a request for help yet, because I'm doing it :)
  • Midnight3v0
    Midnight3v0
    Soul Shriven
    Sorry if the following looks a bit incoherent, I'm just picking my brain here for possible reasons. :smiley:

    Do you have a model name, and how old is it? Also, on what kind of surface are you using the mouse? Are the LED and optical sensor clear and unobstructed?

    Are you noticing the same (or other) quirks elsewhere as well, e.g. with other games, apps, or on the desktop?

    Have you tried disabling or uninstalling all addons (if you're using any), to see whether the effect still occurs?

    What are the values of the following settings in your file ~/Documents/Elder Scrolls Online/live/UserSettings.txt (use liveeu instead if you're playing on the EU megaserver):
    SET MouseRawInput "1"
    SET MouseSensitivityFirstPerson "0.50000000"
    SET MouseSensitivityThirdPerson "1.00000000"
    SET MouseSmoothing "0"
    SET InvertMouseWheel "1"
    SET InvertMouseY "1"
    SET InvertMouseX "1"
    These should be the default values.
    
    Sorry for the delay in response, I had to attend my cousin's wedding :)

    Do you notice a different behavior if you invert the values for MouseRawInput or MouseSmoothing?

    Just a standard free Compaq mouse you get along with a Compaq computer.

    I have a family member who has a macbook air 2014 and he has the same problem as me :(

    This problem happened with or without addons

    I have not tried to do that yet and I am typing this message as i read your post. I noticed that everything is by default, your values mentioned besides Mousesmoothing which was set to "1". I Just set it to 0 to see if it makes a difference, WISH ME LUCK!
    -2 min later: I feel like putting MouseSmoothing to 0, did not fix the problem, although... it reduced the amount "craziness" that happens.

    I think that maybe the problem lies behind Mousesmoothing? I really don't know for sure.

    By the way, Thanks for your time and effort you put into looking at my probl
  • chris.dillman
    chris.dillman
    ✭✭✭
    Midnight3v0

    Are you playing on a external monitor or anything?

    -- ESO -- Lead Mac Programmer...
    Staff Post
  • Midnight3v0
    Midnight3v0
    Soul Shriven
    Midnight3v0

    Are you playing on a external monitor or anything?

    No :(
  • Windshadow_ESO
    Windshadow_ESO
    ✭✭✭
    When you unplug the mouse and restart the computer with the mouse unplugged does the problem exist with just the trackpad?
  • Midnight3v0
    Midnight3v0
    Soul Shriven
    When you unplug the mouse and restart the computer with the mouse unplugged does the problem exist with just the trackpad?

    Nope, Trackpad does not have the problem. When I plug in the Mouse, the problem starts, then when I take it out and replace another mouse, still same problem. Trackpad, in the other hand will always work fine. Dragging with 3 fingers (counts as a mouse click hold and drag), works just fine.
  • chris.dillman
    chris.dillman
    ✭✭✭
    ESO has no actual idea if the input is coming from a mouse or a track pad.

    It is all the same input.

    That makes it look like a mouse or driver is sending bad input or something.

    We still can't recreate the problem.

    We have tested with a number of USB and apple bluetooth mice.

    Edited by chris.dillman on August 19, 2015 9:26PM
    -- ESO -- Lead Mac Programmer...
    Staff Post
  • GTech_1
    GTech_1
    ✭✭✭✭
    As @Attorneyatlawl mentioned above, this sounds to me like a basic mouse pointer acceleration issue.

    Issues like this can occur based upon the mouse settings in your OS.
    With certain settings enabled, the faster you move the mouse, the more it accelerates.
    Side note: The point of mouse pointer acceleration is to enable the use of a large screen, while only having a small space for your mouse.

    Where you find these settings will differ, based on your OS. I'd tell you exactly where to look, and how to change them, but Macs are not my specialty.

    Hope this helps,
    ~GTech_1
Sign In or Register to comment.