Holy "out of date" Batman!

Gillysan
Gillysan
✭✭✭✭
Gotta love big patch days. I saved my variables, now the waiting begins. I think 90% of my addons show out of date even though 11 were just updated.
  • Wykkyd
    Wykkyd
    ✭✭✭✭✭
    Out of date does not mean broken.
  • Nestor
    Nestor
    Community Ambassador
    Wykkyd wrote: »
    Out of date does not mean broken.

    Kind of does in some cases. Since the Craft Store has not been updated, I tried the Research Assistant. Ended up losing each every piece of heavy armor that I was saving for research as RA told me I had already researched them. Lucky I noticed this after just my Blacksmither went through the armor, and not the weapons which I have a lot more of. You would have heard the screams if this had happened with my Clothing/Woodworker

    Looks like I have to go back to a spread sheet for this.

    For the record, this was with an updated for patch 1.4 Research Assistant

    Enjoy the game, life is what you really want to be worried about.

    PakKat "Everything was going well, until I died"
    Gary Gravestink "I am glad you died, I needed the help"

  • Garkin
    Garkin
    ✭✭✭
    Bug in Resarch Assistant is already fixed, just update it to the latest version.
    Garkin / EU / CSF guild
    My addons: SkyShards, LoreBooks, Dustman, Map Coordinates, No, thank you, ... (full list)
    I'm taking care of: Azurah - Interface Enhanced, Srendarr - Aura, Buff & Debuff Tracker and more
    My folder with updated/modified addons: DROPBOX
  • Wykkyd
    Wykkyd
    ✭✭✭✭✭
    Nestor wrote: »
    Wykkyd wrote: »
    Out of date does not mean broken.

    Kind of does in some cases. Since the Craft Store has not been updated, I tried the Research Assistant. Ended up losing each every piece of heavy armor that I was saving for research as RA told me I had already researched them. Lucky I noticed this after just my Blacksmither went through the armor, and not the weapons which I have a lot more of. You would have heard the screams if this had happened with my Clothing/Woodworker

    Looks like I have to go back to a spread sheet for this.

    For the record, this was with an updated for patch 1.4 Research Assistant
    Actually "Out Of Date" literally means the author didn't declare the current API version in their addon manifest. I could upload a version of my addons today with API version 100008 declared instead of 100009 and they would show up as "Out Of Date" even though they're perfectly functional.

    An addon isn't broken unless it actually breaks or does not function, which has nothing whatsoever to do with the "Out Of Date" flag.
  • Phinix1
    Phinix1
    ✭✭✭✭✭
    ✭✭✭✭✭
    Wykkyd wrote: »
    An addon isn't broken unless it actually breaks or does not function, which has nothing whatsoever to do with the "Out Of Date" flag.

    THIS.

    9 times out of 10, the only thing needed to "fix" an addon for a new patch is literally to edit the API version in a single line of code. The API changes this update were pretty moderate. Most addons either didn't use them or have already been updated.

    For example, check out all the addons I have listed in the 2nd post of PhinixUI addon-powered interface for ESO. All of those addons either work without updates or have been updated already.

    Incidentally, I have updated my own UI config to the latest patch (Update 4) with all the latest changes to the SavedVariables files for the various addons.

    Also, cool to see both Garkin and Wykkyd hang out here. /respect
    Edited by Phinix1 on September 17, 2014 5:30AM
Sign In or Register to comment.