The Scribes of Fate DLC and Update 37 base game patch are now available to test on the PTS! You can read the latest patch notes here: https://forums.elderscrollsonline.com/en/categories/pts
Maintenance for the week of February 6:
· [IN PROGRESS] NA megaservers for patch maintenance – February 9, 4:00AM EST (9:00 UTC) - 10:00AM EST (15:00 UTC)
· [IN PROGRESS] EU megaservers for patch maintenance – February 9, 9:00 UTC (4:00AM EST) - 15:00 UTC (10:00AM EST)

Cannot cap FPS

mickeyrourke
mickeyrourke
Soul Shriven
My pc runs pretty hot when playing eso. I play on a 13 inch Retina MacBook Pro late 2013. Settings are set to minimum/low at 1280x800.

I can cap fps to 60 by enabling vsync but i still feel like the pc is heating up too much in most places in-game (especially when talking to NPCs).

Therefore i want to try to cap the fps at, lets say, 40 fps to see if it runs cooler. I found this post on the forum http://forums.elderscrollsonline.com/discussion/74459/can-i-cap-fps
where a guy says that you can cap fps by changing SET MinFrameTime.2 "0.01000000" in the UserSetting.txt file located in the folder: documents/Elder Scrolls Online/live

If I want 40 fps i have to set the variable to 0.02500000 since 1/40 = 0.025
(I do this while both game and launcher is closed)

Unfortunately this doesn't work. I still get 80-100 fps when vsync is OFF and 60 fps when vsync is ON.

Please. Any help would be highly appreciated.

  • Enigmatix
    Enigmatix
    Did you close your client before editing the user settings?
    Edited by Enigmatix on July 5, 2014 6:14PM
  • mickeyrourke
    mickeyrourke
    Soul Shriven
    Enigmatix wrote: »
    Did you close your client before editing the user settings?

    Yes I did, as I said in the post.

  • viktorcodeneb18_ESO
    Unfortunately, undocumented settings aren’t guaranteed to work, so there might be no way to cap FPS below 60.

    However, I can give you an advice based on my own experience of overheating Macs. See, 60 fps of any graphics should be enough to not overheat. Do you have Macbook / Macbook Pro? Several models of Apple notebooks have issues with cooling because the exhaust grille gets clogged with dust. I routinely disassemble Macbook Pro to clean the cooling grille. The temperature difference before and after the cleaning is like night and day: where I could cook an egg earlier I can rest my palm comfortably now.

    Hope this helps.
  • Moonraker
    Moonraker
    ✭✭✭✭
    When you alter UserSettings via TextEdit ensure that smart quotes are off or it changes these and changes don't work.

    For the Mac in Text Edit you actually need to switch off Edit > Substitutions > Smart Quotes which is what changes the quote marks and they wont work. I switch them off in the Preferences otherwise you need to do it each time you open the document.

    Try that. Otherwise I just adjust settings myself to give a range of FPS I want so setting shadows up one etc. will usually reduce under 60FPS.
  • Gix
    Gix
    ✭✭✭✭
    What I've noticed (at least on my computer) is that, if you really want to have a resolution of 1280x800, you should probably do that within the OS and not the game... since, in my experience, the game is being treated like a fullscreen window despite having the option of "fullscreen".

    Each time I load up ESO, I go to my display system preferences and use the "scaled" resolution change feature.

    Luckily, for me, my framerate stays around 30fps, as it should be for a laptop.

    I can also confirm the whole "smart quotes" thing that Moonraker suggests. Without doing that, any setting you apply seem to be revert it back... no matter how many times you save and/or lock the file.
  • Moonraker
    Moonraker
    ✭✭✭✭
    Gix wrote: »
    What I've noticed (at least on my computer) is that, if you really want to have a resolution of 1280x800, you should probably do that within the OS and not the game... since, in my experience, the game is being treated like a fullscreen window despite having the option of "fullscreen".

    Each time I load up ESO, I go to my display system preferences and use the "scaled" resolution change feature.

    Luckily, for me, my framerate stays around 30fps, as it should be for a laptop.

    I can also confirm the whole "smart quotes" thing that Moonraker suggests. Without doing that, any setting you apply seem to be revert it back... no matter how many times you save and/or lock the file.
    It actually works the other way where Fullscreen is true fullscreen and doesn't function as Windowed Fullscreen at all (i.e. Apple OS X key shortcuts don't work etc.) Though I think there is something different with MacBook Pro Retina if you use those related to how it scales so your suggestion may work for the OP which is not directly related to the FPS throttling (in fact will increase FPS from 1440 x 900)
Sign In or Register to comment.