Maintenance for the week of January 17:
• [COMPLETE] PlayStation®: NA megaserver for maintenance – January 19, 2:00AM EST (7:00 UTC) – 12:00PM EST (17:00 UTC)
• [COMPLETE] Xbox: NA and EU megaservers for maintenance – January 19, 6:00AM EST (11:00 UTC) – 10:00AM EST (15:00 UTC)
• [COMPLETE] PlayStation®: EU megaserver for maintenance – January 19, 6:00AM EST (11:00 UTC) – 10:00AM EST (15:00 UTC)
• ESO Store and Account System for maintenance – January 20, 8:00AM EST (13:00 UTC) – 3:00PM EST (20:00 UTC)

Is the altar in the Deadlights quest bugged? Or just me?

Sambucca1973
Sambucca1973
✭✭✭
Got the quest today that takes you to the Deadlights. One step is to “examine the altar”. I get to the altar with The Amchorite, it shows the quest objective icon kind of buried in the altar, and I couldn’t “examine” it. (Seems other people had a similar issue. A few of us running around trying to get that step done.)

Things I tried to see if it would fix it:

1. Jumping on the altar.
2. Shooting the altar.
3. Trying to see if there is a lower level that needed accessed. (If there is, it’s behind a locked gate that probably unlocks after you finish examining the altar.)
4. Reloaded UI. Twice.
5. Logged out and back in. Once.
6. Looked around for some switch or trigger but didn’t find one.

None of those fixed it. Stuck at the “examine altar” step with the quest icon in the altar.

Am I missing something? Or is this a bug? Thanks for your help.
  • SekaiXD
    SekaiXD
    I have the same problem.
  • Sambucca1973
    Sambucca1973
    ✭✭✭
    Well, good news kind of. Left and went back after 24 hours. Did NOT drop the quest.

    And the quest icon appeared above the altar and I could interact with it and continue the quest.

    Maybe wait a day and try again? Hope that works. Frustrating when it happens in the middle if a quest and in an area you can’t port right into.

    Also, there’s another step after that (forget which one) that also seemed broken. It’s not. It’s just that the hit box to interact is really small.
  • Old_Foggy
    Old_Foggy
    ✭✭✭
    I had the same issue with that alter and I logged my character out and back in and it worked for me.
  • SekaiXD
    SekaiXD
    Old_Foggy wrote: »
    I had the same issue with that alter and I logged my character out and back in and it worked for me.

    Me too.
  • jessica_1403
    Me too I left the zone and came back and then I could continue. I was running around with other players and I could see they had the same problem
  • etchedpixels
    etchedpixels
    ✭✭✭✭✭
    Same here - first character I did it on it worked perfectly second can't interact with it.

    When I log out and back in the arrow has moved higher up and it works
  • Metal10957
    Metal10957
    ✭✭✭
    Still buggy as of Dec. 18.
    For the Horde!
Sign In or Register to comment.