The Scribes of Fate DLC and Update 37 base game patch are now available to test on the PTS! You can read the latest patch notes here: https://forums.elderscrollsonline.com/en/categories/pts
Maintenance for the week of January 30:
• [COMPLETE] Xbox: NA and EU megaservers for maintenance – February 1, 6:00AM EST (11:00 UTC) - 9:00AM EST (14:00 UTC)
• [COMPLETE] PlayStation®: NA and EU megaservers for maintenance – February 1, 6:00AM EST (11:00 UTC) - 9:00AM EST (14:00 UTC)

6.3.8 crashing in the MoltenVK library

ioResult
ioResult
Soul Shriven
6.3.8 is crashing whenever I try to use a way shrine to go from one zone to another. This happens no matter how I set the graphics, from minimum all the way to highest settings. This didn't happen with 6.3.7. If I look at the crash log, the thread that is set faulting is one calling into the MoltenVK library to tell the AMD Radeon driver to render a texture. Looks like a bad memory value is being passed in and causing the graphics driver to crash.I sent the crash log in as a ticket but all I have gotten back thus far is a canned answer on trying things I've already tried. Any thoughts on how to diagnose this further? The game is essentially unplayable if one can't change zones without crashing the whole app.
Edited by ZOS_Chiroptera on May 4, 2021 1:51PM
  • ioResult
    ioResult
    Soul Shriven
    So @ZOS_GinaBruno does no one at ZOS care that I can't use a wayshrine without the game crashing?

    From the crash log...

    Crashed Thread: 28 Dispatch queue: MoltenVKQueue-0-0-1.0-Dispatch

    Exception Type: EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000018
    Exception Note: EXC_CORPSE_NOTIFY

    Termination Signal: Segmentation fault: 11
    Termination Reason: Namespace SIGNAL, Code 0xb
    Terminating Process: exc handler [2000]

    Thread 28 Crashed:: Dispatch queue: MoltenVKQueue-0-0-1.0-Dispatch
    0 com.apple.IOAccelerator 0x00007fff51f44514 IOAccelResourceDirtyBufferRange + 13
    1 com.apple.AMDRadeonX6000MTLDriver 0x00007fff20b297d1 amdMtl_HwCmdBufUpdateRsrc(AMD_HwCmdBufInfoRec*, MTLIOAccelResource*, unsigned int, unsigned int) + 218
    2 com.apple.AMDRadeonX6000MTLDriver 0x00007fff20b75084 amdMtl_GFX10_SetTexture(GFX10_RenderCmdEncoderMembersRec*, unsigned int, id<MTLTexture>, unsigned int, unsigned int) + 85
    3 com.zenimaxonline.eso 0x0000000106964ced MVKGraphicsResourcesCommandEncoderState::encodeImpl() + 653
    4 com.zenimaxonline.eso 0x0000000106943d7f MVKCommandEncoder::finalizeDrawState() + 63
    5 com.zenimaxonline.eso 0x0000000106941e55 MVKCmdDrawIndexed::encode(MVKCommandEncoder*) + 21
    6 com.zenimaxonline.eso 0x0000000106942c4b MVKCommandEncoder::encode(MVKQueueCommandBufferSubmission*) + 107
    7 com.zenimaxonline.eso 0x0000000106942aec MVKCommandBuffer::execute(MVKQueueCommandBufferSubmission*, MVKCommandBufferBatchPosition const&) + 124
    8 com.zenimaxonline.eso 0x0000000106957c7e MVKQueueCommandBufferSubmission::execute() + 110
    9 com.zenimaxonline.eso 0x0000000106956acc invocation function for block in MVKQueue::submit(MVKQueueSubmission*) + 28
    10 libdispatch.dylib 0x00007fff6729d6c4 _dispatch_call_block_and_release + 12
    11 libdispatch.dylib 0x00007fff6729e658 _dispatch_client_callout + 8
    12 libdispatch.dylib 0x00007fff672a3c44 _dispatch_lane_serial_drain + 597
    13 libdispatch.dylib 0x00007fff672a45d6 _dispatch_lane_invoke + 363
    14 libdispatch.dylib 0x00007fff672adc09 _dispatch_workloop_worker_thread + 596
    15 libsystem_pthread.dylib 0x00007fff674f8a3d _pthread_wqthread + 290
    16 libsystem_pthread.dylib 0x00007fff674f7b77 start_wqthread + 15

  • ioResult
    ioResult
    Soul Shriven
    Another crash log snippet...

    Are we calling into amdMtl_GFX10_SetTexture() with some nil pointer in 6.3.8?????

    Crashed Thread: 20 Dispatch queue: MoltenVKQueue-0-0-1.0-Dispatch

    Exception Type: EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000018
    Exception Note: EXC_CORPSE_NOTIFY

    Termination Signal: Segmentation fault: 11
    Termination Reason: Namespace SIGNAL, Code 0xb
    Terminating Process: exc handler [782]

    Thread 20 Crashed:: Dispatch queue: MoltenVKQueue-0-0-1.0-Dispatch
    0 com.apple.IOAccelerator 0x00007fff51f44514 IOAccelResourceDirtyBufferRange + 13
    1 com.apple.AMDRadeonX6000MTLDriver 0x00007fff20b297d1 amdMtl_HwCmdBufUpdateRsrc(AMD_HwCmdBufInfoRec*, MTLIOAccelResource*, unsigned int, unsigned int) + 218
    2 com.apple.AMDRadeonX6000MTLDriver 0x00007fff20b75084 amdMtl_GFX10_SetTexture(GFX10_RenderCmdEncoderMembersRec*, unsigned int, id<MTLTexture>, unsigned int, unsigned int) + 85
    3 com.zenimaxonline.eso 0x0000000110294ced MVKGraphicsResourcesCommandEncoderState::encodeImpl() + 653
    4 com.zenimaxonline.eso 0x0000000110273d7f MVKCommandEncoder::finalizeDrawState() + 63
    5 com.zenimaxonline.eso 0x0000000110271e55 MVKCmdDrawIndexed::encode(MVKCommandEncoder*) + 21
    6 com.zenimaxonline.eso 0x0000000110272c4b MVKCommandEncoder::encode(MVKQueueCommandBufferSubmission*) + 107
    7 com.zenimaxonline.eso 0x0000000110272aec MVKCommandBuffer::execute(MVKQueueCommandBufferSubmission*, MVKCommandBufferBatchPosition const&) + 124
    8 com.zenimaxonline.eso 0x0000000110287c7e MVKQueueCommandBufferSubmission::execute() + 110
    9 com.zenimaxonline.eso 0x0000000110286acc invocation function for block in MVKQueue::submit(MVKQueueSubmission*) + 28
    10 libdispatch.dylib 0x00007fff6729d6c4 _dispatch_call_block_and_release + 12
    11 libdispatch.dylib 0x00007fff6729e658 _dispatch_client_callout + 8
    12 libdispatch.dylib 0x00007fff672a3c44 _dispatch_lane_serial_drain + 597
    13 libdispatch.dylib 0x00007fff672a45d6 _dispatch_lane_invoke + 363
    14 libdispatch.dylib 0x00007fff672adc09 _dispatch_workloop_worker_thread + 596
    15 libsystem_pthread.dylib 0x00007fff674f8a3d _pthread_wqthread + 290
    16 libsystem_pthread.dylib 0x00007fff674f7b77 start_wqthread + 15
  • Roukoru
    Roukoru
    ✭✭
    from my experience of work as QA of several organizations, bug/crash reports are processed only when their number reached some critical amount. Reports about problems from a signle person are always ignored or branded as "Not A Bug" (or something like). Sad but true. :(
    p.s. I am, too, have my own set of weird bugs with client, all are in a "thank you for reporting! Have you read our troubleshooting FAQ?" line.
    置之死地而后生 (In the land of death -- fight!)
  • vgabor
    vgabor
    ✭✭✭✭✭
    Mac version has many crashes since years without ZOS doing anything about them, just look around in the Mac support forum you'll see plenty of similar reports. So chances are, you're stuck with this one for a while too...
    (looking at it the crash report seems familiar, I think this crash is one of those long ignored bugs, check the Mac forum I think you will find this one is reported plenty of times over the last few years)
    Edited by vgabor on May 3, 2021 9:04PM
  • Roukoru
    Roukoru
    ✭✭
    btw, on MacOS you may try to run windows client under wine with dxvk. This may (or may not) give you better results, comparing with native client.
    置之死地而后生 (In the land of death -- fight!)
  • doesurmindglow
    doesurmindglow
    ✭✭✭✭✭
    This is a common problem for Mac users (every. single. Mac user. in my guild that has responded to our poll is experiencing exactly this, as well as the various forums threads you can see here).

    You should open a ticket with ZOS so they have it on their radar: https://help.elderscrollsonline.com/app/incident

    They'll respond with some probably automated boilerplate about disabling your add-ons and repairing your game, which are reasonable first steps to at least rule those things out. Keep updating the ticket as the problem persists, though.

    In the meantime, I have seen the following advice from users on the forums that SEEM to HELP, though will not eliminate the problem, I've ordered these from easiest to most difficult in their implementation:
    1. Restart the computer and your router, modem, or any other systems in between your client and the game server. I'm sure you've done this already, but it's always a good first step.
    2. Unsummon/banish any combat and non-combat pets and assistants before attempting the instance change. Something in the modeling of these NPC assets triggers a race condition that results in the crash. This doesn't SOLVE the problem, but I have noticed it reduces the frequency.
    3. Leave fullscreen and resize the game window before attempting the instance change. I don't know why this works, though I suspect it has something to do with requiring less memory to render the smaller resolution.
    4. If you use Time Machine, roll back recent software updates to your MacOS. I've found the most stability in Catalina though the crashes still occur. I had the worst stability in Big Sur 11.3. This is ONLY based on MY OWN experience, and I've talked to people running the latest update that still crash but less often than I do, so do take this point with a grain of salt.
    5. If you have Bootcamp of Windows, try using the Windows client. It is much more stable than the Mac one at this point.
    6. If you have a Stadia account, try using their client. This is an interesting solution another forum contributor recommended that worked for him that allowed him to run ESO in MacOS but without issue. I think this introduces an added element of quality control through Google acting as a kind of "representative" for its customers.

    I hope some of this might help. I want to emphasize this is like, "folk advice" emerging from forum discussions and not a substitute for actual customer support, and that you should definitely pursue official customer support by submitting a ticket and updating it regularly. This is ultimately a problem only ZOS can fix by debugging their new approach to rendering model assets that was introduced in the Flames of Ambition patch. The Mac client uses MoltenVK to port Vulkan into Apple's graphics framework, and something in the code is creating graphical issues and a race condition when attempting to load in a new instance or zone.

    The good news is this MIGHT be addressed in the 7.0.x major patch (aka the Blackwood chapter). You won't have to buy the chapter to get it fixed (I'm not planning to, for example, until I know it is), as it is a bug fix to the base game that is merely delivered with that release. ZOS hasn't explicitly stated they're working on the issue for the Mac client and intend to fix it, but 7.0.1 patch notes did say this:
    The game now prevents memory-related crashing when attempting to load in a very large number of players, companions, and pets at the same time. There may still be undesired visual effects in these cases, which will be addressed in a later update.

    This statement, combined with my inability to replicate the issue on the PTS, gives me some hope it is actually being worked on and will be potentially solved. This is why I emphasize submitting a ticket, escalating it, and updating it regularly, even though the troubleshooting they'll provide you isn't likely to do much. It significantly increases the chances that someone working on the problem is both aware of the issue and has some information about what causes it.
    Guildmaster : The Wild Hunt : AD PC/NA
  • xPoisin
    xPoisin
    ✭✭✭
    After last patch I found that issues on Catalina got worse and I upgraded to Big Sur… In fact Inam able to do something but the game is unplayable right now… nothing helped…
    I play on Macbook Pro 13” with Intel i7 and it was running fine, but arter 6.3 it was getting worse and worse… I openned maybe 50 tickets under ces accounts but I still receiveonly the *** help like restart, reinstall, etc…
    Someone should look at the Mac user base and give us reasonable solution…
    I do not like the Stadia, because I cannot customize the video settings and the whole game looks weird and flappy in some areas (and when you meet more than one magsorc with their lightning effects it burns out your eyes)…
Sign In or Register to comment.