Update 40 featuring the Endless Archive is now available to test on the PTS! You can read the latest patch notes here: https://forums.elderscrollsonline.com/en/categories/pts

Launcher Suddenly Not Working

So, I got logged out of the game, suddenly and tried to log back in.

Kept getting a Crash Report Window (as per usual), so closed both the game and the launcher window.

Re-opened the launcher window, it updated and then said there was a newer version Bethesda wanted to install.

I agreed to that, then I got this:


Went to Account and tried to Install the game, hoping I could just reinstall the Launcher, but I can't, as it just wants to install the entire game again.

Please advise.
Edited by Tigerseye on March 24, 2020 9:24PM
  • F9thRet
    Went to start up today , myself, and now the launcher is updating. That's all it says, updating. For like 10 minutes now. Barely moving the blue line at all.

    I'm wondering if I'm gonna run into this problem as well.
  • ZOS_Bill

    Linked below is a thread with troubleshooting that may help with the error you're currently getting. Please let us know if any of the troubleshooting listed there helps.

    Bad Image Error
    The Elder Scrolls Online: Tamriel Unlimited - ZeniMax Online Studios
    Forum Rules | Code of Conduct | Terms of Service | Home Page | Help Site
    Staff Post
Sign In or Register to comment.