Maintenance for the week of May 25:
• [COMPLETE] PC/Mac: NA and EU megaservers for maintenance – May 28, 2:00AM EDT (6:00 UTC) - 4:00AM EDT (8:00 UTC)
https://forums.elderscrollsonline.com/en/discussion/529446

Front bar weapons disappearing (visual bug)

  • OldManJim
    OldManJim
    ✭✭✭✭
    Still happening to me as well.
    PAWS (Positively Against Wrip-off Stuff) - Say No to Crown Crates!
  • Wolste
    Wolste
    Soul Shriven
    Happens alot. Annoying to see this post has been up for this long and the bug is still around
  • Wild_Mage
    Wild_Mage
    ✭✭
    Going on a year with no fix. This is annoying as hell.
  • Mojmir
    Mojmir
    ✭✭✭✭✭
    ✭✭✭✭✭
    Same.doesnt matter what class/wep it dissapears
    Raising floors and lower ceilings by zos standards has created an iron maiden.
    No matter how well you played,when the game is over,the king and pawn go back in the same box.
    Be careful what you ask for from zo$, you always get punished.
    Call me toxic,your the one being slowly poisoned by greed.
  • monkey36948
    monkey36948
    ✭✭
    On my tank i have this happen fairly often the front bar S&B and the backbar destro will get either swapped or the S&B will disappear and i'll be using the destro like a skateboard
  • KappaKid83
    KappaKid83
    ✭✭✭✭✭
    FWIW, still happening. Destro Front Bar and 2 Hand Back Bar and I will be casting my front bar heavy attacks with a 2 hander, looks funky.
  • goldenarcher1
    goldenarcher1
    ✭✭✭✭✭
    Just to say that the weapon disappearing bug only happens on the character that i created less than a year ago,and never happens on the others i made before that.

  • majulook
    majulook
    ✭✭✭✭✭
    Just to say that the weapon disappearing bug only happens on the character that i created less than a year ago,and never happens on the others i made before that.

    Same for me only one character, that was created in June of 2018.

    it only happens only on any weapon on the front bar, switching which weapons front to back bar does not change the issue, it stay broken on front bar.
    Si vis pacem, para bellum
  • John_Falstaff
    John_Falstaff
    ✭✭✭✭✭
    ✭✭
    Odd, for me it happily happens on the character created around Morrowind. I didn't notice any connection here; it's just sometimes hard to reproduce, doesn't always happen.
  • p_tsakirisb16_ESO
    p_tsakirisb16_ESO
    ✭✭✭✭✭
    OK i have spend quite some time to look at this bug.

    It only affects base racial weapon motifs like Breton & Khajiit. (at least i have experienced this bug with those two). Predominately qbar 1 weapons. However while it affects only the shield on S&B configuration allowing the weapon to show as normal, it affects DW on both hands.

    It doesn't affect motifs added later in the game like Dro-m'Athra, Skinchanger etc.

    In overland content I do not believe have seen the bug once however in dungeons occurs all the time.
    Some times in peculiar ways. For example Selene Web, which did just right now, until I pass through the last door the shield didn't show. The moment went through the last door to the shield showed up normal.

    Before we went through the last door, I decided to ask the group if they can see the shield. Only 1 said yes.
    The other two, including myself couldn't see the shield. Which is Breton 2 style (the one with cross).

    As can be seen from the screenshot. I have Pierce Armour active to hit, however the shield doesn't show.
    Must say I wouldn't mind having a trigger to turn off showing the shield as we do with the helmet, but this is clearly a bug.

    None of my other tanks exhibit this issue, but the rest are using Dro-m'Athra shields (they are all Khajiit). Not Breton.
    rdof4ywmt6c3.png

    EDIT. That might be happening if entering a dungeon with the qbar 2 active where there is a bow, because just did a dungeon having ported in with S&B active and the shield showed as normal. I will update if the bug occurs on next dungeon. However EH2 was the first dungeon I saw the shield not missing. Out of 22 other dungeons had the issue with that specific character now.

    Update 2. The bug occurs when porting into a dungeon with qbar 2 selected (bow). When switching to qbar 1 the shield is gone.
    In CoA2 while initially the shield is gone, some of the other players can see it. And I could see the shield also the moment we pass through the portal to oblivion.
    Edited by p_tsakirisb16_ESO on May 10, 2019 11:31AM
  • John_Falstaff
    John_Falstaff
    ✭✭✭✭✭
    ✭✭
    @p_tsakirisb16_ESO , it's odd, but my experience is completely different. I often see that bug overland; it affects me even though I run weapons in original look (I often see my bow - dwemer-styled vMA one - dragging under my feet while I hold celestial styled daggers). So I'm not sure if visual style and overland/dungeon is part of the pattern. Other things may be similar - I often was noticing that which bar I'm on does affect whether the bug will appear once I've teleported.
  • lucasfb1
    lucasfb1
    Soul Shriven
    bump
  • elemag75
    elemag75
    Happing to me all the time. If am I wearing an off hand and phase to a zone, dungeon whatever, its fine. If I use say my two hander and phase to a zone, dungeon etc, when I swap to my off-hand set, the off hand is not visible until I unequipt it or use /reloadui. EVERY TIME. How many years is this going to take? Freakin annoying!
  • Mavor
    Mavor
    ✭✭✭
    This has been happening to me since before Summerset - now come Elsweyr and I still get it, 100% of the time, when swapping to my dual wield weapon set. Doesnt matter what skins I use, my dual wield set always ends up on the floor between my feet. VERY, VERY annoying to have to re-equip every time I enter a new area.
  • Mavor
    Mavor
    ✭✭✭
    Thanks for the reports, all. We're aware and working on getting this fixed (for what it's worth, I ran into the same thing on my character last week).

    Any chance this is ever actually going to be fixed? =P
  • Jasli
    Jasli
    ✭✭✭
    Yes please, a fix, or at least a response.....Not game breaking but really undesirable..
  • Terry_Arquett
    Terry_Arquett
    ✭✭✭
    I see that a year has passed since the creation of the theme. But the bug is still in the game. Recently, it began to appear more often. Please fix this! Sorry, hard to write in English.
    Necronomicon
  • Sunderhall
    Sunderhall
    ✭✭
    At least for me, this is not only a visual bug.

    Could not use any of my dual wield skills while my weapons where gone and the bow from 2nd bar was put under my feet. Could only punch mobs or stick to range bar. Dropping one of my weapons would fix the problem. But since this is impossible infight, it's a extremely annoying bug.
  • E-Zekiel
    E-Zekiel
    ✭✭✭
    This is affecting me too now. In my case I use 1h/shield and dual wield and this keeps happening to my 1h/shield bar (which is my first bar). My shield disappears and I have a dagger in my main hand. (Note: My front bar appearance is a full sized sword and shield, and by back bar is two daggers). It's very disorienting because a full sized sword and shield with 1h abilities looks fine, but a little tiny dagger and no offhand looks just silly.

    This is irritating because it happens *constantly*. Particularly every time I go through a load screen. It's particularly aggravating I have to do /reloadui every time it happens.

    Outfit swapping works, too, but I don't have multiple outfits on all my characters, so....

    Edit: I can seem to "prevent" this by making sure to always be on the affected weapon every time I hit a load screen. But I actually use bar #2 more, so... this happens frequently.
    Edited by E-Zekiel on June 2, 2019 11:50PM
  • withermane
    withermane
    Soul Shriven
    5n15iun7b728.jpg

    I realize the dev team knows about it by now. Though, just to show my frustration as well, Indaenir is questioning my incompetency with their native weapons...
  • veroxiousvemo
    veroxiousvemo
    ✭✭✭
    Happens to me in delves / dungeons. For me it's front bar (dual wield). I hope they fix this because it looks like I'm dancing when I use Whirlwind. Sometimes it looks like I'm slapping my enemies left and right. Funny, but it looks ridiculous :D
    Kia ora!
    Xbox NA CP494
    PC NA L20
  • Ufretin
    Ufretin
    ✭✭✭✭✭
    Never had this bug before but now experiencing it on a new toon.
    Two-handed sword is sometimes missing (barely visible beneath my feet).
    With sword and board equipped, the shield is missing, instead there is a dagger (!) on the ground.
    Happens in both overland zones and group instances.
    FYI I'm using Molag Kena sword style.
  • dannymcgr81b14_ESO
    dannymcgr81b14_ESO
    ✭✭✭✭
    Happening to me also. "Working on getting this fixed" over a year ago doesn't really fill me with a sense of hope.
  • DeathStalker_X
    DeathStalker_X
    ✭✭✭
    I posted about it happening with a bow in a new thread - didn't realize it was ALL front-bar weapons.

    Come on ESO - this is QA Tetsing 101 for crying out loud! Seriously, WHERE are your processes?
  • Jenzi
    Jenzi
    ✭✭✭✭
    This bug used to happen to me once in a blue moon but since using the treasure hunter personality in a dungeon, my daggers disappear constantly now when swapping from bow. The only way to prevent it for me is to make sure I have daggers on the bar when porting or entering a dungeon. It’s extremely annoying.
  • DeathStalker_X
    DeathStalker_X
    ✭✭✭
    Only way to "fix" it is to use a wayshrine, or log off and back on. :(

    I honestly fail to see how this could possibly get past ANY level of *proper* testing .....
  • Sivaas23
    Sivaas23
    You can fix it by unequipping and reequipping the weapon, but it is definitely throwing me off. I think this bug didn't start happening for me until the Elsweyr DLC dropped, but I've been hearing about it for a while.
  • Sindrik8x
    Sindrik8x
    ✭✭✭
    FYI guys. There is a permanent fix available a friend online told me about. It's through Minion. Install the Add-on, "Clutch". I had the issue for over 4 - 5 months until he told me. Put it on my game about a month back. Not one glitch.
  • Jenzi
    Jenzi
    ✭✭✭✭
    Yes I’ve been using it since reading this thread a couple days ago, it works really well, thanks.

    Here is the link for those that still have this problem. https://www.esoui.com/downloads/info2302-Clutch.html
  • scorpius2k1
    scorpius2k1
    ✭✭✭✭✭
    Thank you for this! Once again, the community quickly fixes what the company obviously cannot after being reported over a year ago.
    [Zenimax] zone: WTS [Turning Players Into Payers]
    [Zenimax] zone: ;o)
Sign In or Register to comment.