We are currently investigating connection issues some players are having on the European PC/Mac megaserver. We will update as new information becomes available.
Maintenance for the week of November 18:
· [COMPLETE] PC/Mac: NA and EU megaservers for patch maintenance – November 18,  4:00AM EST (09:00 UTC) - 8:00AM EST (13:00 UTC)
· Xbox One: NA and EU megaservers for maintenance – November 20,  6:00AM EST (11:00 UTC) - 9:00AM EST (14:00 UTC)
· PlayStation®4: NA and EU megaservers for maintenance – November 20,  6:00AM EST (11:00 UTC) - 9:00AM EST (14:00 UTC)

Problems after system restore using Windows 10

Rilos
Rilos
Recently I restored my computer to an earlier state. When I logged back in, the ESO launcher had to be reinstalled and all of my files were still there.

I launched the application, clicked play and nothing happened. I tired various ways of making the game launch, such as reinstalling the runtime, reinstalling directx.

I even tried uninstalling the game from the control panel and installing it from nothing, but every time I try to uninstall, the old files are still on my machine and the game won't launch.

  • Rilos
    Rilos
    Okay, I figured it out.

    I uninstalled the game again and this time, chose a different place to install.

    The installation directory was set at my cloud drive and I needed to change the location of where I reinstalled it.

    I decided to install it on steam anyway, because it's more easy to manage.
  • Rilos
    Rilos
    Also, I needed to go and uninstall it from the APP list and not the control panel. At least I think that's what finally uninstalled it.
Sign In or Register to comment.