On Wednesday, from 1:00PM to 4:00PM EST, the forums will be undergoing maintenance. During this time there may be brief periods where the forums will be unavailable.

Game won't go above 60 fps

Betsararie
Betsararie
✭✭✭✭✭
Why?

I'm playing on a 5K iMac M395 but I'm posting it here because I assume no one goes to the Mac forum...

How is it possible to achieve the fps he's getting in this video?



I understand the Mac isn't a gaming machine but every other game has run well. It's only ESO that runs terribly

I generally get 60 fps, ~50 in fights and ~50 in cities sometimes dropping down to the 40s.

But I will never get above 60 even looking at the sky or in an empty room.

Gaming on 2048x1152 resolution. How can I get my resolution to go above 60 fps? Has anyone with a Mac ever achieved higher than 60 fps? Any help is appreciated.
Edited by Betsararie on April 1, 2017 11:11PM
  • Rohamad_Ali
    Rohamad_Ali
    ✭✭✭✭✭
    ✭✭✭✭✭

    This is caused by a built in v-sync kind of thing called BeamSync. Solution:

    • Download Graphics Tools for Xcode https://developer.apple.com/downloads/index.action

    • Mount, open Quartz Debug

    • Under BeamSync, set to disable. CS can now render at above 60fps (just keep quartz debug open whilst you want to have a figher framerate)

    Source from Reddit
  • Betsararie
    Betsararie
    ✭✭✭✭✭
    This is caused by a built in v-sync kind of thing called BeamSync. Solution:

    • Download Graphics Tools for Xcode https://developer.apple.com/downloads/index.action

    • Mount, open Quartz Debug

    • Under BeamSync, set to disable. CS can now render at above 60fps (just keep quartz debug open whilst you want to have a figher framerate)

    Source from Reddit

    Thanks a lot for that.

    I checked into that and the only issue is since I am running on El Capitan, quartz debug no longer has the function to disable beamsync. In fact, apparently beamsync doesn't even exist anymore and now it is running on something called Metal, which there are no known ways to disable.

    Bit of a problem. I did check in the game and somehow V sync was turned on in the game settings which wasn't intentional, of course I turned that off and it seems to be helping.

    However if I could disable that system wide that would surely be preferable, sadly I do not know if that is possible...
  • KhajitFurTrader
    KhajitFurTrader
    Community-Botschafter
    Blanco wrote: »
    Bit of a problem. I did check in the game and somehow V sync was turned on in the game settings which wasn't intentional, of course I turned that off and it seems to be helping.

    However if I could disable that system wide that would surely be preferable, sadly I do not know if that is possible...
    There's no way to do that. Every game engine, or any code that invokes the OpenGL API for that matter, gets to decide on its own whether or not it supports or uses vsync.

    That being said, you should check for an activated vsync option after each patch to the game, and turn it back off in the case it has been re-enabled.




  • Betsararie
    Betsararie
    ✭✭✭✭✭
    Blanco wrote: »
    Bit of a problem. I did check in the game and somehow V sync was turned on in the game settings which wasn't intentional, of course I turned that off and it seems to be helping.

    However if I could disable that system wide that would surely be preferable, sadly I do not know if that is possible...
    There's no way to do that. Every game engine, or any code that invokes the OpenGL API for that matter, gets to decide on its own whether or not it supports or uses vsync.

    That being said, you should check for an activated vsync option after each patch to the game, and turn it back off in the case it has been re-enabled.




    Thanks.

    So it's pretty much always better to have it off? improved performance, etc
  • KhajitFurTrader
    KhajitFurTrader
    Community-Botschafter
    Blanco wrote: »
    So it's pretty much always better to have it off? improved performance, etc
    Vsync is a way to prevent screen tearing by insuring that a new frame gets pushed into the video buffer only at the same time the monitor does a refresh. At the usual refresh rate of 60 Hz, this means that the graphics engine's computation is locked to this rate, or multiples/fractions thereof. Since it's a bit hard for mobile GPUs to push 120+ fps on a 1440p resolution or above (on decent quality settings, that is), fps gets capped at 60 with vsync enabled.

    So yes, disabling vsync lets the GPU loose. This has been a tried and tested "performance improvement" since the days of beta, and I continue advertising it in my Mac 64-bit client FAQ (link below). ;)

  • Betsararie
    Betsararie
    ✭✭✭✭✭
    Thanks, very helpful.

    My machine is the M395 i5-6600 model (with 512 SSD).

    Now concerned if I should've gone for i7-6700k.

    I didn't want to dump any more money into it , and the general knowledge is that CPU matters little for gaming so that is why I just went with the i5.

    Now concerned if the i7 would've helped me in ESO...

    I would prefer a steady 60 fps and I'm not getting that... also am not willing to turn graphics below high...
  • Betsararie
    Betsararie
    ✭✭✭✭✭
    Thanks, very helpful.

    My machine is the M395 i5-6600 model (with 512 SSD).

    Now concerned if I should've gone for i7-6700k.

    I didn't want to dump any more money into it , and the general knowledge is that CPU matters little for gaming so that is why I just went with the i5.

    Also didn't anticipate I would end up playing ESO this much.

    Now concerned if the i7 would've helped performance in ESO...

    I would prefer a steady 60+ fps and I'm not getting that... also am not willing to turn graphics below high...
    Edited by Betsararie on April 7, 2017 12:09AM
Sign In or Register to comment.