Maintenance for the week of June 24:
• PC/Mac: No maintenance – June 24
• ESO Store and Account System for maintenance – June 26, 4:00AM EDT (08:00 UTC) – 12:00PM EDT (16:00 UTC)

Crash after pressing "Play" button in launcher

guildwars2eb17_ESO1
guildwars2eb17_ESO1
Soul Shriven
Greetings,

I know this has been asked a 100 times before, as I already roamed through the older forum posts, but I am at a dead end.

First of all here is the situation:
- Brand new ESO installation, no addons, no saved variables
- Bethesda.net_Launcher application AND eso64.exe have been set to compatibility mode for Win 7 and to be ran as administrator
- There is no settings text file to be edited in the directory "Documents/Elder Scrolls Online/live/" because the game has never been launched before
- Im trying to play from a laptop Lenovo Ideapad y510p

Here is the problem:
Launcher loads, confirms there are no new updates, and allows me to press "Play". I press play, screen goes black and after no more than 1 second, everything crashes and I get the error message listed below (it will be posted at the bottom of this post to keep all relevant information bundled together up here)

From a previous topic found over here: https://forums.elderscrollsonline.com/en/discussion/325636/crash-on-play I read that updating your drivers might help. I have 2 graphics drivers "Intel HD Graphics 4600' and a "NVIDIA GeForce GT 755M". I went to the device manager and tried to update both my video drivers by right clicking them -> Properties -> Driver -> Update Driver... and the my laptop came back at me saying all my drivers are up to date.
I didn't trust this message since my Intel 4600 was last updated in 2013, so I downloaded the driver update tool from intel.com and it detected my 4600 driver and warned me its a custom build for my laptop specifically. This is the exact message that was given to me:
"A customized computer manufacturer driver is installed on your computer. The Intel Driver Update Utility is not able to update the driver. Installing a generic Intel driver instead of the customized computer manifacturer driver may cause technical issues. Contact your computer manufacturer for the latest driver for your computer."
Looking around the lenovo website did not yield any results on newer driver versions, so I left it as is.
My NVIDIA drivers are up to date.
I also read over here: https://forums.elderscrollsonline.com/en/discussion/321710/potential-fix-for-eso-has-stopped-working-immediate-crash-after-hitting-play#latest that disabling my intel driver might solve the trick but honestly I don't want to even bother trying. Usually something bad happens somewhere else for some related reason when I fiddle around with my drivers. My question is: Is there anything else I can try that might solve the issue? I feel like I shouldn't have to go through all that just for one game. My drivers will stay as they are, I don't feel like removing anything.



THIS IS THE ERROR MESSAGE:

====================================================================
eso has stopped working.
====================================================================

[reporter]
version = 0.01


[extra]
ProductName = eso
Version = eso.live.2.7.10.1426602
branch = live
client.executablebits = 64
client.mode = startup
client.renderertype = D3D11
client.session_start_timestamp = 2017-03-20T19:57:01.591Z
client.timestamp = 2017-03-20T19:57:02.999Z -frme 0-
computer.name = USER-PC
computer.user = User
cpu.arch = 9
cpu.count = 8
cpu.level = 6
cpu.type = 8664
data.depotid = 4000
data.dir = D:/Steam/steamapps/common/Zenimax Online/The Elder Scrolls Onli
data.syncm = databuild
data.version = 4000.win.1426675.live.1426602
exe.buildnum = 1426602
exe.opt = release
exe.reltype = public
exe.type = client
gfx.description = 9.18.13.2762
gfx.deviceid = 1046.939595690.6
gfx.driver = Intel(R) HD Graphics 4600
gfx.vendorid = 32902
mem.system_physical = 8108
os.osbits = 64
os.platform = windows
os.version = 6.1.7600.Service Pack 1
ptime = 1586
reportfield.ver = 3
version.major = 2
version.patch = 7
version.subpatch = 10
  • Dudsworth1
    Greetings,

    I know this has been asked a 100 times before, as I already roamed through the older forum posts, but I am at a dead end.

    First of all here is the situation:
    - Brand new ESO installation, no addons, no saved variables
    - Bethesda.net_Launcher application AND eso64.exe have been set to compatibility mode for Win 7 and to be ran as administrator
    - There is no settings text file to be edited in the directory "Documents/Elder Scrolls Online/live/" because the game has never been launched before
    - Im trying to play from a laptop Lenovo Ideapad y510p

    Here is the problem:
    Launcher loads, confirms there are no new updates, and allows me to press "Play". I press play, screen goes black and after no more than 1 second, everything crashes and I get the error message listed below (it will be posted at the bottom of this post to keep all relevant information bundled together up here)

    From a previous topic found over here: https://forums.elderscrollsonline.com/en/discussion/325636/crash-on-play I read that updating your drivers might help. I have 2 graphics drivers "Intel HD Graphics 4600' and a "NVIDIA GeForce GT 755M". I went to the device manager and tried to update both my video drivers by right clicking them -> Properties -> Driver -> Update Driver... and the my laptop came back at me saying all my drivers are up to date.
    I didn't trust this message since my Intel 4600 was last updated in 2013, so I downloaded the driver update tool from intel.com and it detected my 4600 driver and warned me its a custom build for my laptop specifically. This is the exact message that was given to me:
    "A customized computer manufacturer driver is installed on your computer. The Intel Driver Update Utility is not able to update the driver. Installing a generic Intel driver instead of the customized computer manifacturer driver may cause technical issues. Contact your computer manufacturer for the latest driver for your computer."
    Looking around the lenovo website did not yield any results on newer driver versions, so I left it as is.
    My NVIDIA drivers are up to date.
    I also read over here: https://forums.elderscrollsonline.com/en/discussion/321710/potential-fix-for-eso-has-stopped-working-immediate-crash-after-hitting-play#latest that disabling my intel driver might solve the trick but honestly I don't want to even bother trying. Usually something bad happens somewhere else for some related reason when I fiddle around with my drivers. My question is: Is there anything else I can try that might solve the issue? I feel like I shouldn't have to go through all that just for one game. My drivers will stay as they are, I don't feel like removing anything.



    THIS IS THE ERROR MESSAGE:

    ====================================================================
    eso has stopped working.
    ====================================================================

    [reporter]
    version = 0.01


    [extra]
    ProductName = eso
    Version = eso.live.2.7.10.1426602
    branch = live
    client.executablebits = 64
    client.mode = startup
    client.renderertype = D3D11
    client.session_start_timestamp = 2017-03-20T19:57:01.591Z
    client.timestamp = 2017-03-20T19:57:02.999Z -frme 0-
    computer.name = USER-PC
    computer.user = User
    cpu.arch = 9
    cpu.count = 8
    cpu.level = 6
    cpu.type = 8664
    data.depotid = 4000
    data.dir = D:/Steam/steamapps/common/Zenimax Online/The Elder Scrolls Onli
    data.syncm = databuild
    data.version = 4000.win.1426675.live.1426602
    exe.buildnum = 1426602
    exe.opt = release
    exe.reltype = public
    exe.type = client
    gfx.description = 9.18.13.2762
    gfx.deviceid = 1046.939595690.6
    gfx.driver = Intel(R) HD Graphics 4600
    gfx.vendorid = 32902
    mem.system_physical = 8108
    os.osbits = 64
    os.platform = windows
    os.version = 6.1.7600.Service Pack 1
    ptime = 1586
    reportfield.ver = 3
    version.major = 2
    version.patch = 7
    version.subpatch = 10

    I have the Lenovo Ideapad y410p with the same graphics chipsets as you. I don't experience the crash on play and am on Windows 10. My current Intel Driver is 10.18.15.4279, with a driver date of 8/24/15. I'm not sure what OS you are on, but if you are on Windows 10 there should be a newer one available even for us. Unfortunately since we have notebooks, Zenimax officially believes that our computers can't possibly run ESO even though we both know that isn't true... I emailed support on a different crashing issue and their official response was:

    "I'm sorry that you are having issues with the sound cutting our and the game crashing. After reviewing your report attachment, the NVIDIA GeForce GT 755M doesn't meet the ESO requirements.

    Since mobile graphics cards do not meet ESO's system requirements there is limited troubleshoot we can offer."

    So basically they will believe that a laptop can't run ESO regardless of how powerful it is or the hardware inside of it... That's rich. Anyway, check on that driver version, if you aren't on Windows 10 though, obviously it will be different.
  • Nestor
    Nestor
    Community Ambassador
    Edit your Power Settings to be High Performance while plugged in. The game is trying to launch on the 4600 Graphics which will not run the game. High Performance Video should force the system to use the 3D Graphics Card.

    You may also have to force this in the Control Panel, it if is running, for your video card. Note the Nvidia Experience can be problematical for this game, but that is a driver updater thing, and not the typical control panel.
    Enjoy the game, life is what you really want to be worried about.

    PakKat "Everything was going well, until I died"

  • guildwars2eb17_ESO1
    guildwars2eb17_ESO1
    Soul Shriven
    Dudsworth1 wrote: »

    I have the Lenovo Ideapad y410p with the same graphics chipsets as you. I don't experience the crash on play and am on Windows 10. My current Intel Driver is 10.18.15.4279, with a driver date of 8/24/15. I'm not sure what OS you are on, but if you are on Windows 10 there should be a newer one available even for us. Unfortunately since we have notebooks, Zenimax officially believes that our computers can't possibly run ESO even though we both know that isn't true... I emailed support on a different crashing issue and their official response was:

    "I'm sorry that you are having issues with the sound cutting our and the game crashing. After reviewing your report attachment, the NVIDIA GeForce GT 755M doesn't meet the ESO requirements.

    Since mobile graphics cards do not meet ESO's system requirements there is limited troubleshoot we can offer."

    So basically they will believe that a laptop can't run ESO regardless of how powerful it is or the hardware inside of it... That's rich. Anyway, check on that driver version, if you aren't on Windows 10 though, obviously it will be different.

    This is troubling news. As you mentioned, my laptop can run this game 6 times over without a problem. I have the hardware for it definitely. I do use Win 7, and I wont be upgrading, the drivers for win 7 must be discontinued I guess.
    Nestor wrote: »
    Edit your Power Settings to be High Performance while plugged in. The game is trying to launch on the 4600 Graphics which will not run the game. High Performance Video should force the system to use the 3D Graphics Card.

    You may also have to force this in the Control Panel, it if is running, for your video card. Note the Nvidia Experience can be problematical for this game, but that is a driver updater thing, and not the typical control panel.

    My power settings have been set to maximum performance while plugged in and it's obviously plugged in.I tired digging deeper into your suggestion to force the game to use NVIDIA instead of the intel graphics and I figured out I can't. For some reason even if I go to the game directory and right click the eso64.exe and select "Run with graphics processor -> High performance NVIDIA processor (default)", when I launch the game, it still gives me the same message in the error report that it tries to launch it with intel 4600. I think I found out what the problem is.

    The problem appears to be that ESO is trying to run itself while using the integrated GPU instead of your actual GPU and the integrated graphics are extremely weak and can barely handle a game of solitare, let alone ESO. It did not work for me, but I will share a few possible solutions to this problem, maybe they will help others:

    1. Go to C:/Program Files/NVIDIA Corporation/Control Panel Client/ and find nvcplui.exe. Right click it, go to Properties -> Compatibility and make sure you are running it as administrator (some people might have users who do not have administrator authority to overwrite settings).

    2. Launch the NVIDIA control panel and go to "Global Settings" tab. from there use the dropdown menu, labled "Preffered graphics processor", to select your current GPU. You should have 3 options: Auto-detect; High Performance NVIDIA processor, ; and Integrated graphics. Pick NVIDIA. This will tell your system to launch games using NVIDIA instead of the inbuilt integrated graphics. Click apply and exit the panel. (at this point you can try again to give it a go)

    3. In case for some reason your windows user is not authorized to overwrite these settings, your system will always revert back to the state of using integrated graphics by default. You can check this by just reopening the NVDIA control panel. If the changes you JUST made in step 2 have undone themselves, then your system is set to revert itself back to default no matter how you change it. In this case you can try going to your game directory folder, for me it was: "Steam/SteamApps/common/Zenimax Online/The Elder Scrolls Online/game/client" and find the 2 executables labeled "eso.exe" and "eso64.exe". At this point it's up to you to figure out if you are running a 64-bit version of windows or a 32-bit. Google it if you don't know how. If you run a 64 bit, right click the "eso64.exe" and in the menu there should be a option called "Run with graphics processor ->". Select your NVIDIA GPU and the game will launch using NVIDIA (this is what doesn't work for me, since the error message still tells me its STILL trying integrated graphics rather than the NVIDIA GPU)

    4. Sometimes this problem is caused by drivers which have been released in a buggy state and have issues with setting being overwritten. To combat this you can *try* to roll back the drivers to a more stable version. To do that, open the START menu, type into the text field "DEVICE MANAGER" and open your device manager. Go to Display Adapters and you should see 2 things for your interated graphics and NVIDIA card. for me the 2 options were "INTEL(R) HD GRAPHICS 4600" and "NVIDIA GeFORCE GT 755M". Right click the Intel HD graphics and select Properties. Go to "Driver" tab and click the "Roll Back Driver" button".
    I read that most people had it fixed by just rolling back their Intel driver and not touching the others, but if it doesn't work for uou, you can try rolling back 1st your Intel driver, then your NVIDIA driver (restarting the computer after every roll back) and then if it still doesnt work, just go to the Driver tab again and click "Update Driver..." to restore it to the state it was before you started messing around with it (restart computer again for the changes to take place).

    At this point I am out of ideas. If what I said in step 3 is true and your computer just reverts to using integrated graphics and your ESO error messages keep telling you the game tried launching using integrated graphics then the fault is NOT with ESO. It is a problem caused by your windows and its refusal to use the NVIDIA gpu under any circumstances. If you are experiencing the same problem as me, I would suggest you try to get it solved somehow as it will affect other programs as well in the future.
  • Nestor
    Nestor
    Community Ambassador
    Are you using the Launcher? That is 2D and the laptop may still not be switching to the graphics card for the game. So, either try to force the Launcher to use the 3D card too. Or try running the game directly from the EXE using a shortcut, which is preferred anyway.

    Also, when you say your system is set to High Performance, did you dig into the Graphics subsection and tell the system there to always use the 3 Card? I have found setting the over all system to High Performance in Power Options does not mean the system actually uses the 3D.

    Finally disable the UAC, it may actually allow you to run your computer like you want.

    This whole falderall you are in is why I build my own systems that do not have or use on CPU graphics. There is no way the system can ever switch to them.
    Enjoy the game, life is what you really want to be worried about.

    PakKat "Everything was going well, until I died"

  • guildwars2eb17_ESO1
    guildwars2eb17_ESO1
    Soul Shriven
    Nestor wrote: »
    Are you using the Launcher? That is 2D and the laptop may still not be switching to the graphics card for the game. So, either try to force the Launcher to use the 3D card too. Or try running the game directly from the EXE using a shortcut, which is preferred anyway.

    Also, when you say your system is set to High Performance, did you dig into the Graphics subsection and tell the system there to always use the 3 Card? I have found setting the over all system to High Performance in Power Options does not mean the system actually uses the 3D.

    Finally disable the UAC, it may actually allow you to run your computer like you want.

    This whole falderall you are in is why I build my own systems that do not have or use on CPU graphics. There is no way the system can ever switch to them.

    UAC has been turned off this whole time, so that's not the problem. I fiddled around with the advanced settings in the power options and it still resets to intel all the time. I found out why though. I would like to share my finding with anyone who has the same issues.

    ATTENTION! IF YOU HAVE A LAPTOP!

    There is this ridiculous system they put on laptops that have only 1 video card (Meaning if you DONT have SLI) called "Optimus". What Optimus means is the manufacturer of the laptops decide to hardwire your integrated graphics card to be your only graphics card and the NVIDIA one to be some sort of backup lapdog to be called when needed. I have a Lenovo laptop with a GeForce 755m. Optimus mean that I actually DONT have a 755m, I have a laptop with Intel 4600 and that integrated card has the option to call for muscle, equal to the 755m capabilities.

    For most games, the dialogue between the program and the computer goes like this:
    Game: You cant run the game with intel 4600
    Laptop: Just try it, trust me
    Game: Ok, as you wish
    Laptop: NVIDIA, start working
    Game: Hay look, it worked

    What happens with ESO is:
    Game: You cant run the game with intel 4600
    Laptop: Just try it, trust me
    Game: No! Not even going to bother trying.

    Q :How can this be fixed?
    A: Well it cant. You have to be really good with computers to uncouple your real GPU from your integrated card, if you think you can handle it, you can open your laptop and try to fix it yourself, but I absolutely would not recommend it. Other than that, if you have a laptop, you are out of luck.

    Q: But wait, I used to play ESO on a laptop a while ago and it was working just fine.
    A: Well at some point, the ESO client started checking your specs before it runs the game, so thats what screwed it up. LIke they have stated, they dont support laptops so it's not really their problem that you have Optimus running.

    If you have a box PC, keep looking for answers, its not your problem
Sign In or Register to comment.