Maintenance for the week of January 30:
• PC/Mac: No maintenance – January 30
• Xbox: NA and EU megaservers for maintenance – February 1, 6:00AM EST (11:00 UTC) - 9:00AM EST (14:00 UTC)
• PlayStation®: NA and EU megaservers for maintenance – February 1, 6:00AM EST (11:00 UTC) - 9:00AM EST (14:00 UTC)

Still broken

Caff32
Caff32
✭✭✭✭
I get stuck in a load screen when switching zones and I don't have access to the DLC zones even though I'm an active ESO plus member. When is this going to be fixed?!
  • RogueShade
    RogueShade
    ✭✭✭
    Yup still broken, can't even get characters to load.
  • BrotherDarkness
    BrotherDarkness
    Soul Shriven
    Current ESO subscriber, with an active sub till the middle of June and cannot access any DLC what so ever. Finally was able to log in, but all DLC is gone.
    “When life gives you lemons, go murder a clown.”
    ― Festus Krex Skyrim
  • Lumenn
    Lumenn
    ✭✭✭✭✭
    So they announced the the issues on na Xbox megaserver regarding loading/zone times are fixed....but they're not. I saw a green txt about two hours ago, are they still working on it?
  • makeyurself
    makeyurself
    ✭✭✭
    I was able to get on but with long loading screens, now nothing. Can't make it past login. Tried resetting and unplugging Xbox, resetting Internet, and still nothing.
    Xbox NA:
    • Soren Hawkheart- Breton Spellsword (DC) Sorcerer
    • Kaenan- Imperial Paladin (EP) Templar
    • Revan- Dunmer Vampire Inferno Mage (EP) Dragonknight
    • Faerandil- Altmer Sage (AD) Templar
    • Aureyna- Altmer Arcane Warrior (AD) Sorcerer
    • Aurthalion- Altme Battle Mage (AD) Sorcerer
    • Dahlek- Argonian Shadowmage/Shadowscale (AD) Nightblade
    • Callion- Breton Thief & Assassin (AD) Nightblade
    • Eldaran- Lore-breaking half-elf Elementalist, not of Nirn (DC) Dragonknight
    • Quenandir- Altmer Ranger (AD) Nighblade
    • Saelif- Breton/Altmer MG Adept (AD) Templar

  • fuzzypotatoe
    Same issues too they replied to my thread but only asked me to rest xboxone and see if that helps but after I did my plus is gone and all my active XP and tricorn boosts hooray wasted money...
  • Lumenn
    Lumenn
    ✭✭✭✭✭
    My eso plus is gone too....
  • Caff32
    Caff32
    ✭✭✭✭
    My ESO plus randomly came back, but I can't load any characters in Auridon

    I would also note that I have reset my xbox, logged in and out multiple times, and tried just quitting the game and none seem to have made a difference
    Edited by Caff32 on May 25, 2016 12:24AM
  • makeumrage
    makeumrage
    ✭✭✭
    Also cannot load in. Was in Wrothgar started loading into that zone and then the screen swotched to Grahtwood and just got stuck there. Character name Mr Carnage gamertag Makeum Rage
    Edited by makeumrage on May 25, 2016 12:32AM
  • hueywtf
    hueywtf
    Can't login to my Templar, who's in Grahtwood. But I can log into my other characters..
  • Caff32
    Caff32
    ✭✭✭✭
    Awesome. Only able to access two characters!

    Mission Accomplished!
  • lycanslerwb17_ESO
    lycanslerwb17_ESO
    ✭✭✭
    Current ESO subscriber, with an active sub till the middle of June and cannot access any DLC what so ever. Finally was able to log in, but all DLC is gone.

    Same here, please advise us on whats happening
  • Nick_Nitr0
    Same here some characters won't load, some characters can't travel stuck in load screen.

    Xbox NA / GT: Nick Nitr0 (all characters having issues)
  • ZOS_DaryaK
    ZOS_DaryaK
    admin
    We are investigating this issue, please go to this thread and add your information, we'll be updating that thread when we have news to share.
    The Elder Scrolls Online: Tamriel Unlimited - ZeniMax Online Studios
    Forum Rules | Code of Conduct | Terms of Service | Home Page | Help Site
    Staff Post
Sign In or Register to comment.