Maintenance for the week of February 17:
• PC/Mac: No maintenance – February 17
• PC/Mac: NA and EU for maintenance – February 18, 4:00AM EST (9:00 UTC) - 7:00AM EST (12:00 UTC)
• Xbox One: NA and EU megaservers for maintenance – February 19, 6:00AM EST (11:00 UTC) - 10:00AM EST (15:00 UTC)
• PlayStation®4: NA and EU megaservers for maintenance – February 19, 6:00AM EST (11:00 UTC) - 10:00AM EST (15:00 UTC)

Terrible FPS and Game Consultant not opening

Davana
Davana
Soul Shriven
I have the recommended requirements, playing on Mac. At first the game played smoothly. Then instead of having the "play" option, it downloaded more, and that's happened a couple times. Since the last download, framerate issues and lag/jerkiness are so bad it's impossible to play at all. I can barely move my character.

A friend added this (I only understand the VRAM part): IMAC from 2008 with a 3.02Ghz Core2 Duo, 4g DDR2, and a geforce 8800 GS with 512 total VRAM. Began having severe performance issues immediately after ESO patched on 03/12. Prior to the update the graphics settings were on medium and getting 30+ FPS. After the update the framerates went from over 30 and stable to under 5 and stuttering. The ingame graphics settings were still set to medium.

Based on the loading times and jerky-spiky framerate it looks to me like ESO is having difficulty with the available VRAM, but that's not enough to explain the sudden loss in performance. To troubleshoot, I turned the texture resolutions from medium to low, reduced particles from 1024 to 768, and turned off bloom. This provided about 5-6 fps boost and smoothed some of the stuttering but it's still under 10 fps and drops below 1 fps seemingly randomly.

I suspect there was either a change to the shaders or a new post-processing effect we couldn't turn off.

I heard from Customer Service asking for a Game Consultant test; the button does lots of nothing, and when they sent a link, I can get a copy of the Game Consultant, but not open it, with my iMac saying: “Game_Consultant” is damaged and can’t be opened.

I have a bootcamp partition running Skyrim, but frankly I didn't buy the Windows, and it doesn't work with Steam (seriously, I have no idea how the same friend got it running at all), so that doesn't seem like much of an alternative.

My total RAM is 4g, and the known issues recommends adding more, I get that, but for now just want the way it ran at first back - maybe not awesome, but smooth and easily playable.
  • KhajitFurTrader
    KhajitFurTrader
    Community-Botschafter
    Hi @Davana,

    please take a look at my Mac 64-bit client FAQ. As has been noted in the patch notes of the Thieves Guild DLC, due to the switch to OpenGL 4.1, Macs with only 4 GB of RAM will suffer severe performance hits. Sadly, there is no easy way back to a smooth performance; you could try the performance tips I listed, but the most effective one is adding more memory.

    But then again, your 8 y/o iMac is already at the low end of minimum system requirements (especially the VRAM), and might not be fit enough for any mid- to long-term future developments regarding ESO's features. It's your decision whether it's prudent to still put money into it.
  • Davana
    Davana
    Soul Shriven
    Yeah, I was suspecting this. Thanks so much for the awesome work and really great response, now I know where the real help is. Had the same thing with other devs before, and I'm not into the game enough to buy Windows!

    Seriously, thanks big time.
  • bitsquare
    bitsquare
    I've got framerate problems too, but my system substantially exceeds the system requirements (MacBook Pro mid 2014, 2.5 GHz Intel Core i7, 16 GB 1600 MHz DDR3, NVIDIA GeForce GT 750M 2 GB GDDR5 SDRAM, Mac OS 10.11.5).

    The framerate starts okay (45-55 fps) but quickly drops down to poor (25-35 fps) and then reaches dismal levels (15-20 fps or less) over time.

    I've noticed that the RAM usage goes up dramatically during gameplay from ~1GB to ~4GB, which seems a bit excessive to me.

    I've tried:
    • repairing the application
    • running the application in Fullscreen (not Windowed) mode
    • switching graphics settings to Medium with VSync off and several other settings to below default values
    • setting HIGH_RESOLUTION_SHADOWS to 0 in the UserSettings.txt file
    • setting MIP_LOAD_SKIP_LEVELS to -3 in the UserSettings.txt file
    • turning off all addons

    None of the above resolves the framerate problem. I am not running any applications (including startup applications) next to eso.app, and all hardware tests are normal.

    I can't think of anything else to do that might boost (and maintain) framerate.

    It might be worth mentioning that I still have graphics issues in the startup animation screen (grainy overlays on the Bethesda and ZOS logos), an issue that first appeared after the switch to a 64 bit client with the Thieves Guild patches. I followed the advice given by @KhajitFurTrader to turn off the startup animation screen, but the underlying problem persists.

    @ZOS_GinaBruno : Tech support has been minimally helpful, instructing me twice to run fixes clearly intended for Windows.
    Edited by bitsquare on June 8, 2016 11:37PM
Sign In or Register to comment.