Maintenance for the week of June 17:
· [COMPLETE] PC/Mac: NA and EU megaservers for patch maintenance – June 17, 4:00AM EDT (8:00 UTC) – 8:00AM EDT (12:00 UTC)
· [COMPLETE] ESO Store and Account System for maintenance – June 17, 10:00AM EDT (14:00 UTC) – 12:00PM EDT (16:00 UTC)
· Xbox One: NA and EU megaservers for patch maintenance – June 19, 6:00AM EDT (10:00 UTC) – 10:00AM EDT (14:00 UTC)
· PlayStation®4: NA and EU megaservers for patch maintenance – June 19, 6:00AM EDT (10:00 UTC) – 12:00PM EDT (16:00 UTC)

Performance: Sometimes great sometimes bad..?

Robmomanjaro
Robmomanjaro
Soul Shriven
So first off Yosemite killed my computer, im not sure if its related or not, applications take forever to open, but thats not the issue

With Yosemite fail, ive gotten my computer to run ESO just fine (on lowerish settings, as my mac is a few years old) but i was getting 60+ frames. I use my mac as a second computer to play MMos with friends (have a pc thats great) Anyways sometimes i load the game and i get the great performance but sometimes as well,

I'll load the game, get a constant 9 fps and can only use ESC or look around with camera but have to hold right mouse click.. anyone know this issue?
  • KhajitFurTrader
    KhajitFurTrader
    Community-Botschafter
    Hi @Robmomanjaro,

    what kind of Mac do you have? On what graphic quality settings are you usually playing?

    I've not encountered your issue, nor had I problems updating to OS X 10.10 (on recent machines which were build in 2010 or later)
    Edited by KhajitFurTrader on March 22, 2015 4:23PM
  • Robmomanjaro
    Robmomanjaro
    Soul Shriven
    Hi @Robmomanjaro,

    what kind of Mac do you have? On what graphic quality settings are you usually playing?

    I've not encountered your issue, nor had I problems updating to OS X 10.10 (on recent machines which were build in 2010 or later)

    mid 2011 imac

    i5 quad core

    playing on lowest settings,

    its been running at high frames, but now, every once in a while i'll be thrown into a loading screen for an expended period of time, not really playable if you get thrown out randomly
  • Robmomanjaro
    Robmomanjaro
    Soul Shriven
    as an example, i'll be paying and my cpu usage will drop to like under 1 percent and the game freezes for a bit, that happens too, or certain assets wont load, but then they do after a random long loading screen
  • chris.dillman
    chris.dillman
    ✭✭✭

    Hi
    applications take forever to open in 10.10

    This really should not be happening on 10.10.
    Do you only have 4GB of Ram in this machine?
    That might be the cause.


    So things that can slow ESO down a lot.

    If theres anything running in the background doing disk I/O
    You can see this in activity monitor.
    Checking the CPU / Disk usage tabs.
    So back up tasks, Virus checkers etc.

    If ESO thinks it is NOT the foreground app it limits FPS to around 10.
    ( this should not be happening to )

    Try toggling between windowed and full screen mode.

    Does restarting ESO make the issue go away?


    1% CPU and pauses….
    Not sure about the 1% issue.
    But if your machine does not ever enough ram.. Say only 4GB
    ESO will cause virtual memory to swap to disk.
    This will cause 1 second pauses.

    If you only have 4GB of ram you might want to just reboot the machine before playing ESO.
    Thats the easiest way to clear all OS Virtual memory.





    -- ESO -- Lead Mac Programmer...
    Staff Post
  • Robmomanjaro
    Robmomanjaro
    Soul Shriven
    i have 6gb, no other programs are running, it was a clean install

    now it loads okay, has the pauses as well as only loads so much of the landscape, when i go to check ot other areas that have nothing generated, it goes to a loadng screen and generates it. but it makes the game un playable.
  • KhajitFurTrader
    KhajitFurTrader
    Community-Botschafter
    i have 6gb, no other programs are running, it was a clean install

    now it loads okay, has the pauses as well as only loads so much of the landscape, when i go to check ot other areas that have nothing generated, it goes to a loadng screen and generates it. but it makes the game un playable.

    6 GB RAM sounds a bit... odd. The 2011 models all had 4 GB in two 2 GB SO-DIMMs as their standard configuration. Dunno whether not being able to interleave the third DIMM is costing performance. You do see the full 6 GB in Apple Menu > About this Mac?
  • chris.dillman
    chris.dillman
    ✭✭✭
    i have 6gb, no other programs are running, it was a clean install

    now it loads okay, has the pauses as well as only loads so much of the landscape, when i go to check ot other areas that have nothing generated, it goes to a loadng screen and generates it. but it makes the game un playable.

    Hi Robmomanjaro,

    The OS is CLEAN install ? or an upgrade.

    Do you happen to have gaming mouse or keyboard hooked up?

    If you have one, did you check that its driver was updated for 10.10
    There are mice etc out there with Mac specific software that does not work well on 10.10
    and causes massive performance slow downs.

    If thats not an issue.
    It kind sounds like the hard drive is behaving really badly.
    As you said apps take a long time to start up etc.
    Have you tried running Disk Utility.app and repairing?

    If the HD is running super slow it would effect ESO being able to stream in data which it does constantly.


    -- ESO -- Lead Mac Programmer...
    Staff Post
Sign In or Register to comment.