Maintenance for the week of April 15:
• PC/Mac: No maintenance – April 15
• ESO Store and Account System for maintenance – April 16, 8:00AM EDT (12:00 UTC) - 12:00PM EDT (16:00 UTC)

Quest bugged: Azura's Relics

Resueht
Resueht
✭✭✭
Using the scroll to reveal the daedra doesn't work. Use the scroll, I freeze for a few seconds, nothing. Tried relogging, didn't fix the issue. I used /bug to report it but the last few times I have used that I don't get a response so I thought I might try the forums. Just wanted devs to be aware.
If she doesn't know the pain of cliffracers, she's too young for you.
  • ZOS_AmeliaR
    ZOS_AmeliaR
    ✭✭✭✭✭
    Thanks for the report, @Resueht‌! We are aware of this quest issue, and a fix for it has already been pushed to PTS as part of v1.4.1.
    The Elder Scrolls Online: Tamriel Unlimited - ZeniMax Online Studios
    Facebook | Twitter | Google+ | Tumblr | Pinterest | YouTube | ESO Knowledge Base
    Staff Post
  • Secchan
    Secchan
    ✭✭
    Tried doing Azura's Relics today, two minutes ago. The scroll won't work. Doesn't matter where I stand, if it's around the waterfall or inside the waterfall. Doesn't matter if I do first or third person. I just freeze for a moment and have to wait for the scroll to reload.
Sign In or Register to comment.