Maintenance for the week of June 24:
• [COMPLETE] ESO Store and Account System for maintenance – June 26, 4:00AM EDT (08:00 UTC) – 12:00PM EDT (16:00 UTC)

Repair option and Game Consultant

Zhengshi
Zhengshi
Hopefully a quick question... Do other people with mac clients have the option to repair under game options? Or does Game Consultant actually do anything? (top right gear, about, game consultant)

My launcher is not showing the repair option and game consultant just seems to sit there for ever. I've mentioned it to support before, but getting anything useful out of them is close to impossible.
  • Windshadow_ESO
    Windshadow_ESO
    ✭✭✭
    yep the consultant has not works on the mac for me since launch
  • Zhengshi
    Zhengshi
    Thank you for the feedback, @Windshadow_ESO‌ Could you confirm if you have a "repair" option under game options please?
  • Moonraker
    Moonraker
    ✭✭✭✭
    Repair should be under Game Options (under News in main window)

    Try switching off Auto Updates in Game Options relaunch and see if Repair is available.

    If it isn't you need to let it start the new install, create the temp. folders etc. (no actual download) initially then when it starts to download over net click the Cancel button (top right cog icon for Options) And see if it is now available.

    Suggest to back up the install folder first as there is a chance if can be wiped (not to Trash) If it does not appear repeat a couple of times, relaunching each time usually will get it to show the Repair.

    Once Repair is available then let it run through and verify the install and download anything it needs.

    Game Consultant does work but doesn't really do anything except record ping and traceroute to the patch server.

    After you press Run Tests it should move across maybe stop for short time then complete . Then you have to click Open Report or Open Report Location and quite it manually.

    If it doesn't work then it's not able to connect properly to the patch server and stalls.
    Edited by Moonraker on May 3, 2014 8:14PM
  • Windshadow_ESO
    Windshadow_ESO
    ✭✭✭
    I have never been able to get game consultant to function either on the old mac pro from 2006 on 10.7.5 or on the mid 2009 mac book pro running 10.9.x it launches and done bar instantly goes to about 25% and then the application just sits there for ever I even let it set overnight once.. and attempt to quit it by moving the mouse cursor over application menu has it turn to the spinning ball as long as it is hovered over the menu bar inc the apple menu by clicking on the desktop control can be returned to the finder at which point the app can be killed with force quit I have been reporting this bug for a long time and since it works under boot camp I assume it is a mac bug tech support at one point in march sent a copy of game consultant to me as an email attachment but it too displayed the same as i describe above
    Edited by Windshadow_ESO on May 7, 2014 3:38PM
  • Moonraker
    Moonraker
    ✭✭✭✭
    So, yes the Game Consultant, while running causes the Launcher itself to hang (spinning ball) until it's finished.

    It works most of the time for me. It doesn't give as much detail as the PC version but includes;

    System Profiler (returns nothing currently)
    Netstat
    PS Aux
    Hosts Files
    Ping
    Ping
    Traceroute
    Traceroute

    The later will give a ping and traceroute to the two launcher data servers which are random as it depends on geological location for the CDN in this case Akamai (amazonews not sure if same or separate)

    Example I just ran for the later:

    | HOSTS FILE |
    ##
    # Host Database
    #
    # localhost is used to configure the loopback interface
    # when the system is booting. Do not change this entry.
    ##
    127.0.0.1 localhost
    255.255.255.255 broadcasthost
    ::1 localhost
    fe80::1%lo0 localhost

    | PING |
    PING a1092.d.akamai.net (81.52.201.73): 56 data bytes
    64 bytes from 81.52.201.73: icmp_seq=0 ttl=57 time=37.059 ms
    64 bytes from 81.52.201.73: icmp_seq=1 ttl=57 time=37.370 ms
    64 bytes from 81.52.201.73: icmp_seq=2 ttl=57 time=39.721 ms
    64 bytes from 81.52.201.73: icmp_seq=3 ttl=57 time=35.937 ms

    --- a1092.d.akamai.net ping statistics ---
    4 packets transmitted, 4 packets received, 0.0% packet loss
    round-trip min/avg/max/stddev = 35.937/37.522/39.721/1.377 ms

    | PING |
    PING a1213.g1.akamai.net (90.84.59.169): 56 data bytes
    64 bytes from 90.84.59.169: icmp_seq=0 ttl=56 time=36.589 ms
    64 bytes from 90.84.59.169: icmp_seq=1 ttl=56 time=37.115 ms
    64 bytes from 90.84.59.169: icmp_seq=2 ttl=56 time=38.163 ms
    64 bytes from 90.84.59.169: icmp_seq=3 ttl=56 time=38.174 ms

    --- a1213.g1.akamai.net ping statistics ---
    4 packets transmitted, 4 packets received, 0.0% packet loss
    round-trip min/avg/max/stddev = 36.589/37.510/38.174/0.684 ms

    | TRACEROUTE |
    1 192.168.1.1 (192.168.1.1) 1.478 ms 1.205 ms 1.202 ms
    2 80.10.125.86 (80.10.125.86) 22.648 ms 23.166 ms 22.905 ms
    3 10.125.175.138 (10.125.175.138) 26.125 ms 130.475 ms 22.125 ms
    4 xe-5-3-0-0.nctou202.toulouse.francetelecom.net (193.253.93.170) 21.303 ms 22.268 ms 23.096 ms
    5 ae43-0.nipoi102.poitiers.francetelecom.net (193.252.160.54) 28.050 ms 28.459 ms 28.417 ms
    6 81.253.184.110 (81.253.184.110) 58.009 ms 36.413 ms 40.417 ms
    7 81.52.201.73 (81.52.201.73) 38.394 ms 36.695 ms 35.945 ms

    | TRACEROUTE |
    1 192.168.1.1 (192.168.1.1) 1.329 ms 1.092 ms 1.117 ms
    2 80.10.125.86 (80.10.125.86) 23.723 ms 50.563 ms 22.352 ms
    3 10.125.175.202 (10.125.175.202) 21.746 ms 22.311 ms 22.270 ms
    4 xe-2-2-1-0.nctou201.toulouse.francetelecom.net (193.253.93.190) 22.198 ms 22.967 ms 21.797 ms
    5 ae43-0.nipoi101.poitiers.francetelecom.net (193.252.160.49) 30.407 ms 31.533 ms 28.485 ms
    6 ae40-0.nipoi102.poitiers.francetelecom.net (193.252.160.46) 28.261 ms 28.541 ms 32.797 ms
    7 81.253.184.110 (81.253.184.110) 38.458 ms 41.323 ms 40.276 ms
    8 tengige0-8-0-4.auvtr1.aubervilliers.opentransit.net (193.251.128.234) 36.793 ms 38.869 ms 41.176 ms
    9 90.84.59.169 (90.84.59.169) 36.469 ms 36.218 ms *
    If your Mac is unable to complete the ping or traceroute to either then it will not end or not for a long time. It should give up trying after a set period. This is why it fails which seems to indicate some issue with the connection to the launcher/ patcher servers.

    It's also an indication that you may get problems with the Launcher as the errors are often related to not being able to connect to these servers.

    It's easier to run Ping and Traceroute via Network Utility on the Mac (or Terminal if you are comfortable using that)

    a1092.d.akamai.net
    a1213.g1.akamai.net


    FYI my Launcher version is 1.3.5.964404 (in About)
    Edited by Moonraker on May 5, 2014 3:13PM
  • Zhengshi
    Zhengshi
    I guess I wasn't clear, I apologize. The game consultant doesn't work after leaving it over night as well... I can login and play the game just fine with the exception of the horrible client crashing. traceroute and its dependant ping are both able to reach the hosts just fine with sub 30ms latency. The math doesn't add up for the issue to be simply hosts unreachable.
  • Moonraker
    Moonraker
    ✭✭✭✭
    Zhengshi wrote: »
    I guess I wasn't clear, I apologize. The game consultant doesn't work after leaving it over night as well... I can login and play the game just fine with the exception of the horrible client crashing. traceroute and its dependant ping are both able to reach the hosts just fine with sub 30ms latency. The math doesn't add up for the issue to be simply hosts unreachable.
    Think it's because on the traceroute it wont stop at the last hop (usually blocked from ping for security) so just keeps going. It was noted a while ago on this post.

    The actual Game Consultant is little more than a beta build made last year and I'm sure it has some other issues as you suggest. But it does work consistently at least, for me even if a bit clunky.

    In the end it's not so useful as it doesn't provide them with the System Profiler details as it does in the PC version.

    Do you have the Repair options now in the Launcher? Usually switching off Auto Update will make it appear as above.
    Edited by Moonraker on May 7, 2014 4:24PM
  • Zhengshi
    Zhengshi
    Do you have the Repair options now in the Launcher? Usually switching off Auto Update will make it appear as above.
    Yes, thank you. It didn't come up when I switched it off though, it came up when I switched it back. The repair completed successfully and of course game still crashes, though I entertained support's odd request anyway.

    I have little faith that the game consultant will work unfortunately. watching the processes running, I never see any traceroute called in lsof, activity monitor or dtruss and the log file hangs with
    "Version:1.0
    | SYSTEM PROFILER |
    "

    I don't have the time to debug any further though, they will just have to do proper troubleshooting to figure out why it wont launch... though Im positive that was a stall tactic.
  • Moonraker
    Moonraker
    ✭✭✭✭
    Zhengshi wrote: »
    Do you have the Repair options now in the Launcher? Usually switching off Auto Update will make it appear as above.
    I have little faith that the game consultant will work unfortunately. watching the processes running, I never see any traceroute called in lsof, activity monitor or dtruss and the log file hangs with
    "Version:1.0
    | SYSTEM PROFILER |
    "

    I don't have the time to debug any further though, they will just have to do proper troubleshooting to figure out why it wont launch... though Im positive that was a stall tactic.
    Well, like I said it's not completely functioning anyhow as it is and really not much use for it. They tend to just ask for it as it works fine for PC and they don't understand it pretty much broken on the Mac version.

    I imagine using system_profiler would be a nightmare to include in a report unless it was a summarised version. It takes a long while even on my iMac and to write it.... Just assume it drops that part and continues for rest and completes when it works like for me.

    Seem to connect fine for me via lsof:
    Game\x20C 3147 xxxxxxxxxxx    5u  IPv4 0xf934f727ebfbd3d      0t0  TCP localhost:65385 (LISTEN)
    Game\x20C 3147 xxxxxxxxxxx   27u  IPv4 0xf934f72854f3d3d      0t0  TCP 192.168.1.10:65431->ec2-54-217-220-134.eu-west-1.compute.amazonaws.com:http (CLOSED)
    Game\x20C 3147 xxxxxxxxxxx   29u  IPv4 0xf934f72854f3d3d      0t0  TCP 192.168.1.10:65431->ec2-54-217-220-134.eu-west-1.compute.amazonaws.com:http (CLOSED)
    
  • Zhengshi
    Zhengshi
    Yea, they've already gotten all the contained info previously. I've sent profiler as the XML and as raw text from system_profiler. Btw takes 45 sec on my box
    $time system_profiler
    real 0m44.951s
    user 0m13.148s
    sys 0m6.217s

    This is just another one of their stall tactics... >_<

    the most frustrating thing for me is not that the game crashes, tbh. its how dismissive they are and how clueless the support team seems to be. They dont do any proper trouble shooting, ask for things they already have, blame the issues on things that cant possibly be related... and worst of all, drop communication. If they were more transparent and seemed to at least pretend they gave a ***... maybe all of this would be far less frustrating.

    Well I am just going to keep pushing back on repair and game consultant... maybe they will ask me to delete and reinstall again =P
  • Moonraker
    Moonraker
    ✭✭✭✭
    @Zhengshi But surely you have submitted you dxdiag file already?! :)
  • Zhengshi
    Zhengshi
    @Moonraker‌ you wouldnt believe how many techs have actually asked for that and msinfo output =P in the same ticket where I can scroll up and show me responding to the first guy that its a mac and doesnt have it... smh
  • Moonraker
    Moonraker
    ✭✭✭✭
    Zhengshi wrote: »
    @Moonraker‌ you wouldnt believe how many techs have actually asked for that and msinfo output =P in the same ticket where I can scroll up and show me responding to the first guy that its a mac and doesnt have it... smh
    Oh I can :) To be fair I have mostly had good intentioned help from ESO Support and before the crush of launch they answered fast and would pass it up quite quickly and got a lot of factual details. It's been slower since though my last two tickets were resolved within a day which is reasonable including not being able to sign in to forum ;)
Sign In or Register to comment.