Update 40 featuring the Endless Archive is now available to test on the PTS! You can read the latest patch notes here: https://forums.elderscrollsonline.com/en/categories/pts
Maintenance for the week of September 25:
· [COMPLETE] PC/Mac: EU megaserver for maintenance – September 26, 4:00AM EDT (8:00 UTC) - 12:00PM EDT (16:00 UTC)
· [COMPLETE] Xbox: EU megaserver for maintenance – September 26, 4:00AM EDT (8:00 UTC) - 12:00PM EDT (16:00 UTC)
· [COMPLETE] PlayStation®: EU megaserver for maintenance – September 26, 4:00AM EDT (8:00 UTC) - 12:00PM EDT (16:00 UTC)

Random fps drops - I am at the end of my rope

I have a 6 month old HP Omen gaming laptop - 16GB RAM, SSD, Nvidia RTX3060 graphics card.
When I had just installed ESO, it ran very smoothly. However, for the past two months or so I keep getting random fps drops where I will suddenly drop from 100 to 10 fps.
This can happen at any time, not just when there's a lot going on, and it can go back up suddenly as well. It has happened during dungeons and trials, during fights in Cyrodiil but also when I'm just picking flowers or standing still in a field. There seems absolutely no logic in what triggers it, as sometimes I'll be in a big 10fps fight in Cyro when it suddenly smoothens out and goes back to 80/90 with the fight and all the visual effects still going on. Other times I'll be standing somewhere doing absolutely nothing, there are no other players around and whomp whomp, 10 fps.
This only happens with ESO. For example - I can play Cyberpunk 2077 at max graphics settings without any issue.

What I have tried so far:

* I have tried every step in this guide - https://help.elderscrollsonline.com/app/answers/detail/a_id/32450/kw/performance (drivers updated / Windows updated / graphics settings all the way from Low to Maximum / turned off all add-ons / repaired the game client)
* I have changed the number of particles, viewing distance, tried every different graphic setting
* I have turned multi-threaded rendering on and off
* I have SET SoftwareOcclusionCullingEnabled "1" in user settings (https://www.reddit.com/r/elderscrollsonline/comments/11qbczu/psa_enable_software_occlusion_culling_beta_for/)
* I have SET MaxCoresToUse.4 "2" in user settings (https://forums.elderscrollsonline.com/en/discussion/599878/fps-after-patch/p2)
* I have changed power management settings (https://forums.elderscrollsonline.com/en/discussion/623661/horrendous-memory-leak-frame-drops-recently/p2)
* I have installed and used cc-cleaner
* I have used DDU to uninstall and then reinstall my graphics card drivers
* I have uninstalled and reinstalled ESO

Extra info - I play on PC/NA and have to play with a VPN because of a server routing issue that seems to affect most players in my region where all parties are saying "not our problem" (https://forums.elderscrollsonline.com/en/discussion/626423/se-asia-players-get-errors-108-200-334-and-increased-ping-on-pc-since-jan-25)

So far, NOTHING has helped. Does anyone have any more suggestions for me to try?
Sign In or Register to comment.