Update 43 is now available for testing on the PTS! You can read the latest patch notes here: https://forums.elderscrollsonline.com/en/categories/pts
Maintenance for the week of July 22:
• [IN PROGRESS] Xbox: NA and EU megaservers for patch maintenance – July 24, 6:00AM EDT (10:00 UTC) - 12:00PM EDT (16:00 UTC)
• [IN PROGRESS] PlayStation®: NA and EU megaservers for patch maintenance – July 24, 6:00AM EDT (10:00 UTC) – 12:00PM EDT (16:00 UTC)

Addon - Custom Idle Animation - animations start during some activities

vsrs_au
vsrs_au
✭✭✭✭✭
✭✭
I'll probably create an ESOUI account and post it there also, but for now, perhaps someone on this forum could help me ?

I'm using the addon "Custom Idle Animation" and I'm happy with it, but for a minor annoyance. When I'm doing one of the following activities, the idle animations sometimes start, and fairly soon too:
- fishing, but only when I finish reeling in and move the fish to my inventory. The animation will start, and I have to cancel it by casting the line out again
- conversing with NPCs, or at least, in the listening part of this
- immediately upon arriving at a wayshrine, i.e. the usual idle delay configured in the addon seems to be ignored. In fact, now that I think about it, the wayshrine travel time (spent staring at a zone transition screen) is probably considered idle time
- possibly other cases, but those are all I can recall right now

I tried to find ESOUI API functions covering these activities, and there is one for interactions in general (IsInteracting), but nothing specific to the above 2 activities.
Edited by vsrs_au on December 2, 2022 2:07AM
PC(Steam) / EU / play from Melbourne, Australia / avg ping 390
  • Baertram
    Baertram
    ✭✭✭✭✭
    I'm not using this addon but reading the addon comments at
    https://www.esoui.com/downloads/info1002-CustomIdleAnimation.html#comments
    they often say 20s is a good idle start time.

    And the idle time is considered only before the first animation starts, after that (in between other animations) it's not considered any longer, only the normal animation waiting times are considered.

    So maybe you need to setup your start idle time higher.
    No matter what I set the Delay time at, all the emotes I've selected will play one right after the other. The delay time works initially. i.e. I set it to 20 seconds. After I've been standing idly doing nothing for 20 seconds, the emotes will begin to play.

    But it's not 20 seconds in between each emote. It's 20 seconds of standing idle and then they all play immediately one right after the other. Is this a bug or is this just how the addon is supposed to work? Because I want there to be some delay time in between each emote too, not just initially after being idle.

    I'm sorry you're having trouble setting up your idle sets. Indeed I've realized that I wrote a wrong description for the delay. The delay is only used initially, after that the minimum time of the emote that is currently played is being used. I've added a feature with the new update, in which you can set an emote to loop during its minimum time or not. By the way, you can also add the idle emotes (/idle, /idle2, /idle3, ...) into your idle sets.

    Options
  • vsrs_au
    vsrs_au
    ✭✭✭✭✭
    ✭✭
    Baertram wrote: »
    I'm not using this addon but reading the addon comments at
    https://www.esoui.com/downloads/info1002-CustomIdleAnimation.html#comments
    they often say 20s is a good idle start time.

    And the idle time is considered only before the first animation starts, after that (in between other animations) it's not considered any longer, only the normal animation waiting times are considered.

    So maybe you need to setup your start idle time higher.
    No matter what I set the Delay time at, all the emotes I've selected will play one right after the other. The delay time works initially. i.e. I set it to 20 seconds. After I've been standing idly doing nothing for 20 seconds, the emotes will begin to play.

    But it's not 20 seconds in between each emote. It's 20 seconds of standing idle and then they all play immediately one right after the other. Is this a bug or is this just how the addon is supposed to work? Because I want there to be some delay time in between each emote too, not just initially after being idle.

    I'm sorry you're having trouble setting up your idle sets. Indeed I've realized that I wrote a wrong description for the delay. The delay is only used initially, after that the minimum time of the emote that is currently played is being used. I've added a feature with the new update, in which you can set an emote to loop during its minimum time or not. By the way, you can also add the idle emotes (/idle, /idle2, /idle3, ...) into your idle sets.
    Thanks. I think I might consider updating my local copy of the addon, to see if I can get it to put idle time between the emotes.
    PC(Steam) / EU / play from Melbourne, Australia / avg ping 390
    Options
  • Baertram
    Baertram
    ✭✭✭✭✭
    It could be that the server "queues" the emotes and thus you cannot insert idle time in between!
    Once you try to start them you can just delay the first call and all others are queued after that and executed directly, if not aborted.
    Options
  • Necrotech_Master
    Necrotech_Master
    ✭✭✭✭✭
    ✭✭✭✭✭
    i used to use this addon, and always thought it was funny when i started eating food while i was fishing (with the fishing reel still out) lol

    fishing was the one activity that i noticed the idle animations starting kind of funny, but had no issue at other periods
    plays PC/NA
    handle @Necrotech_Master
    active player since april 2014
    Options
Sign In or Register to comment.