The Scribes of Fate DLC and Update 37 base game patch are now available to test on the PTS! You can read the latest patch notes here: https://forums.elderscrollsonline.com/en/categories/pts

Mac Minimum and Recommended System Requirements Update

ZOS_JessicaFolsom
ZOS_JessicaFolsom
Community Manager
On September 23, we will update both the minimum and recommended Mac system requirements for The Elder Scrolls Online. Specifically, supported models are now mid-2017 and newer Macs with at least 4GB of GPU memory.

ESO players currently running the game on Mac models older than those now supported should be able to continue to play the game, however, we cannot guarantee an optimal experience in the future.
Edited by ZOS_JessicaFolsom on September 16, 2021 5:44PM
Jessica Folsom
Lead Community Manager - ZeniMax Online Studios
Facebook | Twitter | Twitch | Tumblr | Instagram | YouTube | Support
Staff Post
  • Druachan
    Druachan
    ✭✭✭
    Can you guarantee an optimal experience now?
    Say please, before you AAAAAaaaarrrgghhh at me.
  • Inoki
    Inoki
    ✭✭✭
    ESO players currently running the game on Mac models older than those now supported should be able to continue to play the game, however, we cannot guarantee an optimal experience in the future.

    That must be a joke. Have you actually tried to play on a Mac? Do you know we can't even port from zone to zone? I'm now stuck nearly a month in one zone, because I got better things to do than try to play a game that is unplayable, while my subscription is running for the next 7 months, and you guys, along with the folks at Steam, refused to refund me for the horrible experience you caused with your blatant disregard to your Mac user base.
  • Rogue_WolfESO
    Rogue_WolfESO
    ✭✭✭
    How many players currently play using a Mac? The answer probably equals the reason behind the apathy towards Mac issues.
  • Inoki
    Inoki
    ✭✭✭
    Rogue_Wolf wrote: »
    How many players currently play using a Mac? The answer probably equals the reason behind the apathy towards Mac issues.
    You do realise that more would likely play if it was possible to, especially due to the amount of good games on Mac, more Mac users would likely try out ESO.

    I think that—as always—Mac sets the bar high, and soon everyone will follow suit, and perhaps companies will make more games for the Mac. As an M1 owner, I would not use anything else. The performance of this machine is unlike anything out there. No Windows PC that I tried in 20 years has been as smooth as a Mac.
  • Sqada
    Sqada
    Soul Shriven
    Rogue_Wolf wrote: »
    How many players currently play using a Mac? The answer probably equals the reason behind the apathy towards Mac issues.

    The number of players does not matter. It says on the box that mac is supported, but in fact the client is not working. There is an error in the system requirements, since the installation requires not 85, but 160 GB of free space. The game crashes constantly. Moreover, what is even worse, except for the letter from Matt Firor, nowhere does it say that m1 will not be supported. In other words, this becomes known already when communicating with the support service. I understand that all this is not said to increase sales, but it is deception and disrespect to the customer.
  • keto3000
    keto3000
    ✭✭✭
    I just installed the game on my new Mac Mini M1, 16gb. It runs very smooth so far. I've played on a 2013 imac since launch so I know the roller coaster ride mac users have had. Once the client became 64 bit a few years back, the game has usually run very stable for me. I'll start testing it on this new M1 mac and give more feedback re pvp, dungeons, etc.

    “The point of power is always in the present moment.”

    ― Louise L. Hay
  • Svartulv
    Svartulv
    ✭✭✭
    Posting here for any new players, since ZOS doesn't seem to care to update their website and this thread.

    ARM-based Macs are not supported. The game won't launch.

    Known workarounds are listed on the official support page, but be aware that they might stop working in the future, as the new game updates are released.
Sign In or Register to comment.