ESO not using dedicated laptop GPU ?

Ironthorne
Ironthorne
Soul Shriven
I'm having serious issues running ESO on my laptop (config below). Although my laptop exceeds min requirements, even when putting everything on min settings, I still get stuck loading the game (endless character load) and for the few times I manage to get in, when I try to port I crash or get a time-out.

But I've noticed something strange : when I generate a report using ESO Gameconsult, in the Display Devices section it refers to the integrated graphics HD Graphics 4600 and only lists my GTX 765M under devices. I've used the NVidea Control Panel to associate ESO with the "High-performance NVIDIA processor", but that doesn't change anything.

Is it possible that ESO is only using the integrated graphics?
Does anybody have a suggestion for a fix?

Laptop Config :
Operating System: Windows 8.1 64-bit
Processor: Intel(R) Core(TM) i7-4700MQ CPU @ 2.40GHz
Memory: 8GB RAM
GPU : NVIDIA GeForce GTX 765M
  • Audigy
    Audigy
    ✭✭✭✭✭
    ✭✭
    You could try to deactivate the integrated GPU processor in the device manager.

    If your Nvidia card is not broke (which I think it isn't), your Laptop should automatically use this one then)

    Besides that what you tried was the right move. Just for clarification, you did the following yes?

    1. Right click on the desktop and open nvidia control panel.
    2. Then head to the "manage 3D settings" drop down under 3D settings.
    3. Then under the global settings tab, underneath preferred graphics processor, change it from auto detect to high performance graphics processor.

    You also have your Laptop plugged in to a power supply yes? Because if not, the Laptop can use the integrated card to save power.

    Also make sure to reboot if you change something ;)
    Edited by Audigy on April 30, 2014 7:35AM
  • Ironthorne
    Ironthorne
    Soul Shriven
    Thanks for your feedback.
    I'll give that a go tonight.

    In answer to your questions :
    Yes, I followed steps 1 and 2, but in step 3 I left the global settings to auto detect whilst in the second tab I selected the ESO exe and specified that that needed to run with the high performance nvidia processor. I'll check tonight if forcing the laptop to only use the gpu changes something.

    Yes, power-cable is plugged in. :smile:

    And yes, I did reboot :smiley:
Sign In or Register to comment.