Update 43 is now available for testing on the PTS! You can read the latest patch notes here: https://forums.elderscrollsonline.com/en/categories/pts
Maintenance for the week of July 15:
• PC/Mac: No maintenance - July 15

Experiencing odd issues on the Series X

Before I get into the details, I have uninstalled and re-installed the game. I have also hard reset the console. Nothing has worked so far.

These are not game breaking issues, but they are extremely annoying. I don't know what causing them, as they simply appear/disappear at random.

The most frequent of issues is the disappearing bow. Just the bow. No other weapon on any other character. It disappears completely. Making the issue even more annoying, there's a dagger floating on the ground between the character's legs.
When it happens: whenever it wants. Typically, the bow will disappear when changing screens. Then, it'll just pop back in, and then a weapon swap later, disappears again.

Here's the odd thing: everyone in my group or playing around me says they can see the bow just fine!

Next issue is, after some play time, swapping weapons creates a momentary lag between swaps. The entire screen briefly freezes, then resumes as if nothing happens.
Once this issue starts, the only way to remove it is to log out and back in again.

Another issue seems to be... well, not sure how I can really explain this other than "targeting misfires"?
Since the game calculates damage immediately on the highlighted enemy, what I've seen is other enemies are taking the damage while the focused enemy is not. For a brief moment, the enemy receiving the damage will receive the highlight before going back to the original enemy which was targeted.

I have noticed this tends to happen about the time the above pause happens, so it's possibly related. I swap weapons very frequently, so between this, the target could likely change between the stall.

Finally, a visual obscurity. When I played on the XBox One X, it seemed the draw distance was better and clearer. For example, standing on the bridge on the way to the Brass Fortress at night, I would stop to look at the lights on the buildings to the left.
Now, they're obscured with some gross looking... fog or lighting effect which really looks horrible.

The output resolution is 4K@60Hz (max my current TV can produce), in game mode, HDR enabled, and all setting at default, but even playing around to adjust the contrast and brightness, the fog-like ugliness won't go away. Really miss this view being crystal clear.

Any ideas to this or should I try to reinstall everything again? I hope not. This takes far too long. :disappointed:

Edited by ZOS_Bill on January 20, 2022 12:44AM
  • TequilaFire
    Believe it or not the bugs you describe especially disappearing weapon and the weapon between your feet have been around for a while on all platforms. And yes they reduced the draw distance on both consoles and fogged it trying to improve performance.
  • Sylvermynx
    The weapon under your feet can be "mitigated" by turning "show polymorph helmet" off in your game settings.

    [I know, I know - really, I'm not crazy.... Someone a year or so back posted that, and apparently it worked for many of those with the issue, at least on PC. I don't know if it will work on the series X or not, but it can't hurt to try?]
    Edited by Sylvermynx on January 14, 2022 9:26PM
  • ZOS_Bill

    Have you tried clearing the local save cache to help with the disappearing weapon?

    To delete save data on the Xbox One
    1. From the Xbox Home Menu, navigate to My games & apps.
    2. Go to Games.
    3. Highlight The Elder Scrolls Online tile and press the [Menu] button of the controller.
    4. Select Manage Game. Highlight and select Save Data for the desired user.
    5. Select Delete.
    The Elder Scrolls Online: Tamriel Unlimited - ZeniMax Online Studios
    Forum Rules | Code of Conduct | Terms of Service | Home Page | Help Site
    Staff Post
Sign In or Register to comment.