Maintenance for the week of January 17:
• [COMPLETE] PlayStation®: NA megaserver for maintenance – January 19, 2:00AM EST (7:00 UTC) – 12:00PM EST (17:00 UTC)
• [COMPLETE] Xbox: NA and EU megaservers for maintenance – January 19, 6:00AM EST (11:00 UTC) – 10:00AM EST (15:00 UTC)
• [COMPLETE] PlayStation®: EU megaserver for maintenance – January 19, 6:00AM EST (11:00 UTC) – 10:00AM EST (15:00 UTC)
• ESO Store and Account System for maintenance – January 20, 8:00AM EST (13:00 UTC) – 3:00PM EST (20:00 UTC)

Much Better on Mac?

AngryLorekeeper
I have been super critical of the way ZOS has handled the problems surrounding the game on the Mac platform over the past 10 months. However, I do have to admit that after the last server maintenance things improved significantly for me and now this latest patch seems to have fixed whatever was ailing the game. It took a while but I feel like they did finally take things seriously and got them fixed. How has everyone else's experience been lately?
  • fiender66
    fiender66
    ✭✭✭
    I'd agreed till this morning (3rd Nov). I have continual crashes, and this is not happening on my Win PC.
    I fear I have to reinstall, for repair has been of no avail.

    Done. No improvement. I tried also to login w/o STEAM and to remove all addons. Curious that an older iMac of mine, with Catalina (and not Big Sur) shows no problem at all.
    Edited by fiender66 on November 3, 2021 5:34PM
  • Squatch4x4
    My Mac client is working better as well. I haven't used it in a month or two due to the crash issues, but after a few days on the new patch it is promising. Now if they can just fix Bluetooth controller support :smile:
  • vgabor
    vgabor
    ✭✭✭✭✭
    Well, the quest marker crash still not fixed
    Thread 3 Crashed:
    0   com.zenimaxonline.eso               0x00000001009ee5ad ZoAStar<Breadcrumb::Node, 4294967295u, 4294967295u>::Cleanup() + 95
    1   com.zenimaxonline.eso               0x00000001009edc73 ZoAStar<Breadcrumb::Node, 4294967295u, 4294967295u>::~ZoAStar() + 25
    2   com.zenimaxonline.eso               0x00000001009ecd78 QuestConditionPathFinder::ExecutePathFind(Breadcrumb::Node*, Breadcrumb::Node*, ZoList<Breadcrumb::Node*>&) const + 92
    3   com.zenimaxonline.eso               0x00000001009eed97 QuestConditionPathFinder::FindBreadcrumbsTask::DoBackgroundThreadWork() + 85
    4   com.zenimaxonline.eso               0x00000001031c253d ZoTaskQueue::DoBackgroundThreadWork(ZoTaskQueue::TerminateCondition, unsigned int) + 443
    5   com.zenimaxonline.eso               0x00000001031c32d1 ZoTaskQueueUpdater::Run() + 103
    6   com.zenimaxonline.eso               0x00000001003dbc1f ZoWorkerThreadUpdater::Run() + 53
    7   com.zenimaxonline.eso               0x00000001031c39bb ZoThread::ThreadFunc(void*) + 65
    8   com.zenimaxonline.eso               0x00000001031c40cb (anonymous namespace)::ThreadExecutionFunction(void*) + 82
    9   libsystem_pthread.dylib             0x00007fff72640109 _pthread_start + 148
    10  libsystem_pthread.dylib             0x00007fff7263bb8b thread_start + 15
    
  • Jharym
    Jharym
    Yes, for me, it has stopped crashing. I'm on a late 2015, Mojave. iMac.
    No problems with any wayshrine, door, zone movements, delves.
    Used to have crashes on all of those, character switch and log out as well, nothing now. Mind you, it's taken long enough.
    I used the reduced window trick to work around the problem, not ideal though.
    I'm not going anywhere near the OS updates, I bet they are not really compatible.
Sign In or Register to comment.