Maintenance for the week of January 24:
• PC/Mac: No maintenance – January 24
• PC/Mac: NA and EU megaservers for patch maintenance – January 27, 4:00AM EST (9:00 UTC) – 8:00AM EST (13:00 UTC)
• ESO Website for maintenance – January 27, 2:30PM EST (19:30 UTC) – 3:30PM EST (20:30 UTC)
• ESO Store and Account System for maintenance – January 27, 2:30PM EST (19:30 UTC) – 3:30PM EST (20:30 UTC)

CP armory exploit fix broke saving CP config on previously saved builds (only the first time)

Muttsmutt
Muttsmutt
✭✭✭✭✭
EDIT 2:
see this post for additional info and advice.
here's a place to save your builds. you need to make an account on uesp.

EDIT:
upon further testing, the same issue occurs even without equipping build 2 at any point. simply saving over & subsequently loading an armory slot that had assigned CP saved before the fix rolled out, will create the issue.

-assign CP
-save build over previously saved build that included CP config
-load build
-CP is unassigned despite your saved build having CP config saved

in order to address it, you have to save the build with assigned CP (just one star is enough), load the build, reassign CP (your actual config). seems to work afterwards.
assigned CP config that is saved to an armory build doesn't actually apply, in this specific situation:

-both the old build 1 and build 2 have assigned CP config saved (? i thought they were supposed to reset after fix)
-save over build 2 with unassigned CP (no gear, no active skills, only crafting passives and attributes assigned)
-reassign CP (equip gear, equip active skills)*
-save over build 1
-equip build 2
-CP is now again unassigned, as it should be, because build 2 has empty CP config saved
-equip build 1
-CP is now again unassigned, despite build 1 having assigned CP config saved

*this is the first reassign after the reset from the fix
Edited by Muttsmutt on November 5, 2021 9:54AM
PC-EU // UNDEAD
  • Muttsmutt
    Muttsmutt
    ✭✭✭✭✭
    assigned CP does properly save even after it has been reset as described above, if you reassign the CP again, and save over build 1 again. it seems to work henceforth, even when switching back and forth between the two builds.

    some more info:
    this has so far happened on two chars, first one i had assigned CP, saved build 1, then reset CP (paying the 3k fee), saved build 2, and the issue described above still happened when i followed the steps as described above.
    third character, i assigned just one CP tree, saved build 1, and equipped build 1 right after. the one assigned CP tree was reset. i reassigned another CP tree, saved build 1, equipped build 1 right after- and the assigned CPs were saved properly, and applied properly when the build was loaded.

    may be an issue with freshly reset CP and/or overwriting armory saves from before the fix was rolled out.
    Edited by Muttsmutt on November 4, 2021 1:19PM
    PC-EU // UNDEAD
  • ZOS_GinaBruno
    ZOS_GinaBruno
    Community Manager
    Thanks for the info, we're investigating and discussing this on our end now.
    Gina Bruno
    Senior Community Manager
    Dev Tracker | Service Alerts | ESO Twitter | My Twitter
    Staff Post
  • Muttsmutt
    Muttsmutt
    ✭✭✭✭✭
    thanks for the quick response!

    so far it doesn't seem like a huge issue since it looks like it can be overcome by redoing, saving, redoing, saving again.
    but if people aren't aware, worst case scenario, they might end up saving a build today, loading it later, and not realizing their CP is actually unassigned.
    PC-EU // UNDEAD
  • Xenite
    Xenite
    ✭✭✭
    Went and saved all my builds last night before the reset. Went to put them back this morning, CP just stays empty even though it's clearly saved on the builds.
  • Muttsmutt
    Muttsmutt
    ✭✭✭✭✭
    @Xenite as i mentioned in the OP, you can fix this by assigning your CP (any number of CP, you can just fill one star and save), saving over the build, loading the build (your CP is now empty), and then assinging your CP again (the real build this time). it should work. could you try that and post whether it worked?
    PC-EU // UNDEAD
  • mbeetley_ESO
    mbeetley_ESO
    ✭✭✭
    I hadn't had any issues with CP and armory until this morning, when I logged in and all my CP were unassigned. Fortunately, my different builds mainly just varied in equipment, skills, and active CP slots so it wasn't too difficult to reassign them all. I tried the suggested fix of assigning one point, resaving a build, then assigning them all and saving again. Something of a pain to redo two builds, but it looks like they're both saved again. I've quit and reloaded and the CP are staying assigned. Here's hoping that any fix they implement doesn't reset them again!
  • mbeetley_ESO
    mbeetley_ESO
    ✭✭✭
    Follow-up to the above. I just logged in with an alt character with whom I hadn't used the armory, and saw the message that the Champion Point system had been revamped with this update, and that all CP would have to be reassigned. I didn't get that message with my main after Monday's update, not to mention the fact that I'm pretty sure I logged in with this alt on Monday after the update as well.
  • tomofhyrule
    tomofhyrule
    ✭✭✭✭✭
    Follow-up to the above. I just logged in with an alt character with whom I hadn't used the armory, and saw the message that the Champion Point system had been revamped with this update, and that all CP would have to be reassigned. I didn't get that message with my main after Monday's update, not to mention the fact that I'm pretty sure I logged in with this alt on Monday after the update as well.

    CP for all characters was reset after the hotfix: https://forums.elderscrollsonline.com/en/discussion/590509/

    It's because there was an issue where loading an armory build would end up giving you stars for both builds, which would then overflow the CP you had available. The only way to fix that was to reset the CP to zero for affected characters.
  • PurpleScroll
    PurpleScroll
    ✭✭✭
    I don't understand this, because mine saved first time perfectly fine. I saved into my builds once, and have been able to load them with no problems.
  • silvereyes
    silvereyes
    ✭✭✭✭✭
    *deleted*
    Edited by silvereyes on November 4, 2021 6:35PM
  • Artiamus
    Artiamus
    Went to setup my tank with a build for tanking and one for crafting, instead I found that it was not changing skills at all and keeps resetting my CP. After trying to fix it twice I gave up for the day.
    Main: Ziakesh-ka'dar Ne Quin-al, Khajiit Nightblade
  • Kyzeragon
    Kyzeragon
    ✭✭
    Tested this some more as well. As long as you load and THEN save, it should work. So the problem is that any saving you do to the existing build before you load it for the first time will not retain the CP.

    That is, it's not necessary to assign your CP and then save to the build for the first time. The steps to properly fix your armory build are:
    1. Log in, your CP has been reset but ignore that for now
    2. Load the armory build - the CP is empty but everything else loads
    3. Assign your CP (through addon, or manually)
    4. Save over your existing armory build - the build is fixed going forward
    5. Repeat 2~4 for each of your armory builds

    Note that this is not a problem for new, empty builds that have not had CP previously saved.
  • JonnAndCo
    JonnAndCo
    ✭✭
    Double saving doesnt always work (I put some points in, saved once, then finished and saved again). One of my characters had all abilities AND attributes wiped in the process and I had to redo the entire character. Another wipes my CP even after double saving when trying to load an armory slot. Such a hassle, I feel like I have been spinning my wheels all day and I am not sure if anything is really solved.
  • Integral1900
    Integral1900
    ✭✭✭✭✭
    A little warning would’ve been nice, I give up, I’m just going to write my entire build on a piece of paper and Sellotape it to the wall. 🤬
  • Onigar
    Onigar
    ✭✭✭
    A little warning would’ve been nice, I give up, I’m just going to write my entire build on a piece of paper and Sellotape it to the wall. 🤬

    Thats a good idea, the yellow stickies with my build info keep falling off the bottom of my screen .... ;)
    PC NA
    Addon Author:
    Currency Manager: http://www.esoui.com/downloads/info1998
  • Darkmage1337
    Darkmage1337
    ✭✭✭✭✭
    @ZOS_GinaBruno @ZOS_Kevin

    Is there any update on a potential solution to this?
    GM of Absolute Virtue. Co-GM of Absolute Vice.
    6-time Former Emperor, out of 12 characters.
    3 Templars, 3 Sorcerers, 2 Nightblades, 2 Dragonknights, 1 Warden. 1 Necromancer.
    The Ebonheart Pact: The Dark-Mage (Former Emperor), The Undying Nightshade, The Moonlit-Knight, The Killionaire (Former Emperor), Swims-Among-Slaughterfish (Former Emperor), The Undead Mage
    The Aldmeri Dominion: The Dawn-Bringer (Former Empress), The Ironwood Kid (Former Emperor), The Storm-Sword
    The Daggerfall Covenant: The Storm-Shield (Former Empress), The Savage-Beast, The Burning-Crusader
    CP 1,555
    @Darkmage1337
    ESO Platform/Region: PC/NA.
  • ZOS_Kevin
    ZOS_Kevin
    admin
    Hey @Darkmage1337. We are working on a solution for this issue. The problem has been identified and is actively being worked on to resolve as soon as possible.


    However, the work around others in the thread works while we are fixing the issue:
    1. Load the armory build - the CP is empty but everything else loads
    2. respend your CP where you want it
    3. Save over your existing armory build and the build is fixed going forward
    Forum Manager for ZeniMax Online Studio and Elder Scrolls Online
    Staff Post
  • angelspire
    angelspire
    Soul Shriven
    ZOS_Kevin wrote: »
    Hey @Darkmage1337. We are working on a solution for this issue. The problem has been identified and is actively being worked on to resolve as soon as possible.


    However, the work around others in the thread works while we are fixing the issue:
    1. Load the armory build - the CP is empty but everything else loads
    2. respend your CP where you want it
    3. Save over your existing armory build and the build is fixed going forward

    This doesn't work. Tested on 2 chars. CPs are still reset to 0
  • jrfk2
    jrfk2
    ✭✭
    fwiw I had 2 slots saved last night .. logged in today and Slot #2 had 0 CP points allocated .. don't have any other details to share unfortunately ...
Sign In or Register to comment.