The Scribes of Fate DLC and Update 37 base game patch are now available to test on the PTS! You can read the latest patch notes here: https://forums.elderscrollsonline.com/en/categories/pts
Maintenance for the week of February 6:
• PC/Mac: No maintenance – February 6
• EU megaservers for maintenance – February 7, 9:00 UTC (4:00AM EST) - 17:00 UTC (12:00PM EST)
• NA megaservers for patch maintenance – February 8, 4:00AM EST (9:00 UTC) - 10:00AM EST (15:00 UTC)
• EU megaservers for patch maintenance – February 8, 9:00 UTC (4:00AM EST) - 15:00 UTC (10:00AM EST)

Broken "Windowed (Fullscreen)" mode and limited resolution on macOS

thedavidventer
thedavidventer
✭✭✭
The current implementation of "Windowed (Fullscreen)" mode on macOS is broken, and does not function the way it's supposed to. It doesn't work, It is basically the same as Windowed mode. When correctly implemented, while running apps in "Windowed (Fullscreen)" mode on macOS, the app should be full-screen (no window border, taskbar or dock visible) and a three finger swipe (on touchpad) or a two finger swipe) on the Magic Mouse switches out of the fullscreen window (sort of like tabbing out of something on Windows). This works correctly in many other games, such as World of Warcraft and games from the new Apple Arcade, but it's broken in The Elder Scrolls Online.

The alternative to this would be to use "Fullscreen" mode but when playing The Elder Scrolls Online in "Fullscreen" mode, I am unable to swipe out of it in order to view other apps. I'm basically locked into the game unless I disable Fullscreen mode. Playing in a window is not ideal and having to disable "Fullscreen" mode in order to view Discord or Safari, for example, is cumbersome.

The game's resolution also seems locked to the current scaling settings in macOS Catalina, so I'm unable to change the resolution to take full advantage of the 4K display. Other games (such as World of Warcraft, for example) have this setting implemented correctly where "Windowed (Fullscreen)" mode functions like it's supposed to (It is actually fullscreen and I can swipe out of it to access other apps) and the game resolution can be changed to a higher setting than the current scaling of the macOS desktop (I can run the game in 4k and then swipe out to my scaled 2k desktop and other apps). This is broken in The Elder Scrolls Online.

Please review the latest guides from Apple in order to correctly implement "Windowed (Fullscreen)" mode on macOS:
https://developer.apple.com/library/archive/documentation/General/Conceptual/MOSXAppProgrammingGuide/FullScreenApp/FullScreenApp.html

The game performs really well on macOS but this bug is a huge frustration.

Steps to reproduce:

- Play any other game on macOS or run any other app in "Windowed (Fullscreen)" mode; notice how it is actually full-screen (and if it is not, you can click the little green icon on the top left to make it so), you are then able to swipe out of it to the desktop and/or to other full screen apps.
- Play The Elder Scrolls Online on macOS in "Windowed (Fullscreen)" mode; notice how it is just Windowed mode; it's not Fullscreen. The green Fullscreen toggle button is also missing from the top left of the window when playing in "Windowed (Fullscreen)" mode.

Related Thread:
https://forums.elderscrollsonline.com/en/discussion/comment/5771917

EDIT: Fixed terminology, included dev guide link on how to fix the issue, and moved discussion from Bug Report forums to Mac Support forums.
Edited by thedavidventer on December 27, 2020 7:38AM
David Venter - Digital Creator, macOS Gamer, Graphic Designer, Music Producer
Official Website | Facebook (Page) | Facebook (Profile) | Instagram | Twitter | Other Links
  • demerdecanswrath
    demerdecanswrath
    ✭✭✭
    Absolutely agree. 13 months ago we were told that this "wasn't a priority" what with all the crashing and performance issues. Now that everything is on schedule, can we have an update please?
    Characters:
    • Arien Larethian (High Elf Templar)
    • Relus Demerdecan (Redguard Dragonknight)
    • Elisia Bonaire (Breton Nightblade)

    Proudly playing and producing content on a 2018 15" MacBook Pro.
  • thedavidventer
    thedavidventer
    ✭✭✭
    If any of the developers are looking at this forum, here's how to fix the above-mentioned issue:

    https://developer.apple.com/library/archive/documentation/General/Conceptual/MOSXAppProgrammingGuide/FullScreenApp/FullScreenApp.html

    Please fix this!
    David Venter - Digital Creator, macOS Gamer, Graphic Designer, Music Producer
    Official Website | Facebook (Page) | Facebook (Profile) | Instagram | Twitter | Other Links
  • thedavidventer
    thedavidventer
    ✭✭✭
    Windowed (Fullscreen) mode is still broken in ESO on macOS with the Greymoor update.

    @ZOS_GinaBruno @ZOS_BillE @ZOS_KaiSchober @ZOS_AntonioP @ZOS_JessicaFolsom

    Here's how to fix this issue:
    (See the link in my previous post to this tread)

    Please pass this along to the developers to fix in the upcoming patch!
    David Venter - Digital Creator, macOS Gamer, Graphic Designer, Music Producer
    Official Website | Facebook (Page) | Facebook (Profile) | Instagram | Twitter | Other Links
  • thedavidventer
    thedavidventer
    ✭✭✭
    Found a workaround to get ESO to run Fullscreen properly, with multitasking/spaces support.

    1. Set the game to Windowed mode.
    2. Click "Window" in the macOS menu bar and select "Tile window to left of screen"
    3. Click anywhere in the left and it'll expand to fill the entire screen.
    4. You now have a properly functional Fullscreen mode, no dock or menubar, and with ESO running in its own space that you can swipe in/out of, like any other properly coded macOS app/game. Enjoy.

    You're welcome.

    Hey ZOS, please fix the game client so that Windowed (Fullscreen) mode achieves what's mentioned in step 4. When selecting Windowed (Fullscreen) mode in ESO video settings, step 4 mentioned above is what is supposed to happen. We shouldn't have to do the step 1-3 workaround. But at least this works, for now, until you guys fix it.
    Edited by thedavidventer on October 6, 2020 6:49AM
    David Venter - Digital Creator, macOS Gamer, Graphic Designer, Music Producer
    Official Website | Facebook (Page) | Facebook (Profile) | Instagram | Twitter | Other Links
  • thedavidventer
    thedavidventer
    ✭✭✭
    It has come to my attention that, perhaps, the developers working on the MacOS game client aren't even aware of the macOS fullscreen/multitasking/spaces feature. It's possible that they don't have it enabled in macOS System Preferences, so they may wonder "What on earth is this person on about?" when I explained the process above. So, here's a detailed breakdown for the devs, in case they're unaware of the feature:

    Open 'System Preferences', click on 'Mouse', Click on 'More Gestures,' and make sure that 'Swipe between full-screen apps' is enabled. Welcome to macOS multitasking/app-switching. Apps that are properly coded to make use of the macOS fullscreen functionality now provide you with the ability to swipe in/out of it - swipe between fullscreen apps, or swipe back to the desktop, etc.

    6wspkdk6l0id.png

    The ESO client does not do this in Fullscreen mode, nor in the Windowed or Windowed (Fullscreen) mode. It's incorrectly coded/not fully compatible with this functionality.

    However, as stated in my previous entry on this thread, there is a work-around: When opening the game on macOS, it first appears in a small window. Click on the top title/border of this window to make it the active window in order for its related options to appear in the macOS menu/task bar at the top. It'll look like this:

    2062upwaoedk.png

    Click on "Window" then click on "Tile Window to Left of Screen", then this happens:

    jmj96o5lui8q.jpg

    Now click anywhere in the left area where ESO is visible, and BOOM, it expands to fill the entire screen. Now you have a fully functional macOS Fullscreen mode game client that can you easily swipe in/out of.

    This is what is supposed to happen when choosing "Toggle Fullscreen Mode" or selecting Windowed (Fullscreen) mode within the game client settings, but that simply expands the window to fill available space on the desktop, while still keeping the macOS dock and menu bar. Windowed (fullscreen) mode doesn't in fact go into multitasking/spaces compatible fullscreen mode. The only way to get into a functional fullscreen mode is through this workaround by first tiling it to a side of the screen and then clicking in the area to expand it to the full screen. As a side note: when an app is tiled to a particular side of the screen, clicking in that area should NOT make it transform to full-screen app, it's should remain tiled to that particular section. So, the fact that it jumps to fullscreen after clicking in that area is also a bug, but at least this bug allows a fullscreen-mode workaround, for now.

    I seriously hope the developers will see this and fix this issue to make it work like it's supposed to. Until then, as stated in my previous entry on this thread; at least we have this work-around.
    Edited by thedavidventer on December 27, 2020 7:24AM
    David Venter - Digital Creator, macOS Gamer, Graphic Designer, Music Producer
    Official Website | Facebook (Page) | Facebook (Profile) | Instagram | Twitter | Other Links
  • soulferin
    soulferin
    ✭✭✭
    I can't shake off the feeling that Mac OS version of eso is prepared by people who doesn't have Macs and are a little bit confused by Macs native functions
Sign In or Register to comment.