The PlayStation® Network service interruption has been resolved. Thank you for your patience!
Maintenance for the week of September 21
• ESO Website for maintenance – September 24th, 11:00AM EDT (15:00 UTC) – 3:00PM EDT (19:00 UTC)
• ESO Store and Account System for maintenance – September 24th, 11:00AM EDT (15:00 UTC) – 3:00PM EDT (19:00 UTC)
The Markarth DLC and Update 28 base game patch are now available to test on the PTS! Read the full patch notes here: https://forums.elderscrollsonline.com/en/categories/pts/

Stuck on accepting terms

DemiDemon
DemiDemon
✭✭
I was able to play yesterday just fine, now I cannot get passed the new updated terms. I have accepted them 4-5 times now and it still loops me right back into it. I have even restarted the console and tried again, still stuck in that exact same loop.
PC/Xbox One - NA
  • ELawlis
    ELawlis
    ✭✭✭
    XB1/NA Same issue. Have tried hard resetting console and game. I’ve heard PS4/NA has same issue.

    Edit: same results from deleting console save data.
    Edited by ELawlis on September 8, 2020 11:39PM
  • sweetest85b14_ESO
    sweetest85b14_ESO
    Soul Shriven
    Experiencing the same exact thing. My husband was able to accept his no problem but mine keeps looping. I even tried on his xbox and same thing.
  • Zahktar
    Zahktar
    ✭✭
    Same.. I've tried restarting my console, clearing save data, swapping to EU server and back, got nothing. Some of my friends have made it into the game.. the lucky ducks. :persevere:
  • davidj8291
    davidj8291
    ✭✭✭✭
    In the bug reports forum, they said they were working on it.

    10 hours ago.

    Looks like no ESO and we get screwed out of daily rewards and a day or more of the event. Can't really say I expect anything else at this point.
  • ZOS_GinaBruno
    ZOS_GinaBruno
    Community Manager
    We're looking into this now - thanks for the reports.
    Gina Bruno
    ESO Community Manager
    Dev Tracker | Service Alerts | ESO Twitter | My Twitter
    Staff Post
Sign In or Register to comment.