Maintenance for the week of April 3:
• PC/Mac: No NA megaserver maintenance – April 3
• PC/Mac: EU megaserver for maintenance – April 3, 8:00PM EDT (April 4, 00:00 UTC) – April 4, 10:00AM EDT (14:00 UTC)

Update on launcher stuck

For a week now, I have been unable to get into ESO. I have not updated the game in a while, and every time I try, the launcher loads up to 14% and exactly 45479.14 MB remaining and just stops there. Aside from not completing the update, it also makes my whole PC laggy as hell, and won't close unless I use the task manager. I have tried completely uninstalling the game, redownloading it and reinstalling it, but it changed nothing. It still goes up to 14% and 45479.14 MB remaining.
  • ZOS_Bill
    If your launcher is stuck updating, there are a few troubleshooting steps below that may help.

    Create an Anti-virus or Firewall Exception for ESO

    Each antivirus program is different and we recommend that you view the antivirus developer's website for full instructions on how to add exceptions.

    The application files that may require exceptions are:
    • Bethesda.net_launcher: C:\Program Files (x86)\ZenimaxOnline\Launcher
    • ESO.exe: C:\Program Files (x86)\ZenimaxOnline\The Elder Scrolls Online\game\client\eso.exe
    • Steam.exe: C:\Program Files (x86)\Steam\steam.exe

    Some antivirus programs require entire folders to be selected instead of a single file.When this is the case, the file paths below are what you should use. If required by the anti-virus program, include all subfolders since every file is critical to run the game.
    • C:\Program Files (x86)\Zenimax Online\The Elder Scrolls Online\
    • C:\Program Files (x86)\Steam\

    Repair the ESO Launcher
    1. Open The Elder Scrolls Online Launcher by right-clicking on the icon on the desktop and selecting Run as Administrator.
    2. Wait for the launcher to open completely.
    3. If multiple ESO clients are installed and available through the launcher, make sure you have the correct version highlighted by clicking on it once.
    4. Open the Game Options dropdown menu and click on the option for Repair.
    5. Allow the launcher to examine all the files for the game. This may take some time.
    6. If any files are found to have problems, the launcher will re-download those files.

    Delete the Program Data
    1. Close the ESO Launcher.
    2. Navigate to the patch installation folder,
    3. By default, this folder will be located here: C:\Program Files (x86)\Zenimax Online\Launcher\ProgramData.
    4. Locate and delete the ProgramData folder.
    5. Restart the ESO Launcher.

    There are some additional steps you can also try in the help article below.

    What do I do if my ESO launcher won't start or gets stuck at "Looking for launcher updates"?
    The Elder Scrolls Online: Tamriel Unlimited - ZeniMax Online Studios
    Forum Rules | Code of Conduct | Terms of Service | Home Page | Help Site
    Staff Post
  • Gaggin
    This happend to me every other patch. Its to do with my isp. What i do is simply disconnect my internet, turn my phone into a mobile hotspot and plug it in the pc. The download goes as normal.
  • TRoclodyte
    I tried everything mentioned above and in the link provided.

    I added all the exceptions to both my antivirus and my firewall.
    I deleted the ProgramData folder.
    I verified my LAN settings.
    I disabled all the non-Microsoft startup items before restarting my computer in selective startup mode.
    I deleted the ProgamData folder and the host.developer logs.

    However, I have not tried the launcher repair option, because I see none.


    So I ran the Game Consultant. Here is the link to the report in my Google Drive:
  • ZOS_Bill

    Since none of the troubleshooting has helped with your issue with the update getting stuck, you should open a ticket with customer support for further assistance.
    The Elder Scrolls Online: Tamriel Unlimited - ZeniMax Online Studios
    Forum Rules | Code of Conduct | Terms of Service | Home Page | Help Site
    Staff Post
Sign In or Register to comment.