Maintenance for the week of June 24:
• PC/Mac: No maintenance – June 24
• ESO Store and Account System for maintenance – June 26, 4:00AM EDT (08:00 UTC) – 12:00PM EDT (16:00 UTC)

Is minimum frame time / FPS limiter currently broken?

LjDaBadBoy
For specific reference, the UserSettings.txt file found in Documents/Elder Scrolls Online/live/ contains this parameter:
SET MinFrameTime.2 "0.01000000"

With its default value, frame rate should be limited to 100 fps. With minimum graphics settings and v-sync off, I'm able to get 100–115 fps. Also, changing its value appears to have no in-game effect either, whether v-sync is on or off.

I've tested on my discrete graphics, Radeon Pro 555, and external graphics, RX Vega 64.
  • Mudcrabber
    Mudcrabber
    ✭✭✭✭
    It's been working for me, I've had it set to 0.0166 to limit it to 60fps with vsync off (part of a crash workaround last year). Mobile GTX 1060, hybrid with Intel graphics. Borderless fullscreen window. I think I have max prerendered frames limited to 2.

    Edit: Windows 10. I saw this in Recent Discussions and didn't notice it was under Mac tech support. Sorry.

    Edited by Mudcrabber on March 13, 2019 3:37PM
  • LjDaBadBoy
    Mudcrabber wrote: »
    It's been working for me, I've had it set to 0.0166 to limit it to 60fps with vsync off (part of a crash workaround last year). Mobile GTX 1060, hybrid with Intel graphics. Borderless fullscreen window. I think I have max prerendered frames limited to 2.

    Are you playing within macOS, my friend?

    Edit: Looks like you're playing within Windows. The macOS client recently switched to the Vulkan graphics API, and I believe ZOS has yet to implement frame limiting in parity with previous clients.
    Edited by LjDaBadBoy on February 28, 2019 10:14PM
  • Vivifier
    Vivifier
    @Mudcrabber might be playing with a modified version of mac os x ( osx86 variant). This is not the same as mac machines indeed.
    @LjDaBadBoy ; I am give or take new to mac os x BUT I think ( at least in windows) vsync works only in fullscreen games. But still I am curious to know how you got 100+ fps? Is the external gfc that boost it that much? If so can you pm me what external casing you use?

    Btw afaik the limiter is vsync . On my windows machine under a 1060 nvdia I would get around the same W/O vsync.
    Also could you please pm me your ingame settings with your pro 555?
    Edited by Vivifier on March 10, 2019 12:10PM
  • LjDaBadBoy
    To answer my own question; yes, minimum frame time is currently broken in the macOS client.

    I installed Windows 10 on an external SSD, and I am able to limit my frame rate as expected with the aforementioned parameter and with v-sync off.
    Vivifier wrote: »
    @Mudcrabber might be playing with a modified version of mac os x ( osx86 variant). This is not the same as mac machines indeed.
    @LjDaBadBoy ; I am give or take new to mac os x BUT I think ( at least in windows) vsync works only in fullscreen games. But still I am curious to know how you got 100+ fps? Is the external gfc that boost it that much? If so can you pm me what external casing you use?

    Btw afaik the limiter is vsync . On my windows machine under a 1060 nvdia I would get around the same W/O vsync.
    Also could you please pm me your ingame settings with your pro 555?

    See my statement above. Frame limiting isn't related to v-sync. At least, it isn't for the Windows client.

    I am using a 2017 15in MacBook Pro and a Razor Core X graphics enclosure with a SAPPHIRE NITRO+ Radeon RX Vega 64.
  • rluke
    rluke
    ✭✭
    Same problem.

    @LjDaBadBoy
    Has your SAPPHIRE NITRO+ Radeon RX Vega 64 coil whine under macOS ? every Vega I tried had coil whine under macOS.
    i have tried 2 Strix 64 and 2 Nitro+, but unter windows it works totally silent.

  • LjDaBadBoy
    @rluke Yes. If I recall correctly, Windows doesn't. Same as you.
  • rluke
    rluke
    ✭✭
    @LjDaBadBoy

    good news for Vega users, 10.14.5 will fix this problem, I bought a Radeon 7.
    runs great, I hope Zeni will fix the v-sync cap-Frames Problem.

    if v-sync is on I have 50 FPS on my 100hz monitor with v.sync off I have 100-150 fps
    Edited by rluke on April 2, 2019 12:09PM
  • Delsskia
    Delsskia
    ✭✭✭✭
    v-sync was nice 25 years ago when people used CRT monitors, it really has no place on a modern flat screen. Just disable it and never look at it again.
    NA-PC
    Fantasia
  • rluke
    rluke
    ✭✭
    but without fps limiter I get 100-150 fps and my GPUs fans a very loud + screen tearing

    need working v-sync or working fps limiter
  • LjDaBadBoy
    Delsskia wrote: »
    v-sync was nice 25 years ago when people used CRT monitors, it really has no place on a modern flat screen. Just disable it and never look at it again.

    Why do you say that? Why do you think there’s a demand for variable refresh rate technology like AMD FreeSync and NVIDIA G-SYNC?

    I own displays with both technologies, however, macOS currently supports neither. To me, screen-tearing is very distracting and completely breaks any immersion for me.
Sign In or Register to comment.