ESO & macOS Mojave spinning issue (solved)

raffaeleg
raffaeleg
✭✭✭
Just updated ESO and macOS Mojave. This is the result. The camera is above the player and it's spinning very fast until I go in any menu. I hope my link to the video m226v0dy02pm.png
will work. Funny to see.
Don't know how to fix it yet, but I'm working on it. Happens on an iMac Pro. Beware of it if you're a constant player of ESO.

https://dropbox.com/s/u4iypbgn3hq7jxg/IMG_0800.mov?dl=0
Edited by raffaeleg on September 24, 2018 7:08PM
  • actor90
    actor90
    Soul Shriven
    Thanks for this! of all the settings, I never thought it would be that one.
  • lolmer
    lolmer
    ✭✭
    Thank you, I had this same exact issue (others do as well, see https://www.reddit.com/r/elderscrollsonline/comments/978lbw/bug_constant_spinning/ ) and this fixed it. :) My other OS X box did not have this issue, but has "eso" already selected, so not sure if I missed a dialogue pop-up at some point on this computer.
  • iannotinbjing
    iannotinbjing
    ✭✭✭
    raffaeleg wrote: »
    Already solved. In case you have this issue just open System Preferences>Security and Privacy. Go on Privacy tab. Click on the lock on the left bottom corner, enter your password and check "ESO" and "Zenimax Online Studio Launcher". Will fix the issue. See screenshot uu2t204qmupa.png

    Thank you! I just upgraded to Mojave and everything started spinning! This fixed it.
  • EulogyL
    EulogyL
    Soul Shriven
    I upgraded to Mojavi and everything was fine until this patch. Now, my computer keeps spinning. I followed this guide (noting that the "Zenimax Online Studios Launcer" was unchecked. I checked it and... still have the spinning problem. Any other suggestions would be appreciated?
  • EulogyL
    EulogyL
    Soul Shriven
    I can play the game just fine through the launcher now so never-mind.
  • JohnT379
    JohnT379
    Soul Shriven
    The problem is NOT fixed. I have the privacy options set up as raffaeleg originally posted, but it still happens. However, my own conclusion is that this happens if you log back in to ESO using ESO program element, without using the Launcher to bring up and restart the ESO program. This probably happens because when the Quit option is taken from the ESO log-in screen, a Mac OS exception occurs and a report is generated. This means that the ESO part of the program is probably now corrupted, so that the subsequent log-in from the corrupted resident ESO program ends up giving you the Catherine Wheel camera effect after reconnection to the ESO servers.

    At the end of the day, it would seem that it would be better to go back to the version of the Mac OS client (Launcher & ESO) we had before they made changes to the rendering system. Perhaps the Bethesda software support team are unaware that the graphics cards in the Mac machines are not absolutely identical to the similar models in PCs (AMD or nVidia).
  • Deeprave
    Deeprave
    From a design point of view, I think Apple _really_ screwed up on this one.

    Sure, the extra security is indeed a Good Thing, but it would be better integrated as separate tiers of permission instead of an all or nothing thing, much like how Android permissions work. An installer could take care of this, specifying what permissions are required and asking for user confirmation, without having to navigate seemingly unrelated system options (in "Accessibility" of all places, sheesh!).
  • raffaeleg
    raffaeleg
    ✭✭✭
    JohnT379 wrote: »
    The problem is NOT fixed. I have the privacy options set up as raffaeleg originally posted, but it still happens. However, my own conclusion is that this happens if you log back in to ESO using ESO program element, without using the Launcher to bring up and restart the ESO program. This probably happens because when the Quit option is taken from the ESO log-in screen, a Mac OS exception occurs and a report is generated. This means that the ESO part of the program is probably now corrupted, so that the subsequent log-in from the corrupted resident ESO program ends up giving you the Catherine Wheel camera effect after reconnection to the ESO servers.

    At the end of the day, it would seem that it would be better to go back to the version of the Mac OS client (Launcher & ESO) we had before they made changes to the rendering system. Perhaps the Bethesda software support team are unaware that the graphics cards in the Mac machines are not absolutely identical to the similar models in PCs (AMD or nVidia).

    Indeed. Every little update of ESO, and we have to do again, and again. This because each time the main program is recognised as a new one. Very frustrating, doesn't happen with any other app on the Mac.
  • Ostacia
    Ostacia
    ✭✭✭✭✭
    I'm getting the spinning issue just now. Tried the fix above and it did not work. Any other ideas?
    Sorry, never mind. I had to uncheck and recheck everything and then all stopped spinning.
    Edited by Ostacia on December 1, 2018 8:24PM
    Mac (soon to be PC!) / NA
    Imagination is the real and eternal world of which this vegetable universe is but a faint shadow. -- William Blake
  • Raijindono
    Raijindono
    ✭✭✭
    There is a slight issue I'm seeing with this though. Steps to reproduce:
    1. Have ESO open, not in full screen window mode because that's still broken, but in window mode.
    2. Open an application that needs permissions to the accessibility area and add the new application.
    3. Return to ESO, you will find that the application is spinning as soon as it's focused.
    To resolve this, I've had to close ESO, remove all of the ESO references in the accessibility section, and re-add ESO to list on prompt.

    I don't know if anyone else has experienced this issue. It's happened to me twice now.

  • Seedier
    Seedier
    ✭✭
    Confirmed, had to remove all reference to eso in the accessibility section and add again when prompted, instant fix...
  • alterfenixeb17_ESO
    alterfenixeb17_ESO
    ✭✭✭
    And today issue is back. I have removed all references in Accessibility, added them again and it still did not resolve anything. Also this is the only game that requires such weird actions as adding anything to Accessibility so, ZOS, when it will be fixed?

    Edit: Now I have restarted system. Removed then all references in Accessibility, added them again and still no use...
    Edited by alterfenixeb17_ESO on May 21, 2019 9:46AM
  • cluanaidh
    cluanaidh
    Thank you for the suggestion. I did as instructed but the problem remains.
  • bollin
    bollin
    I have the same problem since the update for Elsweyr. I have followed the instructions found here but the problem remains.
  • bollin
    bollin
    I found a solution:
    • I have remove all applications from the list in the security dialog.
    • I have closed all open applications.
    • I have started ESO directly without using the launcher.
    • I have accepted ESO after the security notification was shown.
    • I have closed ESO.
    • I have started the game using the launcher.
    • I have accepted the launcher after the security notification was shown.

    Now I have both ESO and the launcher in the list and everything seems to work again.
  • FierceSam
    FierceSam
    ✭✭✭✭✭
    ✭✭
    Not for me.

    I have to reallow the launcher every time I log in when I get to the character selection screen.

    EVERY time.

    At least the last time ZOS managed to break their Mac client there was a one time fix. Now it’s a permanent problem.

    No doubt soon it will become another unwanted ‘feature’ we’re condemned to live with.

    Top work as always from the devs.
  • Alhatariel
    Alhatariel
    ✭✭✭
    I also must do the fix EVERY time I use the game!
  • raffaeleg
    raffaeleg
    ✭✭✭
    I started this thread long time ago. I can confirm at every update of eso with Mojave I have to open the preferences panels when in game> security >accessibility and I uncheck eso then I check again. Done in a sec but terribly annoying to do each time.
  • Aetnaria
    Aetnaria
    Soul Shriven
    I don't bother with adding the launcher to System Preferences -> Security & Privacy -> Accessibility -> Privacy, I only remove and re-add the application named "eso" after every update found here:
    hzf4gihtu8z2.png
    Of course, I also start the game by opening this application directly, so...
  • raffaeleg
    raffaeleg
    ✭✭✭
    Aetnaria wrote: »
    I don't bother with adding the launcher to System Preferences -> Security & Privacy -> Accessibility -> Privacy, I only remove and re-add the application named "eso" after every update found here:
    hzf4gihtu8z2.png
    Of course, I also start the game by opening this application directly, so...
    Same here I don’t add the launcher in security >privacy, only eso. Yours can be a good option also, thx I will try

  • Delpi
    Delpi
    ✭✭✭✭✭
    "The fix" didn't work for me. I can only play without the problem if I start the game without the launcher, with the eso client.
    "I used to be an adventurer like you. Then I took an arrow in the knee..."
Sign In or Register to comment.