The Scribes of Fate DLC and Update 37 base game patch are now available to test on the PTS! You can read the latest patch notes here: https://forums.elderscrollsonline.com/en/categories/pts
Maintenance for the week of February 6:
· [COMPLETE] EU megaservers for maintenance – February 7, 9:00 UTC (4:00AM EST) - 17:00 UTC (12:00PM EST)
· NA megaservers for patch maintenance – February 9, 4:00AM EST (9:00 UTC) - 10:00AM EST (15:00 UTC) https://forums.elderscrollsonline.com/en/discussion/627149/
· EU megaservers for patch maintenance – February 9, 9:00 UTC (4:00AM EST) - 15:00 UTC (10:00AM EST) https://forums.elderscrollsonline.com/en/discussion/627149/

The game is almost unplayable for me right now. (LAG and dc)

Benemime
Benemime
✭✭✭✭
I'm from Brazil, I've been playing the game for years, I play on a Xbox One S. This week I've been experiencing huge lag and many disconnections. The game is unplayable, I've been running tests all day, ping tests, packet losses tests, download tests, all normal, I even tried some new DNS servers, reseted my modem/router, everything that I could do, trying to figure out if the problem is on my side, but everything looks normal, I also play Overwatch and I'm not experiencing lag while playing it (lag is quiet rare, while with ESO is 24 hours now).

IDK what's happening, IDK if cables from brazil to US are damaged, I ran tests on several texas servers to try to figure out something but It looks normal, no packet losses, nothing, But I can't play ESO, it's like as if the servers are located at the moon right now.

Edited by Benemime on October 27, 2018 9:29PM
  • bmatson
    bmatson
    ✭✭
    Nope it’s not just you. I am in the US and the lag is so bad. And I have seen no reply from anyone from @zos at all regarding this.

    @ZOS_GinaBruno @ZOS_KaiSchober @ZOS_JessicaFolsom @ZOS_BillE @ZOS_GaryA can someone please comment on this ongoing issue now for days?
  • bluerosebud28
    bluerosebud28
    Soul Shriven
    I'm having the same issues. It's driving me crazy. I thought the issue was on my end but nope everything on my side is normal
  • usmguy1234
    usmguy1234
    ✭✭✭✭✭
    Last night I rubber banded from roe back to the mine resource. I hit 4 loading screens from roe to nickel. It seems whatever server the Xbox NA vivec campaign is on is unravelling at the seam. Despite the population numbers being absurdly low, I've never seen the game perform this poorly.
    Zaghigoth- Orc Stamplar
    Soul Razor- Altmer Magsorc
    Les Drago- Redguard Stamdk
    Eirius- Altmer Magdk
    Stormifeth- Altmer Magplar

    Disclaimer: My comments are a little sarcasm mixed with truth. If you can't handle that don't respond to me.

  • bmatson
    bmatson
    ✭✭
    Still no reply in a month from anyone @zos
Sign In or Register to comment.