Maintenance for the week of May 20:
• [COMPLETE] PlayStation®4: NA megaserver for maintenance – May 24, 1:00PM EDT (17:00 UTC) – 3:00PM EDT (19:00 UTC)

https://forums.elderscrollsonline.com/en/discussion/475853/
Maintenance for the week of May 27:
• PC/Mac: No maintenance – May 27
• PC/Mac: NA and EU megaservers for patch maintenance – May 28, 4:00AM EDT (8:00 UTC) – 8:00AM EDT (12:00 UTC)

PS4 - Practice Repair Kit On Siege Weapon Not Working!

lsg1990
lsg1990
Hi all, found a previous forgotten thread about this with no clear resolution,

I have just entered Cyrodiil for the first time and taken on the Siege Warfare mission. I have equipped the repair kit to my favourites reel but I am unable to use it to complete the task! I have tried logging in and out and completely switching the PS4 off and back on again.

Has anyone had similar problems? If so, did you find a resolution?
  • Nestor
    Nestor
    Community Ambassador
    Just to make sure, are you getting close enough to get the UI Prompt to repair it? I remember having to stand in a particular place for that to show up. And, is the Repair Kit qued up and ready or are you scrolling to it? I think it has to be selected and ready, but that could be different on the consoles.
    Enjoy the game, life is what you really want to be worried about.

    PakKat "Everything was going well, until I died"

  • lsg1990
    lsg1990
    Thanks. I select the Repair Kit on the selection wheel, I get close enough and it states "Use" but not "Repair". I've already completed the "Use" section of the tutorial. I'll have another got at standing in specific areas around the siege weapon to make sure and see if the "Use" changes to "Repair".

    Any console players facing this issue?

    Thanks. :s
  • lsg1990
    lsg1990
    Nope, still no good. I tried facing the siege weapons at different angles and it still did not give me the option to "Repair". I have since abandoned the quest. I don't want to waste anymore precious time on this 'tutorial'!

    Can't blame ESO, they got some bigger fish to fry.
  • TheBlaziken
    has anyone worked out how to do this? im having this problem also
  • lsg1990
    lsg1990
    @ajbennett1 I abandoned the task as I was fed up of trying. I'll raise an issue with ESO later as it's now not only affecting me. If you raise a ticket before me post on here to save me the trouble.

    Thanks! :D
  • TheBlaziken
    i dont know how but i ended up doing it, it said use and it repaired it after i equipped the repair kit, took like half hour or more but got it done lol
  • lsg1990
    lsg1990
    Thanks @ajbennett1, guess I need more sticking power!! You playing on PS4?
  • dragonknight0515
    Hold the dpad thing up and circle to the repair kit and then double tap on the repair kit using the dpad up arrow
  • SURxR3AL
    SURxR3AL
    ✭✭✭
    there isnt an option to repair just put it on your wheel and when your close to it ativate it on your wheel like your useing a potion there is not use button you will have to press up on the dpad
    NA Server (Xbox One)
    Magika Sorc - Zane Cloudreaver(EP)
    Magika Temp - Revan V'ile(EP)
    Stam DK - Kraven V'ile(AD)
    Stam NB- Relic V'alor(DC)
    Stam Sorc- Veric Septim(AD)
  • lsg1990
    lsg1990
    Thanks @dragonknight0515 and @SURxR3AL, haven't tried this method yet. Will attempt to redo the task and give it a go.

    Thanks,
  • Splatulated
    Hold the dpad thing up and circle to the repair kit and then double tap on the repair kit using the dpad up arrow

    holy crap it worked (using an xbox controller on PC)
    Edited by Splatulated on August 18, 2018 9:01AM
Sign In or Register to comment.