The issues on the European PC/Mac megaserver have been resolved at this time. Thank you for your patience!
Maintenance for the week of November 18:
· Xbox One: NA and EU megaservers for maintenance – November 20,  6:00AM EST (11:00 UTC) - 9:00AM EST (14:00 UTC)
· PlayStation®4: NA and EU megaservers for maintenance – November 20,  6:00AM EST (11:00 UTC) - 9:00AM EST (14:00 UTC)

Laucher gets stuck at Updating, Loading Applications List, or Initializing

Kcjordan18
Kcjordan18
Soul Shriven
I bought the game day before yesterday, started the install, and opened the launcher to find out that it just gets stuck at one of various screens. I've tried literally every thing that I have found on the forums, google, etc. with no luck.
I have also bought the game for my brother which we run off the same internet connection and his has downloaded fine and he can play.
I have tried the "usersettings.txt" with no prevail as well as reinstalling multiple times, turning off my firewalls and reinstalling, checking the proxy settings to make sure they were disabled, running as administrator, and checking my video drivers to make sure they were up to date.
Thing is now the ESO launcher wont even show up when I try to launch it, I've checked task manager and it doesn't even show it as a running process?
As if things weren't bad enough.
I need help, im trying to have patience , please help.
  • kickamyassa_ESO
    Might be an issue with your antivirus, try disabling it before launching the game,
  • ZOS_LenaicR
    ZOS_LenaicR
    ✭✭✭✭
    Hi @Kcjordan18,

    In that case, can you try starting your windows in selective mode, to do that :
    • Click the start button and in the search box type in MSCONFIG
    • Choose "Selective Startup" and uncheck "Startup Items"
    • Please restart your pc after this step and reload your launcher

    Feel free to come back if your issue persists.
    The Elder Scrolls Online: Tamriel Unlimited Social Team - ZeniMax Online Studios
    Facebook | Twitter | Google+ | Tumblr | Pinterest | YouTube | Base de connaissance ESO

    Staff Post
  • Kcjordan18
    Kcjordan18
    Soul Shriven
    Okay so I tried the selective startup approach and unfortunately the launcher still doesn't show up. Once again not even registering as running in task manager.
Sign In or Register to comment.