Maintenance for the week of January 20:
• PC/Mac: NA and EU for maintenance – January 20, 6:00AM EST (11:00 UTC) - 9:00AM EST (14:00 UTC)
• Xbox One: NA and EU megaservers for maintenance – January 20, 6:00AM EST (11:00 UTC) - 9:00AM EST (14:00 UTC)
• PlayStation®4: NA and EU megaservers for maintenance – January 20, 6:00AM EST (11:00 UTC) - 9:00AM EST (14:00 UTC)

High Ping, Australia

Zavs
Zavs

For some reason i have really high ping today , 400 to 999+,
normally my ping is between 220 and 270 , my internet is working fine.

Please help!
Mischievous
Midian


Zavs
Xavz

Best Answer

  • Mickydanz
    Mickydanz
    ✭✭✭
    Honestly its to do with your ISP route - the servers are overseas. The ISP could of changed your route or they were doing server maintenance to the line. I am in the same boat with 250-999 ping, but recently have been testing out a VPN. It has helped a lot with my ping is 230-300 constantly but it does cost money.

    But VPN works best for people with good network infrastructure eg NBN
    Cropsford Mayor
  • Zavs
    Zavs
    I'm with Optus NBN. I rang my ISP earlier and they told me everything is working fine.
    I don't really know why my latency is all mangle up all in a sudden.
    This constant lag spike is just doing my headin also what sort of VPN program do you use? if you don't mind me asking.
    Mischievous
    Midian


    Zavs
    Xavz
  • AzureDemon01
    AzureDemon01
    Soul Shriven
    I'm on the same boat. I have 50mbps, Before all this my regular ping is always at 200 - 250ms, i can accept that and play fine. But ever since the last monday maintenance i've been getting constant 300 - 900+.. i checked my other online games and their latency is all good. I even configured my ports open to their servers as well, and yield same results.. I'm just crossing my fingers they find something on their next monday maintenance and fixes it. :(
  • Zavs
    Zavs
    I tried playing the game today and dear me, the lag is atrocious, the skills delay is so bad, bar swap has a 5 sec delay and every minute or so i get booted out of the server. for the love of god fix your f****** server ZOS.
    Edited by Zavs on August 31, 2017 1:00PM
    Mischievous
    Midian


    Zavs
    Xavz
  • Kahina
    Kahina
    ✭✭✭
    Zavs wrote: »
    I tried playing the game today and dear me, the lag is atrocious, the skills delay is so bad, bar swap has a 5 sec delay and every minute or so i get booted out of the server. for the love of god fix your f****** server ZOS.

    It needs an AU server. No ifs, no buts. It needs an AU server.
  • ArcaneBlue
    ArcaneBlue
    ✭✭✭
    same issues. my partner and I usually get ping rate of 270-300 which is ok, last night about 6pm AEST (4am US east coast time) we started getting crazy high ping rate, it would go jump up and down between 290 and 999+, the game would randomly crash and roll back multiple times, same story this morning and we were only doing questing in coldharbour, not high stress content or big zerg battles in cyrodiil.
    we also had login issues, kept getting error 108 and 200. our internet seems fine and no other issues apart from this game being unplayable

    our location: gold coast, QLD, Ausstralia
    PC NA
    Edited by ArcaneBlue on September 1, 2017 1:42AM
    #teamEmeric
  • Morgul667
    Morgul667
    ✭✭✭✭✭
    ✭✭✭✭✭
    Same here, play on EU PC from Asia, ping is way worst than what it used to be... no way to pvp or dungeon. Can barely no normal overland PVE
  • magicsprout
    magicsprout
    ✭✭✭
    Im on iinet. dunno if it may be affecting u guys but there is a cable out somewhere around hong kong causing huge latency to all au traffic routed that way
  • Morgul667
    Morgul667
    ✭✭✭✭✭
    ✭✭✭✭✭
    Im on iinet. dunno if it may be affecting u guys but there is a cable out somewhere around hong kong causing huge latency to all au traffic routed that way

    Could be as my traffic usually goes through HK

    Started on 8/30 roughly, so far still having issues
  • Vilestride
    Vilestride
    ✭✭✭✭✭
    I am also in Australia and the exact same situation has happened to me. Since last maintenance it seems. (though I didn't play the day of maint). My ping is flickering between 400 and 999 everyone 20 seconds. It boots me from game after playing for 5-10 minutes. Normally I sit ad 270-300 ping which is fine and everything works as normal.

    My login takes 3-4 attempts to get through and I have even noticed issues connecting to the website

    This does not only occur in cyrodil this is happening to me while I craft writs in craglorn alone.

    Please ZOS, every other application I use my internet for and other games are working fine. ESO is the thing I am having connection trouble with, and its only recent soooo....

    I literally can't play.
    "insert long character list here"


    Guilds
    Dracarys
    Zombie Death Machine
  • Mickydanz
    Mickydanz
    ✭✭✭
    Zavs wrote: »
    I'm with Optus NBN. I rang my ISP earlier and they told me everything is working fine.
    I don't really know why my latency is all mangle up all in a sudden.
    This constant lag spike is just doing my headin also what sort of VPN program do you use? if you don't mind me asking.

    There are heaps of options for VPN's - If you want to test to see if it works for you NORDVPN has a 7 day trial
    Cropsford Mayor
  • Zavs
    Zavs
    Pavlina20 wrote: »

    uhh 6 weeks.
    Mischievous
    Midian


    Zavs
    Xavz
  • witchdoctor
    witchdoctor
    ✭✭✭✭✭
    Zavs wrote: »
    I'm with Optus NBN. I rang my ISP earlier and they told me everything is working fine.

    Just want to add: this is exactly what they will say. And, as far as it is worth, its true. *Their* network is fine. But when you call them, they are not able to tell you what possible node issues exist for you between home and the server in the US you are connecting to.

    Just keep that in mind.

Sign In or Register to comment.