The Markarth DLC and Update 28 base game patch are now available to test on the PTS! Read the full patch notes here: https://forums.elderscrollsonline.com/en/categories/pts/

Mouse Unlocking when hitting alt or looting

BurningSnowman
A couple of days ago I reset the keybinds to default and ever since then whenever I hit alt to exit anything (character screen, inventory, etc) or loot something (crate, mob, whatever) the mouse unlocks to the arrow cursor instead of returning to the target reticle. Logging off and back on resets it for a time, but within 30 to 60 minutes it starts happening again despite working properly for 30 to 60 min. Prior to the keybind reset, it never did this. Once the cursor is unlocked hitting Alt again returns to the reticle, but it's becoming increasingly annoying. Any thoughts, ideas, suggestions on how to get it to stop unlocking? Thank you.
  • Betheny
    Betheny
    ✭✭✭✭✭
    ✭✭
    Has ALT been set to a secondary binding for show/hide cursor?
  • Saoirse_Siobhan
    Saoirse_Siobhan
    ✭✭✭✭✭
    Hmm, that's odd, I have this problem but only noticed it after installing the Furniture Catalog addon. Anytime I typed /fur into chat to bring up the Furniture Catalog the mouse unlocks to the arrow cursor and continues doing so when I exit any ui screen, whether using Esc or Alt. I have to log off and back on again, reload ui doesn't work. I don't have that problem if I don't open up the addon at all when I'm playing.
    (Also I didn't change any of my keybinds recently)
    So maybe you installed an addon recently?
    Edited by Saoirse_Siobhan on June 24, 2017 4:31PM
    PC/EU DC
  • BurningSnowman
    Went through the Keybindings list, Toggle Cursor is set to . and I double checked to make sure Alt was not a second third or fourth binding for anything else

    No new addons. Updated one but that was at least three weeks before this started happening
  • Betheny
    Betheny
    ✭✭✭✭✭
    ✭✭
    Try setting exit menu control to some other key than ALT, and see if that other key now causes the problem (and if ALT key no longer brings up the cursor).
  • BurningSnowman
    Thanks for the suggestion, but that doesn't quite cover the whole issue. One thing I see I didn't emphasize was that the unlocking happens not just with use of the Alt key. I kill a mob, E to loot and say it has 3 items so I hit R to loot all. The cursor will also unlock at that point as well, without the Alt key ever being touched. This is really the part that is so annoying.
  • Betheny
    Betheny
    ✭✭✭✭✭
    ✭✭
    Turn on autoloot and see if cursor still unlocks.
  • Betheny
    Betheny
    ✭✭✭✭✭
    ✭✭
    Also just to check - you're not using windowed fullscreen are you?
  • Saoirse_Siobhan
    Saoirse_Siobhan
    ✭✭✭✭✭
    I kill a mob, E to loot and say it has 3 items so I hit R to loot all. The cursor will also unlock at that point as well, without the Alt key ever being touched. This is really the part that is so annoying.
    Betheny wrote: »
    Turn on autoloot and see if cursor still unlocks.

    Same problem here, but not with looting mobs/containers as I have autoloot turned on, but I don't have it turned on for stolen items since I want to pick and choose, so the cursor does stay unlocked after that. But again, this is only after using a certain addon. I am in windowed fullscreen so I'll check to see if that has anything to do with it.
    PC/EU DC
  • Betheny
    Betheny
    ✭✭✭✭✭
    ✭✭
    I kill a mob, E to loot and say it has 3 items so I hit R to loot all. The cursor will also unlock at that point as well, without the Alt key ever being touched. This is really the part that is so annoying.
    Betheny wrote: »
    Turn on autoloot and see if cursor still unlocks.

    Same problem here...I am in windowed fullscreen so I'll check to see if that has anything to do with it.

    Yeah try turning that off. Let me know if that fixes it.
  • BurningSnowman
    I do play in in Windowed Fullscreen because I use dual monitors and I'm frequently mousing to the second monitor for other stuff. On a different character I do use autoloot and that char has no issues. I may switch to that.

    Lastly, I bound the free cursor key from . to something else, logged out, rebound it back to . and I have not had the issue since. Who knows if that really fixed it, maybe it was a gnome and he got bored and left.
  • Betheny
    Betheny
    ✭✭✭✭✭
    ✭✭
    I do play in in Windowed Fullscreen because I use dual monitors and I'm frequently mousing to the second monitor for other stuff. On a different character I do use autoloot and that char has no issues. I may switch to that.

    Lastly, I bound the free cursor key from . to something else, logged out, rebound it back to . and I have not had the issue since. Who knows if that really fixed it, maybe it was a gnome and he got bored and left.

    Awesome, maybe rebinding it unbound it from the other thing that was secretly interfering with it.
  • Saoirse_Siobhan
    Saoirse_Siobhan
    ✭✭✭✭✭
    Betheny wrote: »
    I kill a mob, E to loot and say it has 3 items so I hit R to loot all. The cursor will also unlock at that point as well, without the Alt key ever being touched. This is really the part that is so annoying.
    Betheny wrote: »
    Turn on autoloot and see if cursor still unlocks.

    Same problem here...I am in windowed fullscreen so I'll check to see if that has anything to do with it.

    Yeah try turning that off. Let me know if that fixes it.
    I tried fullscreen but that didn't fix it. Same problem as before.
    Lastly, I bound the free cursor key from . to something else, logged out, rebound it back to . and I have not had the issue since. Who knows if that really fixed it, maybe it was a gnome and he got bored and left.
    I'm glad you found a fix, I'll have to try that and see if it works for me.

    Edited by Saoirse_Siobhan on June 26, 2017 5:51PM
    PC/EU DC
Sign In or Register to comment.