Zenimax and others. Possible fix for the 64bit client audio hiss/stutter/ambient sounds missing.

jpsgamingb14_ESO
jpsgamingb14_ESO
✭✭✭
Hello, Sorry a wall of text but I hope it helps.

First off. This was based on a system using an Nvidia GPU. Intel CPU and multiple sound cards were tested.

The fix for me appears to be Nvidia related. So if your system is AMD GPU based then this probably wont work.


If you arent very tech savvy please dont try this and I take no responsibility if you break things...you know a disclaimer.

This worked for me so I am hoping it will work for more people even though there is a big chance not everyone.

Only thing I noticed was there are still some NPC dialogue missing so I hope/assume this is a different issue.... but for the last few days I have not had a single audio hiss, random sound files playing, missing sound effects etc etc.

Over the last week I have been doing much research in my spare time and trying different things concerning the terrible sound issues that many are experiencing

I am using Windows 10 Pro as well if that matters.

I am using the Nvidia 360.00 drivers. The newest ones made all sorts of things go wrong system wide :( So I downgraded to this version.

Anyways, after multiple clean installs of drivers, trying 2 PCI sound cards as well as my on board sound card I may have found a fix.


I read this on some well known tech forums and so I gave it a go, it was not ESO specific but it worked for other people experiencing sound issues and low frame rates in many types of games.

There seems to be a conflict with some of the extra drivers Nvidia installs as a part of their package.

If you go to your control panel>Programs and Features (Or on Win 7 its add remove programs)>Scroll down to where you see all the nvidia drivers that are installed.

There are multiple ones.

Nvidia Graphics Driver (version XXX.XX)
Nvidia Physx System software
Nvidia Gefore Experience
Nvidia High definition audio drivers
Nvidia 3d vision driver
and a few others related to 3d vision and High definition cant remember all the names.

I right clicked and removed anything related to high definitioin audio since I have my own sound card, I removed the 3d vision since I dont have 3d monitor and I removed Geforece experience (Some people may want to keep this but I dont like it and it has issues of its own)

All I had left from Nvidia is the Nvidia Graphics Driver and the Physx driver. DONT DELETE THESE!

After this go into the device manager and under the sound video and game controllers tab you may see 2 or so listings called "High definition audio device" this is the Nvidia HID device that no longer has drivers. Right click them and choose disable.

You may also want to make sure windows is set to not automatically install missing drivers, I always have this turned off. Since I prefer control over what gets installed.

Restart your system.

For the past 3 days since doing this I have had perfect sound on the 64bit client. Where as the last 2 weeks my ears have been getting abused with many random hisses and screeching sounds appearing out of no where.

I hope this can help others like it helped me. A lot better playable experience.



  • WalkingLegacy
    WalkingLegacy
    ✭✭✭✭✭
    I don't use the extra Nvidia drivers and they're not on my PC.

    I have a Asus Sonar DG
    Edited by WalkingLegacy on March 28, 2016 3:02AM
  • jpsgamingb14_ESO
    jpsgamingb14_ESO
    ✭✭✭
    I don't use the extra Nvidia drivers and they're not on my PC.

    I have a Asus Sonar DG

    Well bummer sorry it didnt help. :(
  • IlgaBeck
    IlgaBeck
    ✭✭
    I just tried this and so far, so good. Really great job jpsgamingb14_ESO. I reckon you're onto something here.

    B)
  • jpsgamingb14_ESO
    jpsgamingb14_ESO
    ✭✭✭
    IlgaBeck wrote: »
    I just tried this and so far, so good. Really great job jpsgamingb14_ESO. I reckon you're onto something here.

    B)

    Awesome! Thank you!
  • Tinolyn
    Tinolyn
    ✭✭✭
    I'm sure it helps, but I doubt it gets rid of all of the problems. I never install anything but Nvidia drivers and Physx, and I have the audio and poor client performance issues. And yes, Win 10 pro.
  • zerosingularity
    zerosingularity
    ✭✭✭✭
    For the record, I have never installed the high def audio and 3d driver from nVidia on this machine, and have them fully disabled on windows 10 pro, and I still have sound/animation delays on the 64-bit client, as well as hissing. (They are infrequent though.) It is worth noting that I am using the nVidia beta drivers right now (364.51), cause the bugged driver was legit fail. I dunno if the beta driver still has some issues or not though, worth looking into.
    NA-PC

    Kaineth - Stamina Nightblade (Weakest Player Ever!)
    Elena Stormwood - Magicka Sorcerer (vMA no Death 12/21/15 Score 401148)
    Sheila Feyrondas - Magicka Dragonknight Tank (Frost staves are gonna be fun!)

    *Disclaimer* I fail at emotional communication, so assume what I say is NOT meant to be offensive.
  • Sirvandal
    Sirvandal
    ✭✭✭
    I did what you advised to do in Win 10. Squeeky sounds are gone. Thought in Cyrodill, combat sound still disapears,and effect sounds are not at the right moment, mostly after an attack some sort weird delay. Also sometimes a weird mix of sound effects.
  • kawazu874b16_ESO
    I'm on Win 7, have removed 3d vision and nvidia audio drivers from install/update a very long time ago and had problems with the last 64 bits client immediately after having loaded a character (repeated sound) in deshaan (the blacksmith noise).
    I'm playing with 32 bits version since.
  • IlgaBeck
    IlgaBeck
    ✭✭
    I had a good long test session last night and I still have no sound issues on the 64 bit client after following the instructions in the OP.

    Some issues like occassional very low (slide show) fps remain but that is a separate issue to what is being adressed by this workaround. I'm on W7 Pro and it took a bit of messing around to stop Windows re-installing the Nvidia High Definition Audio Device every time I restarted the PC. The only way I could find to stop it was to disable Windows' auto-installation of drivers through the Group Policy editor as described here:

    https://support.microsoft.com/en-us/kb/2500967

    which isn't really ideal.

    Maybe I'm missing an easier solution but just disabling the thing through Device Manager and uninstalling the drivers didn't work for me. Hopefully, the info presented by jpsgamingb14_ESO will give the devs a bit of a heads-up as to where the problem is anyway.

    A big thumbs-up from me jpsgamingb14_ESO.

  • jpsgamingb14_ESO
    jpsgamingb14_ESO
    ✭✭✭
    IlgaBeck wrote: »
    I had a good long test session last night and I still have no sound issues on the 64 bit client after following the instructions in the OP.

    Some issues like occassional very low (slide show) fps remain but that is a separate issue to what is being adressed by this workaround. I'm on W7 Pro and it took a bit of messing around to stop Windows re-installing the Nvidia High Definition Audio Device every time I restarted the PC. The only way I could find to stop it was to disable Windows' auto-installation of drivers through the Group Policy editor as described here:

    https://support.microsoft.com/en-us/kb/2500967

    which isn't really ideal.

    Maybe I'm missing an easier solution but just disabling the thing through Device Manager and uninstalling the drivers didn't work for me. Hopefully, the info presented by jpsgamingb14_ESO will give the devs a bit of a heads-up as to where the problem is anyway.

    A big thumbs-up from me jpsgamingb14_ESO.

    Heya,

    It may be worded a bit differently on Windows 7 but it is close to the same thing for disabling auto downloads of drivers on windows.

    If you Right click MY PC in your start menu> Choose properties>Click Advanced system settings on the left> Choose the hardware Tab> Choose the device installation settings option> Disable or choose not to have windows automatically donwload and install drivers.

    Hope this helps.

    Also make sure under the device manager sound audio and game controllers tab you are disabling the 2 or so High definition audio devices that have no drivers.

    Edited by jpsgamingb14_ESO on March 31, 2016 9:09PM
  • jpsgamingb14_ESO
    jpsgamingb14_ESO
    ✭✭✭
    Well crap...

    I have been gone all week but got home today and updated the client to the latest patch.

    All the sound issues are back.

    Dang it Zenimax can I have the last build back lol?

    So I guess all this just gone blown out the water for me :(
  • Sirvandal
    Sirvandal
    ✭✭✭
    Indeed sound is serious F#$%#$d up. Any word from a dev please when a fix is incomming?
    Edited by Sirvandal on April 1, 2016 7:08AM
  • iClustaFlux
    iClustaFlux
    Soul Shriven
    Killing the "Ambience Volume" seems to have stopped the horrendous intermittent hissing noise issue for me.

    Of course this isn't any real fix, but it allows me to play comfortably with my headset on again.

    As for the rest of the odd sounds, it seems to me as though there might be a problem with radius/distance from sound sources. This idea has been further bolstered by witnessing fights at the edge of my viewing distance, yet hearing some of the sound effects as if they were right beside me.

    And of course hearing the squeaks and squeals of every rodent in nirn.

    I'm sure other people may have passed similar comments, but just in case, perhaps mine may be of some help to the audio team if passed along @ZOS_CaseyCoffman
  • ZOS_CaseyCoffman
    ZOS_CaseyCoffman
    ✭✭✭
    Killing the "Ambience Volume" seems to have stopped the horrendous intermittent hissing noise issue for me.

    Of course this isn't any real fix, but it allows me to play comfortably with my headset on again.

    As for the rest of the odd sounds, it seems to me as though there might be a problem with radius/distance from sound sources. This idea has been further bolstered by witnessing fights at the edge of my viewing distance, yet hearing some of the sound effects as if they were right beside me.

    And of course hearing the squeaks and squeals of every rodent in nirn.

    I'm sure other people may have passed similar comments, but just in case, perhaps mine may be of some help to the audio team if passed along @ZOS_CaseyCoffman

    Hi @iClustaFlux we are aware of that odd little behavior, but thank you for further confirming it for us :smile:
    Casey Coffman
    Audio / Voiceover Lead Analyst - The Elder Scrolls Online
    Staff Post
  • Katsibrokos
    Katsibrokos
    ✭✭
    Did what you said a couple of hours ago. No more problems with x64 client. No weird sounds, no crashes, not anything, at least until now.
    Thank you very much m8 :)
    Wood Elf Templar
  • jpsgamingb14_ESO
    jpsgamingb14_ESO
    ✭✭✭
    You know I noticed something else.

    I was getting sound issues again last night but it was while I was watching a movie on Chrome browser on my other monitor. I tend to have things like twitch tv or vaghn tv playing while playing ESO.

    I closed the other window that was playing these and sound issues as far as the static hissing didn't happen anymore for a few hours while playing.

    I did start to notice again the crazy ambient glitches showing up after patching the game with the latest patch from earlier this week.

    It does not occur as much anymore but happens on occasion after the patch this week. Last week was great...but not anymore.
  • Gargath
    Gargath
    ✭✭✭✭✭
    I will not mess with my PC music settings, I prefer to wait for global patch from ZOS, that should repair all those annoying hisses, diabolic laughs and other weird sounds in my game. It's not my PC which should be blamed and repaired. It's the game. Please ZOS use those tips above and implement into new sound related patch.
    It's not a surprise, that only ESO is making those sounds, when all other my games are not doing them.
    PC EU (PL): 14 characters. Member of Priests of Hircine Werewolf Guild. In ESO since 06.08.2015. CP930+.
  • ZOS_GregoryV
    Greetings all,

    We are glad to see everyone coming together to discuss the issues you are each having with the 64-bit client. While we have this looked into, we would like to request that this thread be kept civil and constructive as we have recently had to remove so rather disruptive posts. Thank you for your patience and understanding.
    [b[Abusive Language and Disruptive Behavior[/b]: We do not tolerate abusive language or disruptive behavior on our forums. This goes for abusive and disruptive comments and behavior that are directed at a ZeniMax Online employee and ESO community member, alike. Please remember to be respectful and constructive at all times on our forums, and help us maintain a friendly and welcoming atmosphere for all.
    The Elder Scrolls Online: Tamriel Unlimited - ZeniMax Online Studios
    Forum Rules | Code of Conduct | Terms of Service | Home Page | Help Site
    Staff Post
  • Leucius
    Leucius
    I use Win 7 Home Premium with an AMD R9 380 4gb GPU. I seem to have fixed the hissing and popping by going to properties for my sound output (little speaker in the lower right corner of the screen > right click > playback devices > choose sound device > properties) then going to enhancements tab and enabling "Loudness equalizer" - I've tested this over a few nights. Turned off, sound problems present immediately. Turned on, the loudness equalizer keeps this from happening.

    I just started having problems recently. Seems the fps dips were fixed and the audio issues began :'( However, this >might< fix the issue for some. No promises, though.
    -Leucius
  • pema
    pema
    ✭✭✭
    Running even older drivers from nvidea as the newer ones break ESO totaly.
    Freezing the screen and only restarting it fixes it.

    About this suggestion I only have my used devices.
    Headset (razer Kraken) and my HD soundcard (used when headset aint on)

    I'm Win 10 pro 64bit.
    I'm not using the client with this sound bug, it's such a nuance when loud sounds go on all the time.
    Never had this with 32 bit client, not sure what the difference is and why it's such a hard thing to track, but I'm not a programmer.
    Officer of Alith Legion
    Ebonheart Pact guild, EU server.
    Check out our site alithlegion.com
  • daemonios
    daemonios
    ✭✭✭✭✭
    ✭✭
    I don't think the nVidia HD audio replaces your on-board or discrete soundcard. I remember I had a problem with it once and lost sound from my TV. My living room desktop is hooked up to my TV and I have no other speakers, so the audio is routed via the HDMI cable, and I think that's what nVidia HD Audio takes care of. I'll bear with the occasional hisses until there's a more workable (for me) solution.
  • Martinus72
    Martinus72
    ✭✭✭
    I never allowed anything but the driver and physx to install so this is not what is causing this issue.
  • Dahveed
    Dahveed
    ✭✭✭✭
    I can confirm (tentatively) that these fixes work, or at least help.

    Using the 64 bit client, I get the reported issues almost immediately (within 10 seconds I can tell the bugs are there). Static noises, random combat music, random ambient sounds amplified, etc.

    Using your suggested fixes, I just ran around for about 5 minutes and didn't get a single sound glitch.

    So it seems to be working!


    Kudos for sharing your information, jpsgaming! Thank you!


    EDIT - Unfortunately the fixes only lessen the frequency of the glitches somewhat. I just played a few minutes on the 64-bit client and the problem came back. Reverting to 32-bit again :(
    Edited by Dahveed on June 4, 2016 5:15AM
  • MickeyBN
    MickeyBN
    ✭✭✭✭
    Can confirm this worked for me. Been playing for 5 hours and no hiccups.

    For now anyway, I'm hoping it stays fixed.
    Vaelerys Nightborne - Bosmer Nightblade PC NA
  • khenykeb17_ESO
    khenykeb17_ESO
    Soul Shriven
    Thank you @jpsgamingb14_ESO. Worked forme too!
Sign In or Register to comment.