Maintenance for the week of June 17:
· [COMPLETE] PC/Mac: NA and EU megaservers for patch maintenance – June 17, 4:00AM EDT (8:00 UTC) – 8:00AM EDT (12:00 UTC)
· [COMPLETE] ESO Store and Account System for maintenance – June 17, 10:00AM EDT (14:00 UTC) – 12:00PM EDT (16:00 UTC)
· Xbox One: NA and EU megaservers for patch maintenance – June 19, 6:00AM EDT (10:00 UTC) – 10:00AM EDT (14:00 UTC)
· PlayStation®4: NA and EU megaservers for patch maintenance – June 19, 6:00AM EDT (10:00 UTC) – 12:00PM EDT (16:00 UTC)

Requesting character load

MagnusArmstrong
MagnusArmstrong
Soul Shriven
Hello, I'm having a lot of problems trying to log into any character because of the dreadful "Requesting character load" message. About 1 time out of 10 or 20 (I really don't want to keep count) I can log into a character, only to be thrown back to the main menu with the helpful "Error, try again later" message whenever I hit a load screen. But once I'm in the game, everything works perfectly (besides the not moving from the zone). I tried countless solutions (deleted SavedVariables file, allow exception/disable firewall, open ports, modified hosts file to use many different IPs, etc.). The only thing that appears to have an effect is lowering the graphics to a minimum before a loading screen, but it almost never works. Support asked me to contact my ISP and then stopped answering when I provided evidence that it's not a connection issue (at least not on my side). Is there any standarized solution for the "Requesting character load" message or the kicked back to the main menu when loading screen issues?

Thanks!
  • ZOS_MollyH
    Hi @MagnusArmstrong !

    Can we please have your ticket number in regards to this issue? Thank you!
    The Elder Scrolls Online: Tamriel Unlimited - ZeniMax Online Studios
    Forum Rules | Code of Conduct | Terms of Service | Home Page | Help Site
    Staff Post
  • MagnusArmstrong
    MagnusArmstrong
    Soul Shriven
    Hello @ZOS_MollyH , my ticket number is 150725-003649. Thanks for your help! As I said in a previous post and informed in the ticket, I've since then tried using battleping with immediate success for both issues. However I don't really consider it a solution because I need to pay a monthly fee to use the game.

  • KingAce0075
    Same thing is happening to me and I have tried everything with no success!
Sign In or Register to comment.