Maintenance for the week of January 27:
· [COMPLETE] PC/Mac: NA and EU megaservers for patch maintenance – January 27,  4:00AM EST (9:00 UTC) - 8:00AM EST (13:00 UTC)
· [COMPLETE] ESO Website for maintenance – January 27, 1:00PM EST (18:00 UTC) - 4:00PM EST (21:00 UTC)

When launching ESO, game launches on my main monitor, but mouse cursor is on the 2nd monitor

gothaggis
gothaggis
Soul Shriven
I haven't played ESO in awhile, so figured I'd give it a shot again, however I am currently unable to play. I have 2 monitors (different resolutions, my 2nd monitor is twisted so its vertical) - running Windows 10 and latest nvidia drivers (980ti). When I launch ESO, as soon as it gets to the character selection screen, I can't select anything...but I see my mouse cursor on my 2nd monitor moving around - there is no cursor on the monitor the game is running on. Any ideas how to fix it? It makes playing ESO impossible right now.
  • gothaggis
    gothaggis
    Soul Shriven
    a bit more information - if I click any of the mouse buttons, the game minimizes - if I try to maximize it, it then sends the game window to the 2nd monitor (the one I don't want to play on) and the mouse works...because its on the 2nd monitor. this is all very strange.

    I also noticed if the game is running on monitor #1 (the one I want to ) - if I move the mouse cursor that is on the 2nd monitor to about halfway up the screen, it selects the 'delete character' button - the help text pops up.
  • FriedEggSandwich
    FriedEggSandwich
    ✭✭✭✭✭
    No idea if this will help but you could try switching between full screen mode and full screen (windowed) mode in the settings. Both modes should confine the mouse to your active screen but switching between them might reset it. Also check which screen you have set as main in windows settings. Failing that just disable your second screen while gaming, which you've probably already done in order to play.
    PC | EU
  • gothaggis
    gothaggis
    Soul Shriven
    yeah its strange, windowed mode does work - however it will still show the taskbar at the bottom of the screen...so if I start up the game in windowed mode, I can then switch the game to fullscreen and everything is great. of course I have to remember to set it back to windowed mode before quitting ( or use geforce experience) or else i have the fullscreen problem again. its very annoying.
Sign In or Register to comment.