Maintenance for the week of January 18:
• PC/Mac: No maintenance – January 18
• PC/Mac: NA and EU megaservers for maintenance – January 19, 4:00AM EST (9:00 UTC) - 8:00AM EST (13:00 UTC)
• Xbox One: NA and EU megaservers for maintenance– January 21, 6:00AM EST (11:00 UTC) - 10:00AM EST (15:00 UTC)
• PlayStation®4: NA and EU megaservers for maintenance – January 21, 6:00AM EST (11:00 UTC) - 10:00AM EST (15:00 UTC)

Unable to login to with Edge on Windows 10

Just got a new Windows 10 PC (previously using Windows 7 on old PC). So, I need to download and install ESO of course. Except that my account login doesn't do anything. I keep being prompted for the login on ESO's website.
Here's the kicker - it works fine if I use Chrome on the new Windows 10 system. So it's some sort of incompatibility between the Edge (Microsoft) browser and the ESO website.

Can anyone please advise what Edge browser settings changes are required for this to work? I'm new to Win10.
PS: no ticket yet. I'm not ingame until the download completes - in about a day or so, due to a slow internet connection...
  • Pyr0xyrecuprotite
    PPS: I don't get any error message at all when the login fails to work when using Edge.... Just back to the login screen.
  • Biafra
    Soul Shriven
    I am able to log in using Edge without difficulty. Here are a couple tidbits to try with Edge:

    1.) Make sure you log in using your In-game UserID and the correct Password.
    2.) Click More Actions (the icon with three dots), then select Settings in the drop down to open the settings drawer. Scroll down the drawer and click the View Advanced Settings button. In there, make sure that the Use Adobe Flash Player switch is enabled (slid to the right), and the drop down menu for cookies (you may have to scroll down for this) is set to "Don't Block Cookies". Close and relaunch the browser.
    3.) Clear Edge's cache and cookies and try logging in again.
    4.) If that fails, it may just be Edge itself that sucks on your PC. Switch to a proper browser like you did with Chrome, or if you must use Microsoft browsers, click More Actions, then click Open in Internet Explorer.

    Hope this helps.
  • Pyr0xyrecuprotite
    Weird, ok to close this thread. I just tested again, and it's working now. No settings changes required, that I know of. Maybe something else weird going on at the time when I was having problems?
Sign In or Register to comment.