Maintenance for the week of June 17:
• PC/Mac: NA and EU megaservers for patch maintenance – June 17, 4:00AM EDT (8:00 UTC) – 8:00AM EDT (12:00 UTC)
• ESO Store and Account System for maintenance – June 17, 10:00AM EDT (14:00 UTC) – 12:00PM EDT (16:00 UTC)
• Xbox One: NA and EU megaservers for patch maintenance – June 19, 6:00AM EDT (10:00 UTC) – 10:00AM EDT (14:00 UTC)
• PlayStation®4: NA and EU megaservers for patch maintenance – June 19, 6:00AM EDT (10:00 UTC) – 12:00PM EDT (16:00 UTC)

Textures and loading problem please help

Soul Shriven
A few days ago i bought ESO: Imperial Edition. i was so happy but problems began to appear. First thing: Downloading time, it took me 72 hours!
But ok, 72 later FINALLY installed!!! yay!!
The second problem appeared after log in the game. Very long time of loading, it took me 2 hours to enter character creation
When i entered character creation i saw nothing, most of textures just disappeared. just two or one stones and a skeleton. Nothing more :neutral:
So i selected random character creation and entered the game
Aaaaaaand nothing. no character, no textures, just interface. I really dont know what to do. ive tried everything that is:
downloaded service pack 3 for windows xp
updated adobe flash player
upadated java
repaired game files
updated direct x
updated graphics card
cleaned up the computer by WinThruster
Skyrim worked on my computer wonderfully on very high quality with no bugs, but ESO...
Please help!!!
  • Ranique
    I assume you match the system requirements?
    Operating System: Windows XP 32-bit
    Processor: Dual Core 2.0GHz or equivalent processor
    Memory: 2GB System RAM
    Hard Disk Space: 60GB free HDD space
    Video Card: DirectX 9.0 compliant video card with 512MB of RAM (NVIDIA® GeForce® 8800 / ATI Radeon™ 2600 or better)
    Sound: DirectX compatible sound card

    If thats the case I suspect something something slowing down the connection severly. I suggest enabling ESO in the firewall and enabling ports on your router.

    This post by ZOS should help:

    -edit: after NVidea experience updating today (on windows10 technical preview). The optimized settings didn't work and produced the exact same issue. After resetting to default in the game it worked again. It's a long shot, but if you used geforce epxerience before you started to play to optimize the settings, you might want to hit default in game. (on the character select screen you can click settings, then x for default)
    Edited by Ranique on March 30, 2015 7:16PM
    Through me you pass into the city of woe:
    Through me you pass into eternal pain:
    Through me among the people lost for aye.

    PC player - EU
Sign In or Register to comment.