Maintenance for the week of August 19:
· [IN PROGRESS] PC/Mac: NA and EU megaservers for patch maintenance – August 23,  4:00AM EDT (8:00 UTC) - 8:00AM EDT (12:00 UTC)

iMac 5k - settings suggestions?

tfraley
tfraley
Good day guys,

I've just moved from an 08MacPro to a new 5k iMac.

I love the new iMac, however when trying to play last night I spent 3hours testing and testing trying to find the best settings.
I don't play much, but have been supporting ESO since the beginning I pre-ordered and started playing on launch. Even after hearing about the changes I still wanted to continue to support after the free to play changes.

With that said I really feel ESO never grasped and took ownership of the Mac client, it's never felt solid

With that said I would of thought the new iMac would handle the game better but I was mistaken.

Does anyone have any suggestions on settings with the new patch yesterday?

I've gotten the game after 3 hrs or so to get a steady 50+ fps but things still feel choppy

With my old MacPro I was only getting 30fps or so but felt smooth.


All comments & suggestions welcome.
  • chris.dillman
    chris.dillman
    ✭✭✭
    Hi tfraley

    Is the MacPro and iMac running the same versions of the OS?

    Are the machines both connected to the internet the same way? ( Wifi, Cable etc)

    Can you describe what the un smoothness looks like?

    If you turn the texture settings down to low does the game get smoother?





    -- ESO -- Lead Mac Programmer...
    Staff Post
  • Attorneyatlawl
    Attorneyatlawl
    Community Ambassador
    @Tfraley, to be completely honest the 5k imac is very much underpowered for handling any modern and moderately demanding (or more) game at its native resolution since it only has a mobile equivalent of a radeon r9 290. 5k is literally around 70% more pixels than 4k is, to give an idea here. Your best options, in my opinion, would be:

    -I'd try this for sure before anything else: in your ESO "usersettings.ini" file, change the line GPUSmoothingFrames = 10, to a 0 (zero) instead of 10 (ten). That setting asks the client to do a larger-than-normal frame buffering amount, which if your framerate is very high won't be too noticeable except for the added input lag, but if you're on the cusp like you are, it can result in a very unpleasant experience. Most games do double or triple buffering which is 2 or 3 respectively.
    -Enable subsampling to "medium" inside of ESO. It'll still look very nice but should ensure you maintain a strong framerate by rendering at a lower resolution than the 5k native and upscaling it.
    -Lowering your settings significantly is another option.

    Good luck and shoot an update later on :).
    Edited by Attorneyatlawl on March 4, 2015 8:39PM

    -First-Wave Closed Beta Tester of the Psijic Order, aka the 0.016 percent. =P
    Exploits suck. Don't blame just the game, blame the players abusing them!

    -Playing since July 2013, back when we had a killspam channel in Cyrodiil and the lands of Tamriel were roamed by dinosaurs.
    -Order of Mundus, Nightfighters, LoM, and Mostly Harmless founding member, "DPS: We Deliver."
    ________________
    -In-game mains abound with "Nerf" in their name. As I am asked occasionally, I do not play on anything but the PC NA Megaserver at this time.
  • tfraley
    tfraley
    thanks for getting back to me so quickly

    Starting with @chris.dillman question.

    Yes they are both runing the same version of Yosemite.
    They are both on the same internaet using the same cabling. Ie I replaced the Macpro with the iMac.

    @Attorneyatlawl
    Great feed back and I think you are on to what I was seeing.
    Yha I understand the iMac is not a gamming rig but I require it for my daily work, Wasn't expecting it to rock the game big time but being able to play it respeciably would be nice.

    As for the resolution anything other than native just looks awful and jaggad or blurry.

    I was playing with "subsampling" this morning and this seems to be the only thing that is making a difference.
    Even lowering the shadow texture to low doesn't make as big of a difference as subsampling does going high to medium

    I wasn't aware of the "GPUSmoothingFrames" tweak I will give this a try later and report back.
    I will also report back with some screenshots
  • tfraley
    tfraley
    OK,

    Here is some more info.

    First the description of jittery.

    Say I am running through town, it doesn't feel smooth.
    It's like he is skiping.
    ie background moves like every second (I am probably over exadurating but its how it feels)

    As it currently stands I get anywhere from 14fps to 45fps its all over the place.

    Here is a copy and past of my current config.

    SET MouseRawInput "1"
    SET MouseSensitivityFirstPerson "0.50000000"
    SET MouseSensitivityThirdPerson "1.00000000"
    SET MouseSmoothing "0"
    SET InvertMouseWheel "1"
    SET InvertMouseY "1"
    SET InvertMouseX "1"
    SET MAGELIGHT_LIGHTS_VISIBLE "1"
    SET PFX_SUPPRESS_DISTANCE_v2 "46.00000000"
    SET PFX_GLOBAL_MAXIMUM "831"
    SET MULTI_GPU_CHECK "1"
    SET CachedRLREnabled "0"
    SET CachedReflectionResolution "0"
    SET CachedShadowFiltering "3"
    SET ScreenshotFormat.2 "PNG"
    SET PregameGammaCheckEnabled "0"
    SET HardwareCheckEnabled.3 "0"
    SET SUB_SAMPLING "2"
    SET REFLECTION_QUALITY_v3 "0"
    SET PARTICLE_DENSITY "2"
    SET HIGH_RESOLUTION_SHADOWS "1"
    SET SHADOWS "1"
    SET GAMMA_ADJUSTMENT "123"
    SET VIEW_DISTANCE "1.00000000"
    SET GPUSmoothingFrames “10"
    SET MIP_LOAD_SKIP_LEVELS "1"
    SET RAIN_WETNESS "1"
    SET LENS_FLARE "1"
    SET GOD_RAYS_v2 "1"
    SET ANTI_ALIASING_v2 "0"
    SET AMBIENT_OCCLUSION "1"
    SET COLOR_GRADING_v1 "0"
    SET BLOOM "1"
    SET DEPTH_OF_FIELD "1"
    SET TONE_MAPPING "1"
    SET COLOR_CORRECTION "1"
    SET SOFT_ALPHA "1"
    SET DISTORTION "1"
    SET CHARACTER_LIGHTING "1"
    SET DIFFUSE_2_MAPS "1"
    SET DETAIL_MAPS "1"
    SET NORMAL_MAPS "1"
    SET SPECULAR_MAPS "1"
    SET CLUTTER_2D "1"
    SET SIMPLE_SHADERS "0"
    SET WATER_FOAM "1"
    SET VSYNC_INTERVAL "1"
    SET VSYNC "0"
    SET MAX_ANISOTROPY "2"
    SET PreferMaximizedWindow "0"
    SET PreferExclusiveFullscreen "1"
    SET FULLSCREEN_v5 "2"
    SET FullscreenHeight "1440"
    SET FullscreenWidth "2560"
    SET WindowedHeight "1330"
    SET WindowedWidth "2560"
    SET FOVChangesAllowed "1"
    SET AgreedToPEGI "1"
    SET VoiceChatAutoJoinChannels.2 "0"
    SET VoiceChatEnabled.3 "1"
    SET LuaMemoryLimitMB "64"
    SET GamepadSensitivityFirstPerson.2 "0.72000003"
    SET GamepadSensitivityThirdPerson.2 "0.85000002"
    SET GamepadInvertX "0"
    SET GamepadInvertY "0"
    SET GamepadVibrationEnabled "1"
    SET SOUND_ENABLED "1"
    SET FOOTSTEPS_VOLUME "50.00000000"
    SET FOOTSTEPS_ENABLED "1"
    SET SPEAKER_SETUP "0"
    SET BACKGROUND_AUDIO "1"
    SET VO_VOLUME "92.00000000"
    SET VO_ENABLED "1"
    SET UI_VOLUME "70.00000000"
    SET UI_ENABLED "1"
    SET AMBIENT_VOLUME "70.00000000"
    SET AMBIENT_ENABLED "1"
    SET SFX_VOLUME "70.00000000"
    SET SFX_ENABLED "1"
    SET MUSIC_VOLUME "85.00000000"
    SET MUSIC_ENABLED "1"
    SET AUDIO_VOLUME "67.00000000"
    SET AUDIO_ENABLED "1"
    SET TooltipFilter "-1"
    SET TooltipNumOptions "2"
    SET Language.2 "en"
    SET GraphicsDriver.7 "OPENGL"
    SET PatchDataPath "game:/GameData/"
    SET CacheDataPath "machine:/Cache/"
    SET ViewedAddOnEULAVersion "5"
    SET AcceptedAddOnEULAVersion "5"
    SET AcceptedEULAVersion "3"
    SET DirectionalDamageIndictorVisibleInThirdPerson "0"
    SET CameraFramingTransitionEnabled "1"
    SET SkipPregameVideos "1"
    SET HasPlayedPregameVideo "1"
    SET RangedKillCamera "0"
    SET PlayerKillCamera "1"
    SET LastMonsterKillCamera "1"
    SET MinFrameTime.2 "0.01000000"
    SET ParticlesEnabled "1"
    SET RequestedNumJobThreads "-1"
    SET RequestedNumWorkerThreads "-1"
    SET FreeUnusedGrannyFileSections.2 "0"
    SET IsTrustedMachine "1"
    SET RememberAccountName "1"
    SET AccountName "XXXXXXXXX"
    SET LastRealm "NA Megaserver"
    SET CustomUIScale "0.80813199"
    SET UseCustomUIScale.2 "1"
    SET RollDodgeDoubleTapEnabled "1"
    SET RollDodgeDoubleTapTimeWindow.2 "185"
    SET ClampGroundTargetEnabled "1"
    SET MonsterTellsEnabled "1"
    SET CameraZoomDistancesSynced "1"
    SET SiegeCameraZoomDistance "6.00000000"
    SET WeaponsOutCameraZoomDistance "5.00000000"
    SET WeaponsSheathedCameraZoomDistance "5.00000000"
    SET MaxNetworkWriteBuffer "10485760"
    SET MaxNetworkReadBuffer "10485760"
  • chris.dillman
    chris.dillman
    ✭✭✭
    tfraley,

    Data loading in town seems to cause the FPS stutters.
    It seems much worse on some Macs or on 10.10
    We have old test mac pros that are smooth here running 10.7.

    Turning settings down to say medium tends to help.
    Maybe low the view distance could help also.

    Booth would adjust the amount of data being loaded in.

    -- ESO -- Lead Mac Programmer...
    Staff Post
Sign In or Register to comment.